Drag Attachments to a Finder-Window isnt working

RESOLVED FIXED in Thunderbird 10.0

Status

Thunderbird
OS Integration
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Martin Mueller, Assigned: standard8)

Tracking

Trunk
Thunderbird 10.0
x86
Mac OS X

Thunderbird Tracking Flags

(thunderbird8+ fixed, thunderbird9+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_1) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/14.0.835.109 Safari/535.1

Steps to reproduce:

I drag an Attachment from the "preview"-section to a MacOS X 10.7.1-Finder-Window.


Actual results:

I drag an Attachment from the "preview"-section to a MacOS X 10.7.1-Finder-Window. Instead of the right file, I get a file called "undefined". The filesize is of "undefined" is exactly the right size of the droped file. 

If i look with text-wrangler into the file, the data are the requested. TB doesnt name the dragged file correctly.


Expected results:

The file appears in the finder-window, but the filename isnt given correctly.
xref 515164

Error console is empty when this happens. Confirming with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:8.0a2) Gecko/20110926 Thunderbird/8.0a2 - I didn't find duplicates.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 7 → Trunk
(Assignee)

Comment 2

7 years ago
Created attachment 563339 [details] [diff] [review]
The fix

This fixes it for me - there's an error on the text console with javascript strict mode on staying that attachment.displayName is undefined.

If you look at the CreateAttachmentTransferData this is using name || displayName as well.
Assignee: nobody → mbanner
Status: NEW → ASSIGNED
(Assignee)

Updated

7 years ago
Attachment #563339 - Flags: review?(squibblyflabbetydoo)

Comment 3

7 years ago
Comment on attachment 563339 [details] [diff] [review]
The fix

Review of attachment 563339 [details] [diff] [review]:
-----------------------------------------------------------------

Assuming you've tested that this works (I build on Linux where drag-and-drop to the desktop is broken at a much lower level), it looks good to me.
Attachment #563339 - Flags: review?(squibblyflabbetydoo) → review+
Duplicate of this bug: 690743
Duplicate of this bug: 690403
(Assignee)

Updated

7 years ago
tracking-thunderbird8: --- → +
tracking-thunderbird9: --- → +
(Assignee)

Comment 6

7 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/c24fbeb1f0d4
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 10.0
(Assignee)

Updated

7 years ago
Attachment #563339 - Flags: approval-comm-beta+
Attachment #563339 - Flags: approval-comm-aurora+
(Assignee)

Comment 7

7 years ago
Checked into branches:

http://hg.mozilla.org/releases/comm-aurora/rev/98b40acdbdea
http://hg.mozilla.org/releases/comm-beta/rev/bd34f5b021b2
status-thunderbird8: --- → fixed
status-thunderbird9: --- → fixed

Updated

7 years ago
Duplicate of this bug: 694569
(Assignee)

Updated

7 years ago
Duplicate of this bug: 691269

Updated

7 years ago
Duplicate of this bug: 692390

Updated

7 years ago
Duplicate of this bug: 699455
You need to log in before you can comment on or make changes to this bug.