Closed Bug 688953 Opened 8 years ago Closed 8 years ago

Create/Update 2.5 Release Notes

Categories

(SeaMonkey :: Website, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Callek, Assigned: InvisibleSmiley)

References

()

Details

+++ This bug was initially created as a clone of Bug #684651 +++

+++ This bug was initially created as a clone of Bug #674445 +++

SeaMonkey 2.5 Beta 1 builds will be built on Tuesday, with a likely go to build on late Thursday or Early Friday.

These relnotes can be (begun to be) prepared ahead of the release date, but need to be out by our first beta release.
initial version

cvs commit: Examining src/releases/seamonkey2.5
RCS file: /www/seamonkeyproject-org/src/releases/seamonkey2.5/changes.en.html,v
done
Checking in src/releases/seamonkey2.5/changes.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/changes.en.html,v  <--  changes.en.html
initial revision: 1.1
done
RCS file: /www/seamonkeyproject-org/src/releases/seamonkey2.5/index.en.html,v
done
Checking in src/releases/seamonkey2.5/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/index.en.html,v  <--  index.en.html
initial revision: 1.1
done
RCS file: /www/seamonkeyproject-org/src/releases/seamonkey2.5/relnote.var,v
done
Checking in src/releases/seamonkey2.5/relnote.var;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/relnote.var,v  <--  relnote.var
initial revision: 1.1
done
Assignee: nobody → jh
Status: NEW → ASSIGNED
JFTR, bug 670532 and bug 667299. But I guess you already have them on your list.
Added bug 670532 and bug 667299 to Changes page

Checking in changes.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/changes.en.html,v  <--  changes.en.html
new revision: 1.2; previous revision: 1.1
done

Note: Until now I didn't really have a list, but I created a publicly available Bugzilla Saved Search called "SM relnote 1y" now that includes all SM bugs with the relnote keyword that have been changed within one year's time. Any help either reducing this list by removing unneeded "relnote" keywords or suggestions on how to change the Saved Search are appreciated.
Re bug 621823 comment #42, I've seen that you added this information to the "What's New" page, "Fixes in beta 1" heading. That should be fine, but it refers to bug 672146 which is a related but different issue (default zoom in new windows or on Ctrl+0 didn't work if 100% wasn't within the specified zoom.min/maxPercent range).
(In reply to rsx11m from comment #4)
> Re bug 621823 comment #42, I've seen that you added this information to the
> "What's New" page, "Fixes in beta 1" heading. That should be fine

Right. I decided I'd rather have the upgrade info with the summary and bug number rather than adding a Known Issue (might have to revisit that for subsequent relnotes). In the current form it doesn't refer to upgrading explicitly but I guess that's the common case and resetting in a new profile doesn't hurt either. ;-)

> but it refers to bug 672146 which is a related but different issue

Oops, corrected:

Updated bug number for View/Zoom

Checking in src/releases/seamonkey2.5/changes.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/changes.en.html,v  <--  changes.en.html
new revision: 1.3; previous revision: 1.2
done
Removed Firebug Known Issue (fixed with current stable FB 1.8)

Checking in src/releases/seamonkey2.5/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/index.en.html,v  <--  index.en.html
new revision: 1.2; previous revision: 1.1
done
Added some platform changes [1]
Added bookmarklets bug 688841 to Known Issues and removed en-GB/es-AR Help issue

Checking in src/releases/seamonkey2.5/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/index.en.html,v  <--  index.en.html
new revision: 1.5; previous revision: 1.4
done

[1] based on <http://blog.mozilla.com/futurereleases/2011/08/19/firefoxaurora8/>, excluding HTML5 Native Right Click Menu Support which AFAIK we're missing at least theme changes for (maybe more).
Blocks: SM2.5b2
Corrected b2 changes (bug 680802 instead of bug 690267 which had already been in b1)
Changed relnote version to Beta 2 (also fixes download link)

Checking in src/releases/seamonkey2.5/changes.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/changes.en.html,v  <--  changes.en.html
new revision: 1.5; previous revision: 1.4
done
Checking in src/releases/seamonkey2.5/relnote.var;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/relnote.var,v  <--  relnote.var
new revision: 1.2; previous revision: 1.1
done
Blocks: SM2.5b3
Blocks: SM2.5b4
added bug 662907 (MailNews feed reader noscript display issue) to Known Issues

Checking in seamonkey2.4/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.4/index.en.html,v  <--  index.en.html
new revision: 1.8; previous revision: 1.7
done
Checking in seamonkey2.5/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/index.en.html,v  <--  index.en.html
new revision: 1.8; previous revision: 1.7
done
I'm missing an entry for bug 599731, "Recently Closed Tabs and Recently Closed Windows have been moved from File to the Go menu for consistency" (browser component).
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #3)
> Note: Until now I didn't really have a list, but I created a publicly
> available Bugzilla Saved Search called "SM relnote 1y" now that includes all
> SM bugs with the relnote keyword that have been changed within one year's
> time. Any help either reducing this list by removing unneeded "relnote"
> keywords or suggestions on how to change the Saved Search are appreciated.

You could use the Milestone field in your search, no?
Blocks: SM2.6b1
No longer blocks: SM2.6b1
added bug 599731 / bug 702297 to Known Issues

Checking in seamonkey2.5/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/index.en.html,v  <--  index.en.html
new revision: 1.10; previous revision: 1.9
done
(In reply to Stefan [:stefanh] from comment #11)
> You could use the Milestone field in your search, no?

Not really, since it's only actually set by a handful of people (i.e. it depends on people setting it in the first place) and only once a bug is fixed.

Anyway, the saved search I created doesn't list any false positives right now so it's OK for me.
Blocks: SM2.5
MailNews issue, quite some feedback in Thunderbird on regressions - Bug 677905 - Add menuitem to "show all body parts" (followup to bug 564423, port bug 602718).

"Some attachments in e-mails with certain invalid structures or encodings may not be shown in the attachment pane; toggle mailnews.display.show_all_body_parts_menu to true (once), then temporarily select View > Message Body As > All Body Parts to make such attachments available (bug 677905, bug 674473, bug 702938)."
added bug 677905 to Known Issues

Checking in src/releases/seamonkey2.5/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/index.en.html,v  <--  index.en.html
new revision: 1.11; previous revision: 1.10
done
added "if hardware acceleration is enabled" to DOMI flasher bug description

Checking in seamonkey2.5/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.5/index.en.html,v  <--  index.en.html
new revision: 1.12; previous revision: 1.11
done
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: Websites → SeaMonkey
You need to log in before you can comment on or make changes to this bug.