Last Comment Bug 690267 - Insert|Insert Characters and symbols not working - no options in drop-downs.
: Insert|Insert Characters and symbols not working - no options in drop-downs.
Status: VERIFIED FIXED
[gs]
: regression
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: 7 Branch
: All All
: -- normal with 1 vote (vote)
: Thunderbird 10.0
Assigned To: Mark Banner (:standard8)
:
Mentors:
http://getsatisfaction.com/mozilla_me...
: 691158 695037 695391 (view as bug list)
Depends on:
Blocks: 663300
  Show dependency treegraph
 
Reported: 2011-09-29 01:14 PDT by Mark Banner (:standard8)
Modified: 2011-10-18 12:10 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed
fixed


Attachments
One-byte fix (840 bytes, patch)
2011-09-29 01:18 PDT, Mark Banner (:standard8)
neil: review+
standard8: approval‑comm‑aurora+
Details | Diff | Review

Description Mark Banner (:standard8) 2011-09-29 01:14:55 PDT
If you go to the compose window, and select Insert -> Characters and Symbols then you'll find that the drop-down boxes have no symbols in them.

This appears to be a regression in 7.

A quick look at the error console reveals:

Error: malformed Unicode character escape sequence
Source File: chrome://editor/content/EdInsertChars.js
Line: 416, Column: 2
Source Code:
  "\u00f2\u00f3\u00f4\u00f5\u00f6\u014d\u014f\u0151\u01d2\u01eb\u01ed\u020d\u020e\u022b\u22d\u022f\u0231\u1e4d\u1e4f\u1e51\u1e53\u1ecd\u1ecf\u1ed1\u1ed3\u1ed5\u1ed7\u1ed9\u1edb\u1edd\u1edf\u1ee1\u1ee3", 

The "\u22d" bit seems to be the error - even my emacs picks that up as wrong. My guess is that something has got a bit stricter in 7, causing this to now be an error.
Comment 1 Mark Banner (:standard8) 2011-09-29 01:18:27 PDT
Created attachment 563337 [details] [diff] [review]
One-byte fix
Comment 2 Mark Banner (:standard8) 2011-09-29 01:19:09 PDT
Comment on attachment 563337 [details] [diff] [review]
One-byte fix

Sorry, get the right Neil.
Comment 3 Philip Chee 2011-09-29 03:19:32 PDT
> My guess is that something has got a bit stricter in 7, causing this to now be an
> error.

Bug 663300: If \u is not followed by four hex characters it must be a
syntax error (mutatis mutandis for \x)
Comment 5 Onno Ekker [:nONoNonO UTC+1] 2011-09-30 05:44:29 PDT
> status-thunderbird7: --- ➔ fixed

Does this mean this will be fixed in the upcoming 7.0.1 release?
Comment 6 rsx11m 2011-09-30 15:45:00 PDT
Verified fixed Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20110929 Thunderbird/7.0.1 (thus the answer to comment #5 is yes).

Note that SeaMonkey 2.4.1 didn't pick up that fix (spun too early).
Comment 7 rsx11m 2011-10-02 10:19:24 PDT
*** Bug 691158 has been marked as a duplicate of this bug. ***
Comment 8 Ian Neal 2011-10-17 10:42:02 PDT
*** Bug 695037 has been marked as a duplicate of this bug. ***
Comment 9 Philip Chee 2011-10-18 12:10:13 PDT
*** Bug 695391 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.