Last Comment Bug 691662 - Update shipped Growl framework to 1.2.2 for compatibility with Growl 1.3
: Update shipped Growl framework to 1.2.2 for compatibility with Growl 1.3
Status: VERIFIED FIXED
[inbound][qa!]
:
Product: Toolkit
Classification: Components
Component: XUL Widgets (show other bugs)
: Trunk
: All Mac OS X
: -- normal with 3 votes (vote)
: mozilla11
Assigned To: Markus Stange [:mstange]
:
Mentors:
http://groups.google.com/group/growl-...
: 691892 (view as bug list)
Depends on: 711822
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-03 21:03 PDT by Ben
Modified: 2012-04-13 08:02 PDT (History)
25 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
+
+
verified


Attachments
part 1: update growl framework (14.27 KB, patch)
2011-10-05 03:11 PDT, Markus Stange [:mstange]
smichaud: review+
Details | Diff | Splinter Review
part 2: ignore whether growl is installed or running (1.62 KB, patch)
2011-10-05 03:16 PDT, Markus Stange [:mstange]
sdwilsh: review-
Details | Diff | Splinter Review
alternative part 2: only ignore whether growl is installed, still throw exception when growl isn't running (1.61 KB, patch)
2011-10-05 03:32 PDT, Markus Stange [:mstange]
sdwilsh: review+
Details | Diff | Splinter Review
part 1b: update growl license (1.86 KB, patch)
2011-10-05 04:03 PDT, Markus Stange [:mstange]
gerv: review+
Details | Diff | Splinter Review

Description Ben 2011-10-03 21:03:23 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0a2) Gecko/20111003 Firefox/9.0a2
Build ID: 20111003042017

Steps to reproduce:

I upgraded to Growl 1.3 in the Mac App Store.

The underlying Growl framework has been updated.


Actual results:

I know longer receive Growl updates from Firefox.


Expected results:

I should get notifications.
Comment 1 Markus Stange [:mstange] 2011-10-03 23:47:20 PDT
Looks like we need to update our bundled Growl framework to 1.2.2.
The last update was in bug 522511, as far as I can tell.
Comment 2 Steven Michaud [:smichaud] (Retired) 2011-10-04 18:33:28 PDT
> Looks like we need to update our bundled Growl framework to 1.2.2.

So we don't need to upgrade it to 1.3 to gain compatibility with Growl 1.3?
Comment 3 Steven Michaud [:smichaud] (Retired) 2011-10-04 20:04:12 PDT
*** Bug 691892 has been marked as a duplicate of this bug. ***
Comment 4 Markus Stange [:mstange] 2011-10-05 02:59:35 PDT
Doesn't look like it. There's no framework with version 1.3 yet, and I've confirmed that Growl 1.3 works with Growl.framework 1.2.2.
Comment 5 Markus Stange [:mstange] 2011-10-05 03:11:31 PDT
Created attachment 564776 [details] [diff] [review]
part 1: update growl framework

I think this is all that's needed. It compiles and works (after applying the next patch which I'm about to attach).

I've followed the steps from bug 522511 comment 3 with minor changes, since the necessary files are now stored in two different directories in the framework archive.

1. I downloaded http://growl.googlecode.com/files/Growl-1.2.2-src.tbz and
   unpacked it.
2. I copied all files from Growl-1.2.2-src/Framework/Source/ and from
   Growl-1.2.2-src/Common/Source/ to toolkit/components/alerts/mac/growl/,
   replacing the existing files. I did *not* hg add any files.
3. I re-added the #import <Cocoa/Cocoa.h> line in front of the #import block in
   GrowlPathUtilities.m.
4. I looked through the diff and searched for any new #import lines, so that I
   could hg add any header files that might have become required in the new
   version of the framework.
   There were none, so I didn't add any.
5. I confirmed that the new tree compiled.
Comment 6 Markus Stange [:mstange] 2011-10-05 03:16:48 PDT
Created attachment 564778 [details] [diff] [review]
part 2: ignore whether growl is installed or running

With Growl 1.3, [GrowlApplicationBridge isGrowlInstalled] always returns NO. I've asked in the newsgroups about this [1], and the answer I got was that we should ignore whether Growl is installed and just fire notifications unconditionally.

So this patch backs out bug 381520.

With this patch I've confirmed that things work by executing the following from the error console:

Components.classes["@mozilla.org/alerts-service;1"].getService(Components.interfaces.nsIAlertsService).showAlertNotification(null, "title", "text", false, "", null);

[1] http://groups.google.com/group/growl-development/browse_thread/thread/1bf5b4c50375458#msg_bc88df32b77cd771
Comment 7 Markus Stange [:mstange] 2011-10-05 03:32:52 PDT
Created attachment 564782 [details] [diff] [review]
alternative part 2: only ignore whether growl is installed, still throw exception when growl isn't running

Actually, [GrowlApplicationBridge isGrowlRunning] still works, so we can just keep using it. This way we don't really follow Peter's advice, though.
I'm leaving the choice up to you, sdwilsh.
Comment 8 Markus Stange [:mstange] 2011-10-05 04:03:37 PDT
Created attachment 564789 [details] [diff] [review]
part 1b: update growl license
Comment 9 Steven Michaud [:smichaud] (Retired) 2011-10-05 07:45:56 PDT
Comment on attachment 564776 [details] [diff] [review]
part 1: update growl framework

This looks fine to me.  Thanks for doing it.

One small nit:  You can probably hg remove the following files:

toolkit/components/alerts/mac/growl/GrowlPreferencesController.h
toolkit/components/alerts/mac/growl/GrowlTicketController.h
Comment 10 Steven Michaud [:smichaud] (Retired) 2011-10-05 07:46:55 PDT
One more thing:  Someone should test these changes with older versions of Growl.
Comment 11 Frederik Niedernolte 2011-10-13 09:14:53 PDT
Will this be included in one of the next small updates for Thunderbird 7.x or do we have to wait for Thunderbird 8?
Comment 12 joel 2011-10-13 09:17:26 PDT
I would like to add to comment 7, when will this take place?
Comment 13 joel 2011-10-13 09:18:56 PDT
(In reply to joel from comment #12)
> I would like to add to comment 11, when will this take place?

I menat comment 11!
Comment 14 Markus Stange [:mstange] 2011-10-13 09:25:08 PDT
Depends on when it's reviewed. But it will probably have to wait at least for Thunderbird 8, if not longer.

Shawn, when do you think you'll get to the review? Should I ask somebody else for review?
Comment 15 Shawn Wilsher :sdwilsh 2011-11-06 13:09:59 PST
(In reply to Markus Stange from comment #14)
> Shawn, when do you think you'll get to the review? Should I ask somebody
> else for review?
Sorry; I should get to it today.
Comment 16 Shawn Wilsher :sdwilsh 2011-11-06 19:01:19 PST
Comment on attachment 564782 [details] [diff] [review]
alternative part 2: only ignore whether growl is installed, still throw exception when growl isn't running

Review of attachment 564782 [details] [diff] [review]:
-----------------------------------------------------------------

r=sdwilsh
Comment 17 Florian Bender 2011-11-08 05:15:29 PST
FYI, Growl SDK 1.3 has been released, which no longer relies on Growl.app. So you can display notifications with Mist (basically the SDK, AFAIU), and Growl.app turned into a "pro" frontend for customizing messages. 

Would be nice to see SDK 1.3 implemented! 


http://growl.info/notetodevelopers
Comment 18 Shawn Wilsher :sdwilsh 2011-11-08 19:31:20 PST
Comment on attachment 564778 [details] [diff] [review]
part 2: ignore whether growl is installed or running

Meant to say no on this one.
Comment 19 Shawn Wilsher :sdwilsh 2011-11-08 19:32:21 PST
Markus - ETA on landing this?  Also, this is broken with new growl, so we may want to take this in aurora/beta.
Comment 22 joel 2011-11-14 05:46:08 PST
In what version of Thunderbird will this take effect if Firefox is version 11?
Comment 23 Florian Bender 2011-11-15 16:20:09 PST
AFAICS this is not SDK 1.3. Shall I open another ticket for the new version?
Comment 24 Jae Gangemi 2011-11-18 14:20:51 PST
this fix isn't slated until firefox 11!?!?! i'm sorry, but that is pretty ****. i realize you guys have a lots of other things to do, but come on. 

it really makes me start to wonder why this code is even part of the the native release instead of being handled via some kind of extension that could be updated and released more quickly then this fix is going to be.
Comment 25 Ed Morley [:emorley] 2011-11-18 14:44:07 PST
(In reply to Jae Gangemi from comment #24)
> this fix isn't slated until firefox 11!?!?! i'm sorry, but that is pretty
> ****. i realize you guys have a lots of other things to do, but come on. 

Not sure why "having other things to do" is relevant? This has already been fixed and landed on mozilla-central, which is currently where new development work is occurring (new features do not land on aurora or beta). 

If you wish to try it out, please download the latest nightly: http://nightly.mozilla.org/ or alternatively within 4-5 weeks it will be on aurora: http://www.mozilla.org/firefox/aurora/

If you'd rather not use a nightly/Aurora/Beta, then Firefox 11 final will be released in 17 weeks time.
Comment 26 Jae Gangemi 2011-11-18 15:01:28 PST
i don't see how this is a new feature. it's updating an existing library for an already existing feature, but ok, you guys are in charge of your development process, so i'm not belabor that point.

17 weeks is a long time to wait for an existing feature to start working again and i am not interested in working with a nightly as i find the betas to be unstable enough as it is. 

so back to the question of why is this code even in the core of mozilla instead of being handled by some kind of extension that can be updated and released independently of the core?
Comment 27 Alex Keybl [:akeybl] 2011-12-06 13:00:24 PST
I think it's too late in FF9 to take on beta, but is this patch too risky to uplift to aurora 10? If not, please nominate for approval on aurora - it'd be good to get notifications working again for up-to-date Growl users on OS X.
Comment 28 joel 2011-12-06 14:28:06 PST
When will the update hit Thunderbird, I need that more than Firefox.
Comment 29 Jae Gangemi 2011-12-06 14:30:45 PST
again i would like to raise the question of why this code is in the core at all instead of being handled through a separate extension that could be updated and released outside of the mozilla development cycle.
Comment 30 Jae Gangemi 2012-01-19 10:11:37 PST
firefox does not properly register with growl upon start up, so i am unable to receive notifications.

https://bugzilla.mozilla.org/show_bug.cgi?id=719485
Comment 31 joel 2012-02-03 11:56:38 PST
I thought GROWL would be working in Beta 11 of Thunderbird, but n dice here. Any ideas?
Comment 32 Jens-Erik Weber 2012-02-10 17:24:53 PST
Growl 1.3 has been criticized a lot for two reasons:

1. The free app has become commercial.

2. It has become technically worse and it’s not a system preference panel any more, but an app with an annoying icon in the menu bar (maybe you can switch it off in a new version).

I don’t see any additional features compared to 1.2. It still seems to raise notifications on the screen (or speaks or sends SMS text messages), and that’s it. SO there’s no need to hurry for an upgrade, and  many users still stick to Growl 1.2.2. I just saw on McUpdate that ther is a free fork of Growl <http://www.macupdate.com/app/mac/41038/growl-fork>. So please please stay or become (in case of Thunderbird) compatible with 1.2.2 and Growl Fork!
Comment 33 Steven Michaud [:smichaud] (Retired) 2012-02-13 13:12:35 PST
People who are running Growl 1.2.2 and are having problems with *current Firefox mozilla-central nightlies*, please don't keep commenting here.  The bug you want is (presumably) bug 711822.
Comment 34 Steven Michaud [:smichaud] (Retired) 2012-02-13 13:31:10 PST
People who are running Growl 1.3 (current version 1.3.3) should not be having any problems with current Firefox trunk nightlies.

If you are, please open a new bug.  And I do mean trunk nightlies -- not alphas or betas.
Comment 35 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-01 12:50:40 PST
I'm not having any issues with Growl 1.2.2 nor 1.3.3 on Firefox 11.0b5 -- marking this VERIFIED.
Comment 36 Frederik Niedernolte 2012-03-16 08:53:26 PDT
It doesn't work for me with Firefox 11 or Thunderbird 11 Final on Mac OS X 10.7.3 with Growl 1.3.3.
Both programs aren't registered in Growl.
How can I fix that?
Thanks
Comment 37 Eugene 2012-03-19 08:48:47 PDT
I can confirm that Firefox Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0 DOES register correctly, but Thunderbird Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20120313 Thunderbird/11.0 DOES NOT register.

Since this but is Firefox only it seems like it should not be re-opened, but see Bug 719485.
Comment 38 Eugene 2012-03-20 08:42:51 PDT
Added Bug 737444 -- Thunderbird 11 does not work with Growl 1.3.3 or 1.2.2f1. Firefox bug (this bug) remains RESOLVED WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.