Closed Bug 710784 Opened 8 years ago Closed 8 years ago

Add-on validation fails with no errors and localization tests are not run

Categories

(addons.mozilla.org Graveyard :: Add-on Validation, defect, P2, major)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rldhont, Assigned: basta)

References

()

Details

(Whiteboard: See comment #3)

Attachments

(1 file)

397.79 KB, application/octet-stream
Details
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

I would like to update my add-on Geolocater which uses the preference 'geo.wifi.uri'


Actual results:

Geolocater failed validation, the message is :
The 'geo.wifi.uri' was removed in Firefox 9
It's a compatibility error as explaining here https://bugzilla.mozilla.org/show_bug.cgi?id=692927


Expected results:

Show compatibility warning if an add-ons uses geo.wifi.uri

The 'geo.wifi.uri' has not been removed from Firefox 9
Pointed by dougt : http://mxr.mozilla.org/mozilla-central/search?string=geo.wifi.uri

A comment in the bug https://bugzilla.mozilla.org/show_bug.cgi?id=689252 has clarified that the preference is still being honored. The change is that this preference won’t have a default value and therefore won’t appear in about:config. It is still possible to set its value using the pref service, or creating a new string preference in about:config with the right name. Add-ons reading this preference still need to update their code if they aren’t expecting any exceptions when reading it without setting it first.
Depends on: 692927, 89252
Depends on: 689252
No longer depends on: 89252
The full validation report mentions that the addon failed validation but without error!
https://addons.mozilla.org/en-US/developers/upload/f758fe1ec4df49b69ea20139af1ffb9c
A new one with the addon failed without error :
https://addons.mozilla.org/en-US/developers/upload/75bffc14f4684bbca24d1cb739b50b4a
The problem here may or may not be related to comment #0. Compatibility errors shouldn't be errors in regular validation, I think this was fixed before.

What is happening is that the add-on is failing validation with no visible errors (see https://addons.mozilla.org/en-US/developers/upload/75bffc14f4684bbca24d1cb739b50b4a). Also, it looks like localization tests are not being run at all.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Summary: Remove compatibility error if an add-on uses geo.wifi.uri → Add-on validation fails with no errors and localization tests are not run
Whiteboard: See comment #3
Target Milestone: --- → 6.3.6
Attached file Geolocater 1.5
This is the version 1.5 of Geolocater addon.
https://addons.mozilla.org/en-US/developers/addon/geolocater

During submission this file has a Compatibility error, without visible error in the full report.
Assigning to Matt since it's a validator issue. The validation result gets a message of type error (which is incorrect):

    {
            "context": ["get uri() {", "  return Services.prefs.getCharPref('geo.wifi.uri');", "},"],
            "description": "The geo.wifi.* preferences are no longer in use. See...for more information.",
            ...
            "compatibility_type": "error",
            "file": "modules/geolocater-prefs.js",
            "tier": 5,
            "for_appversions": {
                "{3550f703-e582-4d05-9a08-453d09bdfdc6}": ["9.0a1", "9.0a2", "9.0", "9.*"],
                "{a23983c0-fd0e-11dc-95ff-0800200c9a66}": ["9.0a1", "9.0a2", "9.0", "9.*"],
                "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}": ["9.0a1", "9.0a2", "9.0", "9.*"]
            },
            "message": "The preference 'geo.wifi.uri' was removed in Firefox 9",
            "type": "error",
            "line": 314,
            "uid": "4f2892468e46401a8156cbd34f86eb16"
        }
Assignee: nobody → mattbasta
Yeah, that should be a warning. Not sure why it was added as an error. I `git blame` it on washort.

https://github.com/mozilla/amo-validator/pull/98
Merged

https://github.com/mozilla/amo-validator/commit/3fb6e7529c9148ed671aa943c56f4567637258c3
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.