Closed Bug 714040 Opened 8 years ago Closed 5 months ago

TB: Keyboard Shortcuts broken(?)/wrong/incomplete in documentation: Ctrl+Del, Ctrl+Backspace

Categories

(Thunderbird :: Help Documentation, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: bugzilla2007, Assigned: bugzilla2007)

References

(Blocks 2 open bugs, )

Details

+++ This bug was initially created as a clone of Bug #714036 +++

Keyboard Shortcuts list (1) currently has this:

|Delete current word (not applicable on laptop keyboard)||{for win}{button Ctrl} + {button Del} {/for}{for mac, linux}{button Ctrl} + {button Del} {/for}
|-
|Delete previous word(on laptop, deletes from cursor to start of word)||{for win}{button Ctrl} + {button Backspace} {/for}{for mac}{button Option} + {button Delete}{/for}{for linux}{button Ctrl} + {button Backspace}{/for}
|-

Which, for Windows, translates to:

> Delete current word (not applicable on laptop keyboard): Ctrl + Del
> Delete previous word(on laptop, deletes from cursor to start of word):
>   Ctrl + Backspace

"Not applicable on laptop keyboard"!? At least for Windows, this is nonsense. I don't know about MAC laptops or other OS for that sake, but for windows on a normal laptop, keyboard shortcuts cannot be different from a normal computer's keyboard.

I don't have time for the details, maybe somebody can explain the expected behaviour (Ludo?) and/or appropriate documentation.

(1) https://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts
Whoops. Wrong summary from cloning.
Summary: Thunderbird Help Keyboard Shortcuts broken(?)/wrong/incomplete in documentation: F1 vs. Ctrl+? → Thunderbird Keyboard Shortcuts broken(?)/wrong/incomplete in documentation: Ctrl+Del, Ctrl+Backspace
Summary: Thunderbird Keyboard Shortcuts broken(?)/wrong/incomplete in documentation: Ctrl+Del, Ctrl+Backspace → TB: Keyboard Shortcuts broken(?)/wrong/incomplete in documentation: Ctrl+Del, Ctrl+Backspace
Blocks: 716093
No longer blocks: 716093
Blocks: 720379
This needs verification of both exact shortcuts keys and exact behaviour on the following OS:
- MAC OS
- LINUX

So far no response, so for the time being, I assume that the behaviour of these commands is the same on all OS, so this is the current documentation after I landed today's major revision (1):

|-
|Delete word to the right (from cursor to end of word)||{for win,linux}{key Ctrl+Del}{/for}{for mac}{key Control+Del}{/for}
|-
|Delete word to the left (from cursor to start of word)||{for win,linux}{key Ctrl+Backspace}{/for}{for mac}{key Option+Del}{/for}
|-

(1) https://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts/revision/5614
Assignee: nobody → bugzilla2007
Status: NEW → ASSIGNED
Suyash, in composition, starting with cursor in middle of some word like "foo|bar", can you try Ctrl+DEL and Ctrl+Backspace on Linux? Do they do what is described in comment 2?

Can you test on MAC, too?
Flags: needinfo?(syshagarwal)
(In reply to Thomas D. (away till 31st January) from comment #3)
> Suyash, in composition, starting with cursor in middle of some word like
> "foo|bar", can you try Ctrl+DEL and Ctrl+Backspace on Linux? Do they do what
> is described in comment 2?

Yes.

> Can you test on MAC, too?

Sorry, I don't have a MAC :(
Flags: needinfo?(syshagarwal)
Patrick, I heard from Wayne that you're using TB on MAC.

Could you please verify the following keyboard shortcuts for this bug (tia):

STR
1 compose, type "foobar"
2 place cursor in the middle of the word, like this: "foo|bar"
3a press Control+Del
3b repeat 1 and 2, then:
   press Option+Del

Actual Result?

Pls report what this does for you (also mention the size of your keyboard because keys are different).

Expected Result:

Control+Del: Delete word to the right (from cursor to end of word) -> "bar" should be deleted
Option+Del: Delete word to the left (from cursor to start of word) -> "foo" should be deleted

When we say "Del" on MAC, we're talking about the big "Delete" key in the upper-left corner of main part of big keyboard, i.e. the equivalent of "Backspace" on PC keyboards, right?
Does pressing that "Del" key by itself usually delete backwards?
Flags: needinfo?(patrick.hendriks+bugzilla)
(In reply to Thomas D. (away till 31st January) from comment #5)
> Patrick, I heard from Wayne that you're using TB on MAC.


Hi Thomas, indeed I am still on a Mac but to my embarrassment I have to admit that I recently changed from TB to Mail.app :-/

My apologies
Thomas: could you also please remove the needinfo flag?
(In reply to patrick.hendriks from comment #6)
> (In reply to Thomas D. (away till 31st January) from comment #5)
> > Patrick, I heard from Wayne that you're using TB on MAC.
> Hi Thomas, indeed I am still on a Mac but ...

Hi Patrick, thanks for your reply anyway.
Since you're on MAC, could you perhaps answer this question about the MAC keyboard:

When we say "Del" on MAC, we're talking about the big "Delete" key in the upper-left corner of main part of big keyboard, i.e. the equivalent of "Backspace" on PC keyboards, right?
Does pressing that "Del" key by itself usually delete backwards?
Severity: normal → minor
Flags: needinfo?(patrick.hendriks+bugzilla)
(In reply to Thomas D. (away till 31st January) from comment #8)
> When we say "Del" on MAC, we're talking about the big "Delete" key in the
> upper-left corner of main part of big keyboard, i.e. the equivalent of
> "Backspace" on PC keyboards, right?

Indeed
> Does pressing that "Del" key by itself usually delete backwards?

On my laptop, pressing Delete makes the cursor move from right backwards to the left, thus deleting the character just in front of the cursor

Pressing Fn+Delete makes the cursor move from left to right (i.e., forward, thus deleting the charachter just behind the cursor.

Hope that helps? :)
http://lifehacker.com/5803041/the-mac-os-x-delete-key-it-goes-both-ways

the vast majority of Mac users don't use the full-size keyboard (which has Delete keys for both directions)[*]. Here are a few quick shortcuts to set the matter straight for everyone, but especially for those *macbook* users out there.

    Deleting text in front of the cursor with the regular Delete key can be done by holding down the Function, or fn key while pressing it.
    You can also do this by pressing Control + D.
    You can delete the entire word behind the cursor by pressing Control + Delete or Option + Delete.
    You can delete the entire line of text or paragraph behind the cursor by pressing Command + Delete.

[*] On a full-size Mac USB keyboard, you have a
Delete key (equivalent to Backspace on windows/linux, delete backwards) and a
delete key with an arrow 'x' icon pointing to the right (equivalent do DEL key on windows/linux, delete forwards).
This might help: Official MAC list of keyboard shortcuts.

https://support.apple.com/en-us/HT201236

Bugzilla is no longer used for Knowledge base documentation changed.

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.