New tab page sometimes doesn't show thumbnails

RESOLVED FIXED

Status

()

Firefox
Tabbed Browser
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: glandium, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

I haven't identified a pattern, but with a fresh profile, I don't get thumbnails most of the time, except after restarting firefox. With a very old profile, not matter what i do, thumbnails never show up.
Blocks: 455553

Comment 1

5 years ago
I never got any thumbnails. Only gray tiles. When I navigate to the images URL (moz-page-thumb://thumbnail?url=http%3A%2F%2Fyoutube.com%2F) I get "The image “moz-page-thumb://thumbnail?url=http%3A%2F%2Fyoutube.com%2F” cannot be displayed because it contains errors."
Mike/Greg, if you wait for the webpages to load completely and afterwards refresh the new tab page, do the thumbnails load in the grid? If not, could you provide some sites where this does not happen?

Greg, did you by chance delete the cache and afterwards load the image from the grid when you received that message?
mail.google.com, for instance.
(In reply to Mike Hommey [:glandium] from comment #3)
> mail.google.com, for instance.

This is bug 705911. Do you have any other examples that are not bug 705911 or bug 716949?
Blocks: 497543
No longer blocks: 455553
OS: Linux → All
Version: 8 Branch → Trunk
(In reply to Tim Taubert [:ttaubert] from comment #4)
> (In reply to Mike Hommey [:glandium] from comment #3)
> > mail.google.com, for instance.
> 
> This is bug 705911. Do you have any other examples that are not bug 705911
> or bug 716949?

For example, my main profile (which is very old) has no thumbnail at all, and about:newtab includes https://bugzilla.mozilla.org/, which, if I go to in a fresh profile, does have a thumbnail.
Can you please check the value of 'browser.cache.disk.enable' in your old profile? I suspect bug 724408.
(In reply to Tim Taubert [:ttaubert] from comment #6)
> Can you please check the value of 'browser.cache.disk.enable' in your old
> profile? I suspect bug 724408.

It's set to true.

Comment 8

5 years ago
Ooops sorry my bad it was 'browser.cache.disk.enable' on my side.
Still happens on aurora 13.

Comment 10

5 years ago
For the reference: another pref that is said to affect this is browser.display.use_document_colors ("allow pages to choose their own colors") - bug 737877

Comment 11

5 years ago
I have similar issue and reported it on bug 740287. After making sure that both browser.display.use_document_colors and browser.cache.disk.enable are both true, I closed the browser and deleted the whole Cache folder from my profile. After starting the browser again I can see (for the first time) an image on my new tab page, which is gmail. I guess that the icons are now repopulating themselves, and soon enough I'll have thumbnails for every button on the page. 

This experiment can confirm that in my case it was something wrong with the caching mechanism. I still have a backup of my Cache, in case you have an idea what could cause it.

Updated

5 years ago
Duplicate of this bug: 736796
So, in my case, it looks like it was due to
browser.cache.disk.smart_size.enabled = false
and 
browser.cache.disk.capacity = 0

I don't remember when I set that, but obviously I was shooting myself in the foot. Now I'm starting to see some thumbnails. However, I still have a lack of some thumbnails in fresh profiles where the above prefs are not set.

Comment 14

5 years ago
This bug is annoying. I wonder why it has not received more attention? No user should be expected to debug this when it gets to the final release to get the new tab feature to work correctly. I hope that by beta this catches more attention.

Comment 15

5 years ago
Created attachment 612356 [details]
Missing thumbnails - do you guys mean this?
Will be fixed by bug 744388.
Depends on: 744388

Comment 17

5 years ago
Created attachment 619276 [details]
Missing thumbnails - we mean this

@15:

Sort of. What we really mean is this.

All of the mentioned problem booleans check out here and it's been this way for the entire 6 weeks of the Aurora 13 release cycle and across a couple of exploratory reboots just a moment ago in Aurora 14. (I'm on Ubuntu and the Aurora PPA is always a week behind the release)
Fixed by bug 744388.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.