Closed Bug 73701 Opened 19 years ago Closed 8 years ago

Enhancement: It would be nice and very handy, if Mozilla could handle "/" as a "\" and in other direction too.

Categories

(SeaMonkey :: Location Bar, enhancement)

x86
Windows 98
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 64488

People

(Reporter: mixer, Assigned: braden)

References

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; 0.8.1) Gecko/20010323
BuildID:    2001032319

Enhancement: It would be nice and very handy, if Mozilla could handle "/" as a
"\" and in other direction too.

Reproducible: Couldn't Reproduce
I'm just wondering, where, specifically, would this be useful?  And would it
have any negative impact?
I am often doing webpage and other stuff in Windows and use it in UNIX, it 
become very annoyng to change those chars. And otherwise, when I am downloading 
page, it takes too much time to switch them. :(

I think that our goal is not to make Mozilla use only standards, but to make it
userfriendly and program, which can work regardless to little mistakes in code. 
I think that it is final goal.

I don't think that there is any side effects...
Braden: wouldn't you love to read this bug?
Assignee: asa → braden
Component: Browser-General → URL Bar
Whiteboard: KILLME DUPEME
INVALID (with extreme prejudice)

Accepting incorrect code is not a usability feature. It pollutes standards,
making them more difficult for different implementors to consistently implement
them. Sell "embrace and extend" somewhere else.

BTW, there's no reason you should ever be using '\' as a hierarchy separator in
URLs. It's Not Right. '/' should work for that purpose under any reasonably
correct implementation.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
verifying
Status: RESOLVED → VERIFIED
Whiteboard: KILLME DUPEME
Duplicate of this bug: 371222
Braden? Is there any change that Firefox will use this option? 
(In reply to comment #7)
> Braden? Is there any change that Firefox will use this option? 

Correctly interpreting URIs and implementing this "feature" are mutually exclusive. I am no particular authority on what Firefox will do in this regard. But it is a horrible idea.

I see... But sometimes thinks are better for the World ;) 
Duplicate of this bug: 437932
Product: Core → SeaMonkey
Duplicate of this bug: 521612
Duplicate of this bug: 672853
Duping against bug 64488 just to avoid confusion as seen in bug 672853
Status: VERIFIED → RESOLVED
Closed: 19 years ago8 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: backslash
You need to log in before you can comment on or make changes to this bug.