Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Installing Favimon does not show the right parenthesis on the desktop shortcut or start menu

VERIFIED FIXED in Firefox 15

Status

Firefox Graveyard
Web Apps
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: jsmith, Assigned: Mardak)

Tracking

unspecified
Firefox 15
Bug Flags:
in-moztrap -

Details

(Whiteboard: [marketplace-beta=])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Steps:

1. Go to https://apps.mozillalabs.com/appdir/
2. Install Favimon

Expected:

The application should be installed natively. The desktop shortcut and the item in the start menu should be Favimon (beta).

Actual:

The application is installed natively. However, the desktop shortcut and the item in the start menu is listed as Favimon (beta.
(Reporter)

Comment 1

5 years ago
Created attachment 617004 [details]
Favimon Parentheses Issue
This is related to the sanitization code in bug 704574.
See Also: → bug 704574
(Reporter)

Updated

5 years ago
Blocks: 731054
(Reporter)

Updated

5 years ago
Whiteboard: [marketplace-beta-]
(Reporter)

Updated

5 years ago
Duplicate of this bug: 748676
(Reporter)

Updated

5 years ago
Whiteboard: [marketplace-beta-] → [marketplace-beta=]
(Assignee)

Comment 4

5 years ago
The trailing ) is removed by WebappsInstaller.jsm's stripStringForFilename:

  let stripBackRE = new RegExp("\\W*$","gi");
(Assignee)

Comment 5

5 years ago
felipe, any particular reason trailing characters need to be stripped? Stripping from the beginning makes more sense if the first character must be alphanumeric, but usually there's no requirement for non-first characters.. ?
(Assignee)

Comment 6

5 years ago
This also affects os x in /Applications and Launcher.
OS: Windows 7 → All
Hardware: x86_64 → All
Nope, the original idea was to strip blank/invisible characters, but this ended up to be too aggressive
(Assignee)

Comment 8

5 years ago
So probably just change it to stripping \s ?
(Assignee)

Comment 9

5 years ago
Created attachment 618859 [details] [diff] [review]
v1
Assignee: nobody → edilee
Status: NEW → ASSIGNED
Attachment #618859 - Flags: review?(felipc)
Attachment #618859 - Flags: review?(felipc) → review+
(Reporter)

Comment 10

5 years ago
(In reply to Edward Lee :Mardak from comment #9)
> Created attachment 618859 [details] [diff] [review]
> v1

FYI - Looking at the patch comment:

//strip everything from the front up to the first [0-9a-zA-Z]

This isn't localized to languages outside of the united states. This explains why bug 733482 might be happening. This needs to be localized, along with other regex expressions used for manifest parsing.
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/add831dc812e
https://hg.mozilla.org/mozilla-central/rev/add831dc812e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

5 years ago
No longer blocks: 731054
(Reporter)

Updated

5 years ago
Flags: in-moztrap?(jsmith)
(Reporter)

Updated

5 years ago
QA Contact: jsmith
(Reporter)

Updated

5 years ago
Flags: in-moztrap?(jsmith) → in-moztrap-
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.