Bug 75214 (sueddeutsche)

Page does not render / garbage in iframes (graphics adapter specific?)

VERIFIED WORKSFORME

Status

()

P1
major
VERIFIED WORKSFORME
18 years ago
15 years ago

People

(Reporter: meine.adresse, Assigned: dcone)

Tracking

({testcase, top100})

Trunk
Future
testcase, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Browser starts rendering minor part of page, then freezes...
Cannot say whether bug is new since page has completely changed its layout since
last visit...

Build ID 2001040604

Comment 1

18 years ago
worksforme on linux build 2001040821

Comment 2

18 years ago
No crash for me on build 2001040904 on Windows 95... but wow! Am I the only one
seeing four solid pages of garbage/snow/static at the very bottom of the page?
(Reporter)

Comment 3

18 years ago
I have to correct my description:
1) Just downloaded 2001040904 and the problem is still there for me...
2) Apparently Mozilla does not freeze but the display gets messed up. The page
is displayed only marginally, with most of the previous page remaining in the
display - I can still scroll, but only garbage is scrolled and the scroll bar
does not move. Further, I can still type links into the url-bar, though neither
is http://www.sueddeutsche.de deleted nor the new one I am typing in displayed.
But after hitting enter the new page gets loaded properly and everything seems
to be fine again. Also, links in my personal toolbar folder still work, while
folders do not open.
3) Obviously, I cannot see the couple of pages of static mentioned by the
previous reporter, but if you open the page with internet explorer, you get a
couple of empty pages (just background color) after the content, too. So this
seems to be a site design problem, not Mozilla related.
I see no problems with 2001-04-09-04, Win NT.

BTW, they know about NS 6 and/or Mozilla in their browser sniffing code.
They check even for MSIE 5.0 on Linux :)

If they've done a redesign recently, maybe there was some fine-tuning, which
changed the behavior. And it isn't a static page.

I think this is a worksforme. And severity isn't major anyway.
Severity: major → normal
(Reporter)

Comment 5

18 years ago
Well, if it's working for all the other people out there...

Still doesn't work for me on 2001041020
Additionally it did not work on a friends machine, too (Win 98, Mozilla 0.81)

Comment 6

18 years ago
Ok, I'm able to reproduce some of the paint problems only when I scroll the
page. Looking at the page source, it shows the page is made up of five iframes
elements with scrolling set to "no". I have seen issues on other pages when
scrolling a page containing iframes elements. Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

18 years ago
Tested on Linux and Mac April 10th builds.

Comment 8

18 years ago
Reassigned to attinasi but maybe it should go to Views
Assignee: karnaze → attinasi

Comment 9

17 years ago
2001061620

Load page, browser freezes for a good two to three minutes, then page starts loading
(Reporter)

Comment 10

17 years ago
Still doesn't render at all for me, even though the browser stays responsive,
just the whole user interface and content area not displaying anymore.

My guess is, this might be related to the graphics adapter. My PC has an Ati
Rage graphics adapter and if I remember correctly, there are other
incompatabilities with Mozilla and this graphics device that have been mentioned
in some readme or something!? Tested with a recent build on a different PC with
Win 2000 and Geforce 2 and had no problems at all.

So my guess would be the graphics adapter!? Just my 2 cents...

Comment 11

17 years ago
Sending to rendering team to deal with...
Assignee: attinasi → kmcclusk
Component: Layout → Views
Summary: Pages freezes browser → Page does not render / shows garbage (graphics adapter specific?)

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Comment 12

17 years ago
It also fails on Win95 2001071004.  It displays most of the page, but about
halfway down it simply stops rendering.  CPU Usage goes all the way up to 100%.

Running a Matrox Millenium G200 with 8MB Graphics RAM on Win95 P266 with 64 MB
of RAM.

Comment 13

17 years ago
I see this at home on my dialup box too (56kb USRobotics). emachines PII, 400mhz
64mb ram Win 98. ..not sure of graphics card. I am forced to exit the browser
and restart when it begins to do this for me as I can't read anything on the
page. Has happened at multiple web sites, including working in Bugscape from
home. Usually (But not always) occurs when I have multiple browser windows up
and and am clicking on links between them.Sometimes occurs when I click the Stop
icon on the browser, then click on a link in the same page.
I'll try to find the display adapter and put that info here. I never see this
happen on site at work (I'm on NT there with the T1 line).
Saw it on win32 2001-07-27 branch and trunk.
Setting priority to major as it forces me to exit the browser to make it usable
again.
Severity: normal → major

Comment 14

17 years ago
Does not render for me either. Build 2001080110 on WinME. ATI graphics card.
Only the window with this URL freezes, but can be closed normally. All other
windows are not affected (mail, browser...).

Comment 15

17 years ago
Update onmy cae. I use an ATI Rage Pro Turbo card. I Just installed latest
graphics card driver for win98 on my system at home. So far, the problems seem
to be gone now though I haven't used it a lot since that install. I'll report
back if they pop up again.

Comment 16

17 years ago
Update on my case. Seems to be the ATI driver for me too.

Computer 1: Celeron 333, Matrox G200 8 MB, Windows ME, 160 MB RAM, permanent
connection (100 MBit): works without flaws and renders fast.

Computer 2: Celeron 700, ATI Xpert 2000 Pro 32 MB, Windows ME, 512 MB RAM, 56k
dialup connection: crashes as reported.

First I thought the computer was too slow, but this doesn´t seem to be the case.
I just don´t want to update the ATI driver because the latest driver requires
DirectX 8, which is famous for destroying working windows installations. Is
there a workaround for old ATI drivers?

Comment 17

17 years ago
Just another update on my case. 

I installed DirectX 8 & the latest drivers for ATI Xpert 200 Pro, and the page
still won´t render. But now I can scroll up and down the empty page, it doesn´t
freeze any more.

A more accurate description of my system: Celeron 700 on ASUS CUV4X with 512 MB
RAM, ATI Xpert 2000 Pro 32 MB running at 1152x864x32, Windows ME, Trust modem
56k. Still 384 MB free after loading WinME & Mozilla.

Comment 18

17 years ago
Update: Installed DirectX Video Capture Update. Problem solved. Page renders
without flaws and without any crashes.

Apparently, this is not a Mozilla bug.

!!! Microsoft claims this update is only needed for capture devices. I do not
have _any_ capture devices, but it helped anyway (although I got at least 10
error messages while installing it). A friend of mine who does technical support
told me that the video capture update should _always_ be installed with DirectX8
because it solves a few extra bugs.
(Reporter)

Comment 19

17 years ago
I have no idea why, but after having so much trouble with this bug now
everything is working ok for me, page renders fine. (Build ID 2001090703). I
have not changed my graphics adapter driver or something like that, though, so
the why and how leaves me puzzled.
(Reporter)

Comment 20

17 years ago
Darn, I stand corrected: Contrary to what I wrote before, not everything is OK.
I can load the index page in most cases, but once I click on a link to an
article the same rendering problem arises as described previously by me.
Peterson: Can you reproduce this bug?
Status: NEW → ASSIGNED
Keywords: qawanted
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 22

17 years ago
Several sueddeutsche.de bugs got marked as doubles of Bug 91747. For me (Windows
ME) the bug is still present with the nightly build from 13-11-01, the Linux
version does not seem to have this problem (but it occasionally truncates articles).

Comment 23

17 years ago
The freeze was fixed in bug 91747. Misrendering persists.

The page seems to lay out too long, but selecting the last visible story in the
middle area and dragging downwards tend to show a story or two more. If that
doesn't help, click the brown area right above the story where you started
selection from: more stories suddenly become visible.
Mouse over these, and they turn white again.

Seeing this on a fresh CVS build, RH7.1 Linux, w/ nVidia GF2MX and native
XFree86 4.0.3-5 nv driver. Whatever this is - it's not graphics adapter specific.

Comment 24

17 years ago
I think that in this bug's history, there's actually several different bugs
being exhibited, some of them surely being fixed with mozilla 0.9.7 (the first
release including the fix for bug 91747). Other problems persist, however.

R.K.Aa: what you describe seems to be bug 100574 to me. Could you please confirm?

If you enter any expression into the Search box at the top of the
sueddeutsche.de page, the middle section will stop redrawing (best exhibited by
minimizing and maximizing mozilla) (mozilla 0.9.7, Win98). I haven't found any
other bug which describes this behaviour, so I'm reporting it here.

Generally, due to its strange iframe architecture, www.sueddeutsche.de seems to
be quite a good testcase for the rendering engine and should perhaps be
consulted more often by developers.  ;-)
Bulk moving Mozilla1.01 bugs to future-P1. I will pull from the future-P1 list
to schedule bugs for post Mozilla1.0 milestones
Priority: -- → P1
Target Milestone: mozilla1.0.1 → Future

Comment 26

17 years ago
With Mozilla 0.9.8, bug 100574 is the only remaining problem I still see with
http://www.sueddeutsche.de (I tested Win98, Win2k, and Linux). So unless any of
the other reporters still sees any other problem, I'd suggest closing this bug.

Comment 27

16 years ago
humm, it seems to me like this bug has morphed.

the original problem that was reported is:
> Browser starts rendering minor part of page, then freezes...
which sounds like bug 100574 (which still exists).

anyhow, the new summary states that garbage is being drawn (right?), which I
also encounter, see attachment 86411 [details].
(http://bugzilla.mozilla.org/attachment.cgi?id=86411&action=view)
(screenshot showing the exact snowey / garbage display) problem.

which is most likely related to the graphics card / OS.
I use an nVidia GeForce2 MX200. <- Win98se.

I have upgraded the drivers etc, many times to the newest.

build: 20020530 (release 1.0).

also see bug 149300, which seems like a dup of this.

Updated

16 years ago
No longer blocks: 100574

Comment 28

16 years ago
*** Bug 100574 has been marked as a duplicate of this bug. ***

Comment 29

16 years ago
Unfortunately, Bug 100574, which was very clearly stated and contained precise
testcases to show exactly one well-defined bug, has just been marked as a
duplicate of this bug, which is very unclear and rather a collection of several,
mostly fixed problems which people observed over a long time with
www.sueddeutsche.de. Vice versa (or just closing this bug while leaving 100574
open) would IMHO have been a better idea.

I suggest that everyone who works on this bug have a close look at bug 100574
first, because otherwise the probability is very high that this bug will just be
closed although it is unfixed.

Furthermore, please add the keywords "dataloss" and "top100" soon to this bug.
It took many months until top100 appeared on 100574, it would be a pity if such
a delay would be happening again here. Also, the target milestone of 100574 was
mozilla 1.1alpha (which was very late anyway), so the target milestone of this
bug should be re-adjusted from "Future" to 1.1alpha as well.
-> dcone
Assignee: kmcclusk → dcone
Status: ASSIGNED → NEW
This happens on Linux as well.
OS: Windows 98 → All
Hardware: PC → All
*** Bug 154219 has been marked as a duplicate of this bug. ***
*** Bug 155541 has been marked as a duplicate of this bug. ***

Comment 34

16 years ago
See also http://virtshop.inshop.cz/inshop/scripts/show.asp?page=webmasters.htm
for a demonstration of the problem. The effect looks very similar to
http://www.sueddeutsche.de/ . Be warned though that you may (and probably will)
see some erotic ad banners on the page. (No hardcore porn.)

Comment 35

16 years ago
Oh, and I forgot to mention that this occurs to me on Win98SE Czech, with ATI
Radeon DDR, driver version 4.12.3050. Sorry about the spam.
fwiw, linux trunk cvs 2002-07-11, XFree86 Version 4.1.0.1, matrox g400 - bugs
Created attachment 91095 [details]
simple testcase

testcase contains nothing but an iframe with content about:blank. Corruption
occurs starting at ~2547px onwards on the page -- as reported by
|javascript:alert(window.pageYOffset);|. If you have trouble getting crap
visible, you might need to scroll up and down, preferably by grabbing the
scroll elevator|thumb bit.
Keywords: testcase
Summary: Page does not render / shows garbage (graphics adapter specific?) → Page does not render / garbage in iframes (graphics adapter specific?)

Comment 38

16 years ago
Also see bug 157389. Same IFRAME problem, different website.

Confirming the IFRAME rendering problem on my Windows 98 both in Mozilla 1.0 and
in Mozilla build 2002071404.

Matrox Millenium G400 (with some old may 1999 graphics driver because I got
stability/startup problems on my system when using the latest drivers:-( ) and
DirectX version 8.

Comment 39

16 years ago
The testcase of Tuukka Tolvanen produces display corruption on my
system as well.

Build: 2002-07-22-21 on Linux 2.2.14 (pentium 133) with an Ati rage pro 4Mb
graphics card.

As was already stated for bug 100574, the problem is quite annoying
for any reader of sueddeutsche.de, so I kindly ask, why this wasn't considered
a priority for Mozilla 1.1 beta?
*** Bug 161021 has been marked as a duplicate of this bug. ***
*** Bug 160951 has been marked as a duplicate of this bug. ***
*** Bug 162837 has been marked as a duplicate of this bug. ***

Comment 43

16 years ago
I can observe the bug whenever I view a page containing an IFRAME larger than
about 1740 pixels in any direction (also horizontal). I am using mozilla on a
LINUX with ATI Rage 128 graphics adapter, but I can also see it when I start
mozilla in a vncserver (virtual X server that can be observed "from anywhere on
the Internet and from a wide variety of machine architectures". (see 
http://www.uk.research.att.com/vnc))
*** Bug 163548 has been marked as a duplicate of this bug. ***

Comment 45

16 years ago
I experience this bug on my Mac G3-350 with an AT Rage 128 graphics (driver
version 1.1.16 [I believe this is the latest driver]) running OS X 10.1.5.
Is this an issue with some ATI graphics boards or DirectX.? If it is an issue
with Direct X why is Mozilla being written Direct X dependencies (for any
platform other than Windows)? OpenGL is cross platform and should replace Direct X. 

Also I hope this bug can be fixed soon as I experience it at ~10% of websites
visited. I don't know the degree of complexity in solving this bug, so I
understand if its resolution may take a while.

Comment 46

16 years ago
*** Bug 163853 has been marked as a duplicate of this bug. ***

Comment 47

16 years ago
*** Bug 163887 has been marked as a duplicate of this bug. ***

Comment 48

16 years ago
*** Bug 157389 has been marked as a duplicate of this bug. ***

Comment 49

16 years ago
*** Bug 164813 has been marked as a duplicate of this bug. ***
Alias: sueddeutsche
*** Bug 164846 has been marked as a duplicate of this bug. ***

Comment 51

16 years ago
maybe it should be mentioned at this point, that the 'garbage in iFrames'
problem at http://www.sueddeutsche.de is regarded as a main problem in germany,
because this is one of the most popular german newspaper-homepages and exactly
*this* problem is discussed over and over again in the forums at
http://www.heise.de/newsticker, which is *the* newsticker in german language for
all the computer-stuff, by its readers ("No, I won't use Mozilla ... look at
www.sueddeutsche.de...garbage over all") ...
Could we put the top100 keyword to this bug?
Thanks to all hackers for doing a great job! :-)

Comment 52

16 years ago
agreed.

+top100
-qawanted

whoa, the votes are collecting up.
Keywords: qawanted → top100

Comment 53

16 years ago
Bug 164625 seems to have fixed most of this, but iframes are still corrupted
while loading and scrolling. Trunk 2002090608 on WinME.

Comment 54

16 years ago
With my own compilation from today's CVS on Solaris I have neither
with www.sueddeutsche.de nor  with the simple testcase a problem. It seems to
be fixed.

CT: Do you have an example for the corrupted iframes mentioned in comment 53?

Comment 55

16 years ago
With the latest nightly build on Linux the problem seems indeed fixed.
(No more display corruption on sueddeutsche.de and with testcase).

Congratulations!
(Assignee)

Comment 56

16 years ago
marking WFM based on comments.  
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 57

16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020912 MultiZilla/v1.1.22
Newest nighty build for Windows installed over existing v1.1 with MultiZilla.

Sueddeutsche.de works for me, too. But I still see some flickering/snow while
images are not fully loaded and display. Also flickering a bit "more then usual"
when scrolling down. 
The good news is that the content is finally not scrambled anymore! Good work.

But obviously it's not yet perfect. Compare this subpage:

http://www.sueddeutsche.de/index.php?url=computer&datei=index.php

Usually the page should not be longer than below the copyright note (compared
with IE) but although the page is displayed correctly it's simply much too long.
I can scroll down approx. 5-6 times the normal size of the page. Hope someone
can confirm this.

Comment 58

16 years ago
The problem with the page length seems due to iframes with "height 10000px" in
the code of some subpages. Obviously IE truncates all the blank space below the
copyright note whereas Mozilla simply sticks strictly to the html source code.
Don't know if this is a bug or feature... At least it doesn't "look" too good. ;-)

Comment 59

16 years ago
I can confirm, that there is still garbage displayed during the first loading of
the page ... I was able to reproduce this behaviour with the testcases for 
Bug 91747
Maybe we should file a new bug therefore ...

Comment 60

16 years ago
Created attachment 99237 [details]
Screenshot while loading

As requested in comment #54.

It looks like the fix only applies when the iframe is done loading. Maybe bug
126592 is related to this.

Comment 61

16 years ago
Come to think of it, i've seen the iframe curruption while loading since atleast
trunk 2002070504. (bug 122063 comment #21)
Markus, CT, see bug 133770.
*** Bug 172559 has been marked as a duplicate of this bug. ***

Comment 64

16 years ago
*** Bug 172876 has been marked as a duplicate of this bug. ***
*** Bug 174413 has been marked as a duplicate of this bug. ***

Comment 66

16 years ago
Created attachment 102906 [details]
Page does not render correct

BuildID: 2002091014
OS: WinNT4.00.1381

Comment 67

16 years ago
*** Bug 181977 has been marked as a duplicate of this bug. ***

Comment 68

16 years ago
WFM with a nightly build from a couple of days ago on win2k.  verified.
Status: RESOLVED → VERIFIED

Comment 69

16 years ago
Please note that the layout of http://www.sueddeutsche.de has been completely
reworked (on May, 8th 2003). It no longer uses iframes (actually, in does not
use frames at all any more, just tables).

Thus http://www.sueddeutsche.de/ is no longer suitable as a testcase.

Incidentally, the HTML they use is still horrible -- it does not even correctly
declare an encoding! Also, the homepage still contains 33 pictures and has a
total size of almost 200 kB. The CSS file alone is 10 kB. Well, I guess some
people never learn...

Comment 70

16 years ago
I guess you are rigth ;-)

Comment 71

15 years ago
*** Bug 188241 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.