If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla repeating animation of images when it shouldn't

VERIFIED FIXED in mozilla0.9.1

Status

()

Core
ImageLib
P1
minor
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: Dan Rosen)

Tracking

Trunk
mozilla0.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [imglib])

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
load the attached image in ns4 and mozilla. under ns4, it switches frames once
and doesn't repeat. in mozilla it repeats very quickly.
(Reporter)

Comment 1

17 years ago
Created attachment 30673 [details]
the image

Comment 2

17 years ago
Gimp says:

  Background (2000ms)
  Frame 2 (100ms)

Dup of bug 68104.
no, this is not a dup.....

Comment 4

17 years ago
Yes, you're right. Sorry.

Comment 5

17 years ago
Created attachment 30810 [details] [diff] [review]
patch: proposed implementation for missing feature

Comment 6

17 years ago
Loop feature was not implemented in imgContainer. Here is one implementation
if needed.

Updated

17 years ago
Blocks: 66967

Comment 7

17 years ago
Bug 76500 should be marked as dup of this one.
No longer blocks: 66967

Comment 8

17 years ago
any particular reason why you removed bug 66967 from the "blocks" list? bug
66967 is a meta bug for tracking all problems related to the new Imagelib, and
this bug IS related to the new imagelib...

Comment 9

17 years ago
changing status to [imglib], also I see this behavior on W2k build 2001041804,
changing OS to all
OS: Mac System 9.x → All
Whiteboard: [imglib]

Comment 10

17 years ago
*** Bug 76500 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
Reproduced on WinNT using 2001-04-18-04. Adding patch keyword.

Updating summary from
"Image that doesn't animate in ns4 animates in mozilla" to
"Mozilla repeating animation of images when it shouldn't".
Keywords: patch

Updated

17 years ago
Summary: Image that doesn't animate in ns4 animates in mozilla → Mozilla repeating animation of images when it shouldn't

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1

Comment 12

17 years ago
*** Bug 77545 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
*** Bug 77707 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
Platform All.
Hardware: Macintosh → All

Comment 15

17 years ago
*** Bug 77712 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
Good job with the patch. I was wondering why all of a sudden my Gifs started
going crazy on my pages... Now if only we could get the patch in.... :-)

Comment 17

17 years ago
*** Bug 78141 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
Created attachment 32838 [details] [diff] [review]
updated patch

Comment 19

17 years ago
okay, this needs r= and sr=

Comment 20

17 years ago
r=pavlov

Comment 21

17 years ago
*** Bug 79447 has been marked as a duplicate of this bug. ***

Comment 22

17 years ago
*** Bug 79899 has been marked as a duplicate of this bug. ***

Comment 23

17 years ago
->dr to take patch
Assignee: saari → dr
Status: ASSIGNED → NEW
(Assignee)

Comment 24

17 years ago
patch looks good to me. i'll get sr and checkin asap.
Severity: normal → minor
Status: NEW → ASSIGNED
Priority: -- → P1

Comment 25

17 years ago
sr=hyatt
(Assignee)

Comment 26

17 years ago
fixed
(Assignee)

Comment 27

17 years ago
erm, really fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
*** Bug 80991 has been marked as a duplicate of this bug. ***

Comment 29

17 years ago
Verified fixed w2k build 2001051504
Verified fixed mac build 2001051504
Verified fixed linux build 2001051506
Status: RESOLVED → VERIFIED

Comment 30

17 years ago
*** Bug 81350 has been marked as a duplicate of this bug. ***

Comment 31

17 years ago
*** Bug 81184 has been marked as a duplicate of this bug. ***

Comment 32

17 years ago
*** Bug 84268 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.