App icons and the related Sophie's choice

RESOLVED FIXED in 2012-08-30

Status

Marketplace
General
P2
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: krupa, Assigned: basta)

Tracking

2012-08-30
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-kilimanjaro:-, blocking-basecamp:-)

Details

(Whiteboard: [needs-app-icon-stats])

(Reporter)

Description

6 years ago
Current situation:

1. App icons are optional
2. We do not specify what app icon dimensions are the most suitable for different devices.

With the current implementation-

Pros:
a) Makes app submission an easy-breezy experience. 

Cons:
a) Reduces the aesthetic appeal of Marketplace pages in general if we have too many apps without icons.
b) Difficult for users to scan for installed apps they want to use if many of them have default icons (particularly true for users on mobile devices).

However, given enough time we will have a sufficient number of apps which have no icons associated with them. Secondly, even if the developer specifies a 16px or 48px icon, upon resize we end up with very a blurry icon.

Which begs the question- Should we require app icons and in dimensions which are appropriate to the devices they plan to support? Note that this adds sufficient roadblock to developers who just want to upload an app and do not care/know about generating high-quality custom apps. On the flip side, most developers want their users to have a good experience and will go the extra mile to make that happen.

But coming back to difficult and heartrending decisions, do we make it easier for the developers to upload apps OR do we make it easy for the users to use the apps?
I think that trying to enforce quality standards on app developers might lead to a slippery slope. We should certainly provide the tools needed by developers to create a high-quality experience, but utlimately leave the choice to them. The web is messy like that :)

Our marketplace can, of course, place additional requirements over and above what's mandatory in the manifest. Therefore, I think icons should remain optional in the manifest specification, but that we should reject apps that don't have icons meeting our requirements in our marketplace (and possibly also place other such criteria such as screenshots).

If there are changes needed to the manifest to implement this correctly on the marketplace side, let me know, but I don't think there should be any.

Comment 2

6 years ago
I agree with Anant- the Marketplace should require an icon. We're building an ecosystem which provides apps to a fundamentally iconographic interface- icons are a must. I can live with the larger apps ecosystem not requiring them though.

I will abstain from commenting on krupa's use of "begging the question" :)

As the requirement for b2g is a 79x79px icon, my recommendation is for Marketplace to require at bare minimum a 128pxx128px icon (used in our interface), and allow them to provide a specific 79x79 icon for b2g.
(Reporter)

Comment 3

6 years ago
(In reply to Potch [:potch] from comment #2)
> I agree with Anant-  I can live with the larger apps ecosystem not requiring
> them though.

I worry that if we don't mention the marketplace requirements for icons in the MDN docs, it will lead to confusion when those apps fail validation during submission.
> 
> I will abstain from commenting on krupa's use of "begging the question" :)

Hope Aristotle and you can find it in your hearts to forgive me for using that phrase in that way. As I always say, English is not my first language ;)
I like required add-ons.  Fligtar?
Assignee: nobody → fligtar
Priority: -- → P1
Target Milestone: --- → 2012-06-07
Duplicate of this bug: 766686

Comment 6

6 years ago
For what it's worth, I agree with everything potch said and feel very strongly about requiring app icons (of at least 128x128 pixels -- maybe even double for retina purposes?).

If the web as a whole wants to make icons optional I guess that's their choice, but the Marketplace should look kick-ass; a bunch of those little open box icons from lazy developers is gonna make it hard to visually scan through apps.
(In reply to Wil Clouser [:clouserw] from comment #4)
> I like required add-ons.  Fligtar?

I assume you mean icons. And yes I totally agree that we should require icons. And they should at least be 54x54px for B2G/Gaia.
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?
blocking-kilimanjaro: --- → ?
(In reply to Chris Van Wiemeersch [:cvan] from comment #7)
> (In reply to Wil Clouser [:clouserw] from comment #4)
> > I like required add-ons.  Fligtar?
> 
> I assume you mean icons. And yes I totally agree that we should require
> icons. And they should at least be 54x54px for B2G/Gaia.

So be it.  Let's require 128x128 icons minimum.
Assignee: fligtar → nobody
Blocks: 766201
No longer blocks: 752013
Priority: P1 → P2
Whiteboard: [ddn]
Target Milestone: 2012-06-07 → ---
(Assignee)

Comment 9

6 years ago
(In reply to Matthew Riley MacPherson [:tofumatt] from comment #6)
> For what it's worth, I agree with everything potch said and feel very
> strongly about requiring app icons (of at least 128x128 pixels -- maybe even
> double for retina purposes?).

SVG, anybody?
(Assignee)

Comment 11

6 years ago
Merged:

https://github.com/mozilla/zamboni/commit/96e1535cddcc72f803eb37a8383fd779b0d4241b
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Reverted due to regressions: bug 772767 and bug 772771.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I'd strongly caution setting icon size requirements without conducting a study of the impact of what this does to our existing apps ecosystem on marketplace and understanding support on a per platform apps perspective. 

Android & Desktop are completed as you'll see here in the docs - https://developer.mozilla.org/en/Apps/Manifest. B2G needs this study too (I'll make this a priority when i get back from PTO).

My suggestion would be that an app developer has to support at least one of our "suggested" icon sizes, instead of picking one particular icon size out right (I don't think we need to be too selective IMO, just enough that a "suggested" icon is specified).
(Assignee)

Comment 14

6 years ago
This issue was discussed in another bug which I don't have the number of off-hand.

The requirement is important for the marketplace because low-resolution icons cannot be scaled up gracefully, while high-resolution icons can be scaled down gracefully. We require at least one icon to be 128x128 or larger, which is not a difficult requirement to meet and significantly improves the quality of our listings on Marketplace. Allowing developers to submit only low-resolution icons will mean that search results will include blurry and distorted icons, decreasing the apparent quality of the marketplace as a whole.

Currently, Google Web Store requires all apps to prove a 128x128 icon as well, so we're meeting parity with Chrome on this one.

The iOS app store requires a much larger array of icons to be included (57x57, 114x114, 72x72, 144x144, 512x512, and 1024x1024 for retina).
(In reply to Matt Basta [:basta] from comment #14)
> This issue was discussed in another bug which I don't have the number of
> off-hand.
> 
> The requirement is important for the marketplace because low-resolution
> icons cannot be scaled up gracefully, while high-resolution icons can be
> scaled down gracefully. We require at least one icon to be 128x128 or
> larger, which is not a difficult requirement to meet and significantly
> improves the quality of our listings on Marketplace. Allowing developers to
> submit only low-resolution icons will mean that search results will include
> blurry and distorted icons, decreasing the apparent quality of the
> marketplace as a whole.

There's ways to get around the distortion issue (scaling up I know isn't a good ideas.

Anyways, there isn't enough data to conclude that 128 x 128 is the right icon size to go with anyway until we effectively test this on B2G and know for sure this won't negatively affect the apps that currently exist on marketplace. Given the fact that there's well over 200 apps already listed on the marketplace, enforcing an icon requirement needs to be done carefully with an analysis in place, or else we'll create a mess we don't want to get ourselves into (especially on the evangelism side). 

I'd suggest doing the following steps to carefully determine the right step of action here:

- (B2G QA) Finish off the icon analysis on B2G that was similarly done for Desktop & Android
- (Marketplace Dev) Generate statistics of the current apps on the marketplace by icon size specified - specifically I'm looking to know the metrics of:

* Ratio of marketplace apps with 16 * 16 icon sizes / total apps count on marketplace
* Ratio of marketplace apps with 32 * 32 icon sizes / total apps count on marketplace
* Ratio of marketplace apps with 48 * 48 icon sizes / total apps count on marketplace
* Ratio of marketplace apps with 64 * 64 icon sizes / total apps count on marketplace
* Ratio of marketplace apps with 128 * 128 icon sizes / total apps count on marketplace
* Ratio of marketplace apps with 256 * 256 icon sizes / total apps count on marketplace

> 
> Currently, Google Web Store requires all apps to prove a 128x128 icon as
> well, so we're meeting parity with Chrome on this one.

Take note that on initial submissions we were not enforcing this requirement, so enforcing it now needs to be done carefully with a thorough analysis (or else, you end up in an evangelism battle, which is quite time consuming).

> 
> The iOS app store requires a much larger array of icons to be included
> (57x57, 114x114, 72x72, 144x144, 512x512, and 1024x1024 for retina).

Based on testing desktop & android web apps so far, there's no need for this. If an icon was to be enforced, as long as either 16 x 16, 32 x 32, 48 x 48, 64 x 64, 128 x 128, or 256 x 256 is included we should be okay.
Keywords: qawanted
Whiteboard: [needs-app-icon-stats]
(Assignee)

Comment 16

6 years ago
> There's ways to get around the distortion issue (scaling up I know isn't a good ideas.

Unless we have a script to call up the designer of all the 16x16 icons out there and have them fax us a 114x114 version of the icon, no, this isn't possible. Scaling tiny icons for **new app submissions** to the sizes that we need them is entirely out of the question and is certainly not up for debate.


Perhaps I misunderstand your point, but existing apps are **not affected by this change at all**. There is no developer or community impact because we simply resize existing app icons as needed. This requirement is in place to simply prevent new apps from being submitted with low resolution icons.

Developers can still submit apps with icons that are less than 128x128 and those icons will be used appropriately (to support future design guidelines), so this is a non-issue.

> Based on testing desktop & android web apps so far, there's no need for this.

Certainly not, but it goes to prove that these sizes should already be available for developers looking to port their applications to support the Marketplace. There should be no developer that is unprepared for a 128x128 icon requirement based on the current app landscape.

Delaying the deployment of this requirement will only have a negative impact on our current situation, as even more low-resolution app icons will be submitted and further prevent us from setting a standard in the future.
Mac dock icons are rendered at a 128-pixel maximum. B2G requires 54x54px. I think 128x128 is a reasonable requirement.

We can ask for more sizes later if necessary.
(In reply to Matt Basta [:basta] from comment #16)
> > There's ways to get around the distortion issue (scaling up I know isn't a good ideas.
> 
> Unless we have a script to call up the designer of all the 16x16 icons out
> there and have them fax us a 114x114 version of the icon, no, this isn't
> possible. Scaling tiny icons for **new app submissions** to the sizes that
> we need them is entirely out of the question and is certainly not up for
> debate.

I know scaling is out of the question, but that's not what I'm talking about here. 

Let me back up and ask this question - What is marketplace using the app icon from the manifest for and in what locations?

> 
> 
> Perhaps I misunderstand your point, but existing apps are **not affected by
> this change at all**. There is no developer or community impact because we
> simply resize existing app icons as needed. This requirement is in place to
> simply prevent new apps from being submitted with low resolution icons.
> 
> Developers can still submit apps with icons that are less than 128x128 and
> those icons will be used appropriately (to support future design
> guidelines), so this is a non-issue.

I don't follow. If the manifest validator enforces this or our docs indicates this, then existing apps that do not specify a 128x128 icon would be affected, unless we plan to grandfather them. The underlying question I'm asking then is - If I already have my app on the marketplace and it's accepted, but I don't have a 128x128 icon, what happens?

The underlying concern is that from my testing, I've seen 64x64 a much more common icon size specified, but not so much on the 128x128 situation. But having metrics here could better assess this. 

There's also the factor of "marketplace can't control manifests on external servers behaving how they would like them to behave always." That is because the developer, not marketplace, can change the manifests when they choose to.

> 
> > Based on testing desktop & android web apps so far, there's no need for this.
> 
> Certainly not, but it goes to prove that these sizes should already be
> available for developers looking to port their applications to support the
> Marketplace. There should be no developer that is unprepared for a 128x128
> icon requirement based on the current app landscape.
> 
> Delaying the deployment of this requirement will only have a negative impact
> on our current situation, as even more low-resolution app icons will be
> submitted and further prevent us from setting a standard in the future.

All I'm trying to understand is these things before a deployment is made on this:

1. If I have an app on the marketplace that does not specify a 128x128 icon, am I affected? Will my app be taken down or be sent a notice saying "you need to change something?"
2. When is marketplace making use of the icon from manifest and why does it need to be 128 x 128? Why not use something different like 64x64?
3. If my original manifest I submit uses a 128x128 icon, but later I don't use that icon by changing my manifest, what happens?


(In reply to Chris Van Wiemeersch [:cvan] from comment #17)
> Mac dock icons are rendered at a 128-pixel maximum. B2G requires 54x54px. I
> think 128x128 is a reasonable requirement.

That largely depends on the answers to the questions above. The root concerns being addressed here is about understanding root issues of why the 128 x 128 is needed and if that can affect existing apps on the marketplace.
(Assignee)

Comment 19

6 years ago
(In reply to Jason Smith [:jsmith] from comment #18)
> 1. If I have an app on the marketplace that does not specify a 128x128 icon,
> am I affected?

No.

>Will my app be taken down or be sent a notice saying "you
> need to change something?"

No. You may be notified asking you to add a higher resolution icon, but your app will not be disabled. Such a thing was never suggested or discussed.

> 2. When is marketplace making use of the icon from manifest and why does it
> need to be 128 x 128? Why not use something different like 64x64?

B2G uses 72x72 icons in the marketplace. Our latest designs use 128x128 icons in various locations. The policy is to always scale down, never up.

> 3. If my original manifest I submit uses a 128x128 icon, but later I don't
> use that icon by changing my manifest, what happens?

If you change any of your icons (no matter what size), your marketplace listing is unaffected. You must manually upload new icons to Marketplace. We don't actively spider manifests.
Fair enough, thanks for addressing my concerns. I have no issues with what's specified.
Assignee: nobody → mattbasta
Target Milestone: --- → 2012-07-26
Requiring icons wouldn't block basecamp - we could always just unpublish those apps if we felt strongly.  That said, I expect this to be closed next week anyway.  Basta: cvan is going to give you a hand with this next week.
blocking-basecamp: ? → -
blocking-kilimanjaro: ? → -
I think apps without icons should be unpublished and authors notified of the changes required. I think having apps without icons makes our marketplace look amateur.
(In reply to Matthew Riley MacPherson [:tofumatt] from comment #22)
> I think apps without icons should be unpublished and authors notified of the
> changes required. I think having apps without icons makes our marketplace
> look amateur.

We can evaluate which apps may need icon adjustments after this code lands.  Lets keep this bug focused.
Blocks: 766199
Target Milestone: 2012-07-26 → 2012-08-23
Target Milestone: 2012-08-23 → 2012-08-30
Duplicate of this bug: 775643
(Assignee)

Comment 25

6 years ago
Fixed, partially:

https://github.com/mozilla/zamboni/commit/5985e0074c4c8b47f360beecfa7b307e1c9a3401

The rest of the fix is to implement support for image assets, which is coming with bug 744648.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
jsmith: do we need to still do the survey that you mentioned?  If not, then shall we remove it?
jcarpenter, patryk: tagging you as a fyi.
Flags: needinfo?(jsmith)
Survey? I don't understand? What do you mean?
Flags: needinfo?(jsmith)
(Assignee)

Comment 28

6 years ago
We've had the 128x128 requirement for icons in production now for almost five months without any headaches. Image assets have landed, meaning that we won't be implementing any more icon requirements for a very long time (let's assume until B2G implements retina). I this this bug is done and no more work is required.
jsmith : your comment 15.  Survey, analysis... whatever.  Isn't it the reason why you placed in qawanted?

Removing qawanted based on comment 28.
Keywords: qawanted
Matt, just a fyi, 16 bit is now forced on b2g (bug 831438).  This happened about 4 days ago.  Not sure if that may cause any issues.
You need to log in before you can comment on or make changes to this bug.