Stand Alone Mail Menu: Add/Change/Move/Delete menu items

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
RESOLVED FIXED
17 years ago
9 years ago

People

(Reporter: Ninoschka Baca, Unassigned)

Tracking

({access, polish})

Trunk
All
Windows NT
access, polish
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3], comment 20, URL)

(Reporter)

Description

17 years ago
Build 2001-04-15-04: NT4
Haven't checked linux or mac yet.

Overview: This bug summarizes the changes that should be made to the Stand Alone 
window (double click onto a message in the thread pane) menu items. It includes 
mnemonic and accelerator issues as well.

1. Add
a. Menu Item:
- File|Print Plus (also needs "l" for mnemonic)
- File|New|Message (also needs "M" for mnemonic, Ctrl+M)
- File|New|Address Book Card (also needs "C" for mnemonic)
- Search  (Bugscape# 4617, Netscape only)

b. Mnemonics
- File| Attachments, need "A"
- File|Get New Message for , from "f" to "w"

c. Accelerator
- File|New|Blank Page to Edit, needs "Ctrl+Shift+N"
- Message|Mark|All Read (bug# 66681, from "A" to "Ctrl+Shift+C, now tbd)

2. Delete
a. Edit|Edit Draft (for normal messages. It should also not be present for draft 
messages because opening a draft message automatically places it in edit mode)
b. View|Message
c. View|Sort by
d. View|Messages
e. View|Folder Character Coding
(Reporter)

Comment 1

17 years ago
Note: File|Print Plus menu item (Netscape only)
Keywords: nsbeta1
QA Contact: esther → nbaca
(Reporter)

Comment 2

17 years ago
Assigning to Sean.
Assignee: sspitzer → ssu
(Reporter)

Updated

17 years ago
Keywords: access, ui

Comment 3

17 years ago
> - File|Print Plus (also needs "l" for mnemonic)

Netscape only.

Comment 4

17 years ago
marking nsbeta1+
Priority: -- → P3
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.1

Comment 5

17 years ago
moving to 0.9.2
Target Milestone: mozilla0.9.1 → mozilla0.9.2
(Reporter)

Comment 6

17 years ago
*** Bug 80575 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Standalone Window stuff (spec is outdated from when we couldn't navigate in the 
Standalone window yet).  Updating spec right now, but until then:

File Menu, Disable:
Open Message
Rename Folder (or Account)...

Edit Menu, Disable:
Undo 
Redo 
Cut
Paste
Edit Draft
Select --->
Folder Properties 

View Menu, Disable:
Message
Sort by --->
Messages --->
(Reporter)

Comment 8

17 years ago
Addition to 1b for Mnemonics:
- File|Get New Messages for|Get All New Messages, needs "G".

Comment 9

17 years ago
moving to 0.9.3
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 10

17 years ago
Missed 0.9.3.
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 11

17 years ago
moving to 0.9.5
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Reporter)

Updated

17 years ago
QA Contact: nbaca → olgam

Comment 12

17 years ago
Branch build 2001-09-17: Windows 2000

I add some issues for Stand Alone window.
To get it - double click on any message from 3-pane window.

1. Add
 a. Menu Item
    - File|Print Preview - Ctrl+Shift+P, need "Print Preview" with "V"  
underlined.  Also shortcut: Ctrl+Shift+P.  (Bug #17006)
        
 b. Mnemonics 
    - File|Print Plus|Print Center, need "C" for "Print Center
    - File|Print Plus|Printer Supplies, need "S" for "Printer Supplies"
    - File|Print Plus|Printing Services, need "E" for "Printing Services"
    - File|Get New Messages for|Get All New Messages, need "G".
    - File|Offline|Work Offline, need "W". 
    - View|Character Coding|More - needs mnemonic but it is not specified in 
Spec. 

 c. Add Ellipsis
    - File|Offline|Offline Setting... (... - at the end) since it brings another 
 dialog. 
Depends on: 75622

Comment 13

17 years ago
Print Plus issues are covered in a bugscape bug. Character Coding issues covered 
in a separate bugzilla bug.

Comment 14

17 years ago
moving to 0.9.6
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Updated

17 years ago
Blocks: 104166

Comment 15

17 years ago
moving to 1.0 and nominating.
Keywords: nsbeta1
Whiteboard: [nsbeta1+]
Target Milestone: mozilla0.9.6 → mozilla1.0

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla0.9.9

Updated

17 years ago
Blocks: 122274
Status: NEW → ASSIGNED
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla0.9.9 → mozilla1.2

Comment 16

16 years ago
I remove nsbeta1- keyword - it was for MachV.
Keywords: nsbeta1-

Comment 17

16 years ago
Now I add 'nsbeta1' keyword for Buffy. Sorry, it's faster to edit multiple bugs
at once than manually go to each and remove minus.
Keywords: nsbeta1

Comment 18

16 years ago
Mail triage team: nsbeta1+/adt3
Keywords: nsbeta1 → nsbeta1+, polish
Whiteboard: [adt3]

Comment 19

15 years ago
Summarizing issues from this bug.  Changes performed, and still required, track 
very closely with bug 75622, the parallel issue for the 3-Pane window menu.

Comment 0:
1a
 - File|Print Plus -- NO LONGER PART OF SPEC
 - File|New|Message (with mnemonic & hotkey) -- DONE
 - File|New|Address Book Card -- NOT DONE
 - Search menu -- NO LONGER PART OF SPEC (Netscape only?)
1b
 - File|Attachments mnemonic -- DONE
 - File|Get New Message For mnemonic change -- DONE
1c
 - File|New|Composer Page shortcut -- DONE
 - Message|Mark|All Read -- change complete (but see bug 66681)
2a
 - Edit|Edit Draft -- item is obsolete
2b
 - View|Show/Hide|Message Pane -- DONE [hidden]
2c
 - View|Sort By -- DONE [hidden]
2d
 - View|Messages -- DONE [hidden]
2e
 - View|Folder Character Coding -- item is obsolete
   (in 3pane, this feature is in Folder Properties)

comment 7:
 disable Open Message -- DONE [hidden]
 disable Rename Folder -- DONE [hidden]
 Edit menu changes -- Currently OK, spec needs updating [note 1]

comment 8:
 - File|Get New Messages for|Get All New Messages  mnemonic -- NOT DONE

comment 12:
 - File|Print Preview (including mnemonic) -- DONE;
        Print Preview shortcut  -- NOT PART OF SPEC
 - File|Offline|Work Offline mnemonic -- DONE
 - File|Offline|Offline Setting ellipsis -- NOT DONE
 - View|Character Coding|More mnemonic -- NOT DONE


[note 1] Suggested specification change:
The Edit menu items from the 3pane should be carried over as follows:
    Undo, Redo, Copy should be (and are) available when appropriate
    Cut, Paste should be hidden (currently always disabled)
    Select All should be maintained (and is).  The only other Select option 
right now is 'Select|Thread' (which is disabled); 'Select|Flagged' (bug 72823) 
may be available soon, and should be disabled in the standalone as well.  
(Ideally, the Select menu would change to Select All, without a submenu, for 
this window.)
    Folder Properties should be (and is) hidden



Items still NOT DONE (repeating from above):
 - File|New|Address Book Card -- NOT DONE

 - File|Get Messages For|Get All New Messages mnemonic -- NOT DONE
 - View|Character Coding|More mnemonic -- NOT DONE
 - File|Offline|Offline Setting ellipsis -- NOT DONE

The last three of these items are cited in bug 75622 and presumably would be 
fixed when it is fixed, as the texts for the menus is shared for the two 
windows.  Only the first item -- New Address Book Card -- remains unimplemented: 
The menu item is part of the 3-pane menu but not carried over to the standalone.

Comment 20

14 years ago
(In reply to comment #19)
> Items still NOT DONE (repeating from above):
>  - File|New|Address Book Card -- NOT DONE

After the checkin for bug 75622, this is the only thing left now.
Whiteboard: [adt3] → [adt3], comment 20
Product: Browser → Seamonkey
Assignee: ssu0262 → mail
Status: ASSIGNED → NEW
Priority: P3 → --
QA Contact: olgam
Target Milestone: mozilla1.2alpha → ---

Comment 21

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 22

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 23

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 24

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 25

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 26

9 years ago
Multiple issues in this bug, nearly all are fixed now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.