Closed Bug 769118 Opened 9 years ago Closed 4 years ago

Can't dismiss missed reminders for recurring events (CalDAV)

Categories

(Calendar :: Lightning Only, defect)

Lightning 2.2
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1344068

People

(Reporter: dazquick, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.43 Safari/536.11

Steps to reproduce:

Lightning 1.5.1 add-on in Thunderbird 13.0.1. Mac OS X 10.6.8. Google Calendar connected using CalDAV (neither 'cache' nor 'read only' selected).

Reminder for missed (recurring) event appeared. 


Actual results:

Clicking 'dismiss' or 'dismiss all' buttons results in title bar of dialog flashing briefly from '1 reminder' to '0 reminder' back to '1 reminder'. Impossible to dismiss reminder dialog. Nothing in error console.


Expected results:

Reminder dialog should have disappeared.

Workaround is to unselect 'Show missed reminders'. Re-enabling this option results in the missed reminder re-appearing on next boot. Event was created by another user and I am one of several invitees.

I suspect this is part of a much larger, long-standing bug. There's a 9-page thread on mozillaZine with others experiencing similar bugs with missed reminders dating back to 2008:

http://forums.mozillazine.org/viewtopic.php?f=46&t=623218

Possibly related to X-MOZ-LASTACK?
Can you set the preferences "calendar.debug.log" and "calendar.debug.log.verbose" to true, and restart Thunderbird. When the reminder pops up, before attempting to dismiss it, click back to the main Thunderbird window, and go to Tools -> Error Console and Clear the existing contents. Go back to the reminder dialog and try to dismiss the reminder once, then post the messages that appear in the Error Console.
Attached file Error console output
Thanks for looking into this Matthew. Output from error console attached. I'm the me.surname participant.
It looks like the item is sent to the server with a modified X-MOZ-LASTACK property and appears to be accepted, but when it is requested from the server again the X-MOZ-* properties are missing from the item. Without the X-MOZ-LASTACK property it appears to Lightning that the reminder was never dismissed, which causes it to re-fire.
I have the same problem - using CalDav to connect to a remote Google Calendar. I cannot dismiss recurring event that was shared with me by someone else.
Something very similar here, I can not dismiss any alarms anymore since about a week (Lightning 1.9?). Running Ubuntu 12.04 amd64 and several CalDAV calendars on a Sogo-server.
It's not restricted to recurring events either.

A cumbersome workaround is to disable local caching of the agenda, restart Tbird and enable local copies again (in order to be able to work offline). That takes up to 20 minutes and more CPU than I would like, rendering the pc almost useless.
After that things work for a while, but once an event comes up that does not want to be dismissed, all following events join the list and keep bothering me every 15 minutes or so.
I end up shutting down Tbird completely and only open it twice a day out of annoyance. That is not a good situation for business use.
I would not like to disable alarms for missed events, since 'missed' often means if I hurry I can still get it done on time.

cheers
Tom
Restarted Tbird, waited for the alarms to pop up. Cleared the error log and clicked 'dismiss all' once.
Output is some 23 times the following error message:

Timestamp: 11-12-12 10:51:13
Error: this.mItemInfoCache[aNewItem.id] is undefined
Source File: file:///usr/lib/mozilla/extensions/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendar.js
Line: 660

cheers
Tom
I guess that this bug is a duplicate of Bug #732393?
(In reply to Daniël van Eeden from comment #8)
> I guess that this bug is a duplicate of Bug #732393?

The problem detailed in comment #6 appears to be the same as Bug 732393, but based on the logs from the original problem it's a separate issue.
I'm getting this same situation in Lightning 1.9 in Thunderbird 19 when attempting to dismiss notifications on events created by CalDAV Sync on my Android phone instead of from Lightning. This is against my Owncloud sever (SabreDAV)

This is potentially a simple bug with an easy fix as the error message points out: Line 660 in calDavCalendar.js (in doModifyItem) is assuming the item is in the cache. Maybe it being created elsewhere (as in my phone or the above shared calendar example) causes it not to be there?

let wasInboxItem = this.mItemInfoCache[aNewItem.id].isInboxItem;

Perhaps it's just a matter of checking first? Or does it need to be in mItemInfoCache? Could do something like this: 

let wasInboxItem = (typeof this.mItemInfoCache[aNewItem.id] !== 'undefined') && this.mItemInfoCache[aNewItem.id].isInboxItem;
Urp, my bad, that's the Firefox ver, my TB is 17.0.3
skomorokh, could you test Lightning 1.9.1? It is supposed to fix some problems regarding caching. For full list of changes and download location see http://blog.mozilla.org/calendar/2013/02/lightning-1-9-1-release-candidate-available/
I can confirm that Lightning 1.9.1 (available here: https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/1.9.1) fixes the issue for me.  Thanks!
This problem has returned for me as of about 2 hours ago.  I've posted lots to other related bugs in the past, but I'm not sure which bug is the current one because there are multiple posts and a meta bug.  This is the most recent activity that came up in a search.

I've had Lightning 1.9.1 since pretty much the day it was issued, and it seemed to fix the problem; I haven't seen the problem resurface until today.  I also noticed that reminders on my smartphone for the same event have become VERY LOUD, not sure if it's coincidental.
I can confirm this also just started showing up for me. I'm unable to snooze or dismiss reminders. The only way I can get a reminder to go away is to delete the issue.

Has there been some change to Google's implementation of CalDAV that might be causing this?

Thunderbird 17.0.5 
Lightning 1.9.1
Windows 8
Syncing with Google Calendar using CalDAV
I can also confirm that this issue has returned. I am using Seamonkey version 2.17 and Lightning 2.2b1 with CalDAV and windows 7.
I can confirm  this (Thunderbird 17.0.5, Lightning 1.9.1, Google Calendar + CALDAV)
Ditto here.
I've managed to get something like a functional work-around going for this issue that's been around for a few *years* now.

I've dropped the Google Calendar Provider as completely surpluvous - hoping it would've fixed this issue - it doesn't - and rather making use of Google's native CalDAV protocol.

Find the Calendar ID from the g'cal properties & use https://www.google.com/calendar/dav/$DALID/events , but remove the reminder option, as it's completely broken IMHO.
Allows for bi-directional RW-sync.

I have enough Android devices able to give me those reminders that I might otherwise miss - less distracting than a dialogue I can't dismiss.

This is *such* a long running issue, saying that it's all Google's fault for not being 110% RFC-compliant is a complete cop-out, as I'm able to use other CalDAV clients (such as OS/X native iCal app, iOS) absolutely *fine* with probably the biggest mail & WebDAV servers being used out there atm.
There doesn't seem to be an actual error occurring -- the Dismiss box simply isn't going away.  Here's one console log content that comes up when pressing the Dismiss button when it fails:

CalDAV: send: BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:America/Los_Angeles
X-LIC-LOCATION:America/Los_Angeles
BEGIN:DAYLIGHT
TZOFFSETFROM:-0800
TZOFFSETTO:-0700
TZNAME:PDT
DTSTART:19700308T020000
RRULE:FREQ=YEARLY;BYDAY=2SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:-0700
TZOFFSETTO:-0800
TZNAME:PST
DTSTART:19701101T020000
RRULE:FREQ=YEARLY;BYDAY=1SU;BYMONTH=11
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20130408T052223Z
LAST-MODIFIED:20130415T005334Z
DTSTAMP:20130415T005334Z
UID:92856606-55fc-443a-9810-e168dcf390a7
SUMMARY:Doctor Who
STATUS:CONFIRMED
RRULE:FREQ=WEEKLY
X-MOZ-LASTACK:20130415T005334Z
DTSTART;TZID=America/Los_Angeles:20130414T123000
DTEND;TZID=America/Los_Angeles:20130414T133000
X-LIC-ERROR:No value for LOCATION property. Removing entire property:
SEQUENCE:2
TRANSP:OPAQUE
X-MOZ-GENERATION:3
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT15M
DESCRIPTION:This is an event reminder
END:VALARM
END:VEVENT
END:VCALENDAR

CalDAV: recv: 

CalDAV: Item modified successfully on Tom and Anthony Joint

CalDAV: send(https://www.google.com/calendar/dav/3k7fo7egba00ogijevme0452qc%40group.calendar.google.com/events/): <?xml version="1.0" encoding="UTF-8"?>
<C:calendar-multiget xmlns:D="DAV:" xmlns:C="urn:ietf:params:xml:ns:caldav"><D:prop><D:getetag/><C:calendar-data/></D:prop><D:href>/calendar/dav/3k7fo7egba00ogijevme0452qc%40group.calendar.google.com/events/92856606-55fc-443a-9810-e168dcf390a7.ics</D:href></C:calendar-multiget>

CalDAV: recv: 
<D:multistatus>
 <D:response>
  <D:href>/calendar/dav/3k7fo7egba00ogijevme0452qc%40group.calendar.google.com/events/92856606-55fc-443a-9810-e168dcf390a7.ics</D:href>
  <D:propstat>
   <D:status>HTTP/1.1 200 OK</D:status>
   <D:prop>
    <D:getetag>"63501657861"</D:getetag>
    <caldav:calendar-data>BEGIN:VCALENDAR
PRODID:-//Google Inc//Google Calendar 70.9054//EN
VERSION:2.0
CALSCALE:GREGORIAN
X-WR-CALNAME:Anthony and Tom Joint
X-WR-TIMEZONE:America/Los_Angeles
X-WR-CALDESC:For stuff Anthony wants to book w/Tom and Tom wants to book w/
 Anthony.\n
BEGIN:VTIMEZONE
TZID:America/Los_Angeles
X-LIC-LOCATION:America/Los_Angeles
BEGIN:DAYLIGHT
TZOFFSETFROM:-0800
TZOFFSETTO:-0700
TZNAME:PDT
DTSTART:19700308T020000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=2SU
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:-0700
TZOFFSETTO:-0800
TZNAME:PST
DTSTART:19701101T020000
RRULE:FREQ=YEARLY;BYMONTH=11;BYDAY=1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
DTSTART;TZID=America/Los_Angeles:20130414T123000
DTEND;TZID=America/Los_Angeles:20130414T133000
RRULE:FREQ=WEEKLY
DTSTAMP:20130414T212421Z
UID:92856606-55fc-443a-9810-e168dcf390a7
CREATED:20130408T052223Z
DESCRIPTION:
LAST-MODIFIED:20130414T212421Z
LOCATION:
SEQUENCE:2
STATUS:CONFIRMED
SUMMARY:Doctor Who
TRANSP:OPAQUE
X-LIC-ERROR;X-LIC-ERRORTYPE=VALUE-PARSE-ERROR:No value for LOCATION propert
 y. Removing entire property:
X-MOZ-GENERATION:2
BEGIN:VALARM
ACTION:DISPLAY
DESCRIPTION:This is an event reminder
TRIGGER:-P0DT0H15M0S
END:VALARM
END:VEVENT
END:VCALENDAR
</caldav:calendar-data>
   </D:prop>
  </D:propstat>
 </D:response>
</D:multistatus>

aChangeLogListener=undefined
calendarURI=https://www.google.com/calendar/dav/3k7fo7egba00ogijevme0452qc%40group.calendar.google.com/events/ 
iscached=true
this.mQueuedQueries.length=0

[calFilterProperties] Applying filter:
  start: 0
  end: 0
  status: 15
  due: 15
  category: null
Confirmed with Lightning 2.2b1 on a google calendar via CalDAV.

Normal log-status only creates the following notification in the error-console:

CalDAV: Item modified successfully on HauptkalenderDAV
aChangeLogListener=undefined
calendarURI=https://www.google.com/calendar/dav/me%40googlemail.com/events/
iscached=false
this.mQueuedQueries.length=0

No button of that reminder window will let you get out of the situation.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: Lightning 1.5 → Lightning 2.2
Google recently broke its CalDAV implementation on Google Calendar i.e. they no longer store the information send by Lightning regarding snoozed or dismissed reminders. If you want to confirm this problem please use a reliable CalDAV server but not Google Calendar.
I'd might be mistaken, but it seemed like this was done in https://bugzilla.mozilla.org/show_bug.cgi?id=769118#c6
Thanks for the information though.
Mr. Louwrier may have been using pre-1.9.1, which had other issues that have been fixed.  My gut feeling is to be satisfied with Mr. Sitter's Google Calendar explanation, because on my system the issue now comes and goes nonsensically with no apparent changes to Lightning settings, cache state, or anything else.  Previous to 1.9.1 it would come randomly, but didn't go away without intervention.  An external agent such as changes to Google's server code would be consistent with what I'm seeing.  Other things would be, too, but ... FWIW I'm going to give Lightning the benefit of the doubt on this one until someone reproduces the problem with Lightning 1.9.1 and a known-reliable CalDAV server.

(In reply to Martin F. from comment #23)
> I'd might be mistaken, but it seemed like this was done in
> https://bugzilla.mozilla.org/show_bug.cgi?id=769118#c6
> Thanks for the information though.
The problem at my side now happens not only for recurring events but for all. I even removed calendar (been using CalDAV) and installed Google Calendar provider plugin and entered url to private xml file (I am not sure if this plugin also uses CalDAV or not) but I can't still dismiss any event!
(In reply to wrobel.przemyslaw from comment #25)
> The problem at my side now happens not only for recurring events but for
> all. I even removed calendar (been using CalDAV) and installed Google
> Calendar provider plugin and entered url to private xml file (I am not sure
> if this plugin also uses CalDAV or not) but I can't still dismiss any event!

That is true. I can also confirm this. I was using this procedure along with google calendar provider and started to see this issue. The switched to calDAV and had the same issue. Now I have turned off reminders for all the calendars.
Are #804009 and #769118 dupes or blockers of each other? If so, could someone please set them appropriately?

Also, there is a workaround (from  http://forums.mozillazine.org/viewtopic.php?f=46&t=623218&sid=f7f5a7024a07a14970422341d51b3bba&start=135 )

The following worked for me with Google Calendars that would not dismiss:

Tools > Options
Calendar tab
Reminders sub-tab
Where is says, "When a Reminder is Due:", un-check "Show missed reminders"
Hit OK

Now the missed reminders that wouldn't dismiss should go away.
This was a problem with Google's calendar feeds. They have the problem now, I have enabled event reminders again in Thunderbird and they are dismissed properly now.
Seems to have been fixed for me too...
Not fixed for me; I have three repeating google calendar reminders that keep showing up, both on an icedove (Debian Wheezy) and firefox (kubuntu) system.
(In reply to lohner from comment #30)
> Not fixed for me; I have three repeating google calendar reminders that keep
> showing up, both on an icedove (Debian Wheezy) and firefox (kubuntu) system.

Are you using the caldav or ical link?

It seems to work for the caldav link for me in any case. Using Thunderbird 17.0.5 with Lightning 1.9.1
BTW here is the link for the issue that I'm pretty sure was the cause of the problem:
https://code.google.com/p/google-caldav-issues/issues/detail?id=69&can=1&q=dismiss
https://www.google.com/calendar/dav/nnnnnnnnnnnnnnnnnnnnnnnnnn@group.calendar.google.com/events
I'm using the caldav link...  tbird 17.0.6 with Lightning 1.9, installed via apt: 
ii  xul-ext-lightning                          1.9+build1-0ubuntu1        amd64                      Calendar Extension for Thunderbird
Ah, could be a 1.9 vs. 1.9.1 issue (even though I'm not using the calendars offline), see https://blog.mozilla.org/calendar/category/lightning/

This version fixes an issue that prevents some events from being modified and some reminders from being dismissed in CalDAV calendars with Offline Support enabled – those affected are encouraged to test this build. If you have seen an error message with “this.mItemInfoCache[aNewItem.id] is undefined”, this is you! Be sure to reset your cache, by unchecking the “Offline Support” checkbox, restarting, then checking it again.

Changelog here: https://bugzilla.mozilla.org/buglist.cgi?resolution=FIXED&query_format=advanced&target_milestone=1.9.1&product=Calendar&list_id=6608373
Hi,
Only started to get updates on this bug a couple of days ago. (??).
As suggested in comment #24 is was indeed using Lightning 1.9 on Ubuntu 12.04 / 64amd.
I got a compatible version of 1.9.1 from somewhere (not in the repositories) and installed it locally. That did solved my issue with the offline calendars and sticking reminders.
Server is a Ubuntu 12.10 with Sogo 2.x (running nightlies).

BTW: 1.9 is still in all repositories for Ubuntu including the most current production (13.04) and development branches, it seems no-one has pushed 1.9.1 there and many users may still be fighting this issue unnecessarily.

Thanx for fixing this.

regards
Tom
I'm running 1.9.1 on Windows 7 x64 SP1, and have disabled offline calendars. I still have this problem.

As for comment #22, it never ceases to amaze me that software teams identify outside problems as the source of a bug as if that alleviates them from responsibility.

It wasn't good practice when people blamed Microsoft and said "just use something else," and it's not good practice to blame Google. Lightning is a client-side tool and should make adjustments to accommodate the largest purveyor of CalDAV services in the world.

And finally, my argument is well-founded regardless of whether or not I offer to "pitch in and fix it myself." While that's another favorite meme of the FOSS community (e.g. "Hey, if it's so important to you, we welcome pull requests!"), it's also flawed in that feedback is feedback, and should be taken on its own merits regardless of whether or not it's backed-up by substantive offers to help.
(In reply to G. Richard Bellamy from comment #36)
> I'm running 1.9.1 on Windows 7 x64 SP1, and have disabled offline calendars.
> I still have this problem.
> 
> As for comment #22, it never ceases to amaze me that software teams identify
> outside problems as the source of a bug as if that alleviates them from
> responsibility.
I think you overestimate the "software team" behind Lightning. We are very low on active contributors, there is me and a handful of people that have time once in a while to work on Lightning between job, wife and kids. With the little time left we try to take care of the most pressing issues, which is right now making sure the builds run, fixing major bugs (like: Lightning cannot be used at all because of a regression or change in the Mozilla Platform) and doing some minimal testing to make sure its not broken.

I agree (and I bet Stefan does too) that dismissing alarms is a vital feature, but from the looks of this bug I don't think its just one issue that is easy to identify and fix. Dismissing recurring events works fine for me, as some others have confirmed. Therefore I cannot debug this issue.

> And finally, my argument is well-founded regardless of whether or not I
> offer to "pitch in and fix it myself." While that's another favorite meme of
> the FOSS community (e.g. "Hey, if it's so important to you, we welcome pull
> requests!"), it's also flawed in that feedback is feedback, and should be
> taken on its own merits regardless of whether or not it's backed-up by
> substantive offers to help.

Feedback is very well welcome, Stefan merely asked for confirmation with another caldav server. This bug is (in general!) about dismissing reminders on caldav servers, not specific to Google Calendar. Nevertheless, we have taken action to make sure Google is aware of the issue and at least partially they seemed to have fixed this.

In fact, the best kind of feedback are reliable steps to reproduce. This doesn't just mean "it doesn't work for me when I dismiss a specific recurring reminder I happen to have in my calendar", but steps from a clean state to the bug with any edge case configuration that may apply (for example: 1. subscribe to a calendar where I am not owner (possible edge case) 2. create a recurring event in the Google Calendar UI 3. Modify that recurring event to have a reminder in the past 4. Synchronize in Lightning 5. Dismiss reminder. My extension used are ...)

Note also that by coincidence, a member of the team is working on an alternative that will allow you to dismiss the alarms locally, which will fix the problem for Google Calendar. Search bugzilla for details.

Thank you for your understanding, I hope you see our situation a little better now. If you would like to discuss further, please refrain from adding a comment to this bug, I am happy to reply via email or in the mozilla.support.calendar newsgroup if you cc me.
Duplicate of this bug: 918137
I can confirm the bug under Icedove 17.0.10 + Lightning 1.9.1 under RHEL 6.4 + EPEL, working against Zimbra 8.0.6_GA_5922 (build 20131203103753).
Not sure if you consider this a reliable calendaring server, but it has nothing to do with Google :-P

The issue appears only with recurring events I create myself. I guess (!) that it might be series where I have modified one individual appointment. My workaround is to remove the alarm from the specific appointment causing the trouble, then the reminder disappears. Some people seem to say that alarms coming after the "sticky reminder" would also stick; I can NOT confirm this observation.

If I set the debug options as suggested, and dismiss the sticky reminder, I get 3 events in the console:

CalDAV: Item modified successfully on Zimbra Calendar
--
aChangeLogListener=undefined
calendarURI=https://mail.corp.redhat.com/dav/elavarde%40redhat.com/Calendar/ 
iscached=true
this.mQueuedQueries.length=0
--
[calFilterProperties] Applying filter:
  start: 4
  end: P7D
  status: null
  due: null
  category: null
--
and the event doesn't disappear.

Hope this helps fix the issue...
I've got same problem, but have a guess: reminders are not dismissed for incoming events (i.e. that I'm invited to, not ones I've created myself).
Sorry, my mistake. Via CalDav, Reminders are not dismissed at all: it's my own calendar, and events I created. (it's same calendar via GDATA provider 0.32, where reminders cannot be dismissed for recurring event I invited to).
My workaround is to edit the event (just the specific occurrence, not all) and set "no reminder" for it.
In my testing of tb 38a2 and lightning 4.0a2.

This seems to be fixed with calendar.icaljs=true
Bug 496889 should help here.
I also cannot dismiss reminders for past events.

Thunderbird 38.2.0
Lightning 4.0.2
Calendar stored on server using Horde Groupware 4.1.1.
(In reply to travneff from comment #42)
> My workaround is to edit the event (just the specific occurrence, not all)
> and set "no reminder" for it.

I tried this as well, but my changes are not being saved. The server version just overwrites my local event every time.
I am seeing the same error on a Red Hat Enterprise Linux 7.1, TB 38.2, Lightning 4.0.2

I have set up my Google Calendar as CalDav with the following Location:

https://apidata.googleusercontent.com/caldav/v2/$email_address/events

The Calendar syncs fine, however I see 30 Reminders for reoccurring Meetings. Clicking on any of the buttons (Snooze, Dismiss, Snooze all for, Dismiss all) does not do anything (the window is not closing for a second, or the window title flashing). It just does not react to the buttons.

The Google Account is a Google for work Account and uses 2 Factor Auth.

If you need any further data, please let me know.
Same here. Thunderbird 38.2.0, Lightning 4.0.2.  None of the workarounds fix the problem.

Ha-Duong
I re-encountered this - am attaching debug trace per comment #1 ..... (previously reported this in bug 1146576. In that case the problematic reminder just vanished one day about a month after it appeared!. So there is hope,  if you wait long enough :-( )
Same bug here. Thunderbird 38.2.0, Lightning 4.0.2.1. Has been there for months. Nothing works. Very annoying.
I had to disable and enable the Lightning to stop the annoying alerts.

Thunderbird 38.3.0 on Windows 10.
I have the same issue with an Exchange calendar (accessed using the Exchange EWS plugin). Some recurring events can't be dismissed, and just keep popping up.
Same problem since 4.0.4.1 and Provider for Google Calendar 1.0.4
I honestly can't recall a time that I didn't have this, and I've been a Thunderbird user for years. It's been going on with my installs (various computers) over the last four years,

I will say that whilst I have seen it on Linux, I have never seen it on the Mac version.

It applies to both Microsoft Exchange and GMail calendars.
(In reply to me from comment #54)
> I will say that whilst I have seen it on Linux, I have never seen it on the
> Mac version.
This is definitely affecting me on OSX and is currently keeping me from switching to Thunderbird for my calendar.  =[
Please note this bug is actually about CalDAV, not the Provider for Google Calendar. I am tempted to open a new bug to replace this one for the caldav issues and create a separate one for the provider if it doesn't already exist. I am aware of the provider issues, but I haven't seen any logs that would help me fix it for CalDAV. What I need is 1) enable debugging prefs and restart 2) wait for alarm and clear logs 3) dismiss alarm, do nothing until it appears again 4) save all logs to a text file and attach here. Also, description about specific type of event this happens with, e.g. meeting invitations created by others, and information about the caldav server.
I haven't worked on Thunderbird before, but I'd be happy to lend a hand gathering logs.  Let me figure out how to enable debugging and I'll post some info as soon as I can.
(In reply to Philipp Kewisch [:Fallen] from comment #56)
> 1) enable debugging prefs and restart 
Can you elaborate on how one might do that?  I haven't been able to find any instructions and I don't see anything in preferences or anywhere else.
(In reply to Philipp Kewisch [:Fallen] from comment #56)
> What I need is 1) enable debugging prefs
> and restart 2) wait for alarm and clear logs 3) dismiss alarm, do nothing
> until it appears again 4) save all logs to a text file and attach here.
> Also, description about specific type of event this happens with, e.g.
> meeting invitations created by others, and information about the caldav
> server.

I just created that log and could send it to you. I'd prefer not to post it as I would prefer not having to remove all personal details / email addresses etc. Does that make sense?
The reminder doesn't even disappear at all. I wonder if it might've to do with the fact that the reminder is added for an email list that I'm a member in, but it's not directly addressed to me.
I had this problem. Struggled with it for months.  Tried to dismiss certain recurring events with no luck.  They popped back up and when tried to dismiss I would get that "Item has recently been changed on the server ..." pop-up box.  So, I looked into my T-bird Profiles folder (it's usually located on path: C:\Users\{your user name}\Appdata\roaming\Thunderbird\Profiles\{xxxxx}.default) Inside that *.default folder you will find a folder titled "calendar-data".  When you open that folder you will see 3 *.sqlite files.  These are the databases where your calendar stuff is located.  The biggest of these, in my case, was the file titled "cashe.sqlite"  You will need to be able to access the data in this file because it contains all of the event data for your lightning calendar.  

To access this file I recommend getting the Firefox add-on called, "SQLite Manager".  After installation you will be able to open this add-on by clicking on the tools menu in Firefos.  Load the cashe.sqlite file and look through all of the data.  What I found was what I suspected I would find; the recurring event that I was trying to dismiss had a double entry.  In other words, this cashe.sqlite file had somehow gotten corrupted.  Don't know how and don't care how. The main thing is the fix.  There is an option in SQLite Manager that allows you to delete any item, i.e., event, from the data base.  I simply found the double entries and deleted both of them! And, VOILA!  When I restarted T-bird and the lightning calendar the unwanted items, i.e., all of the unwanted recurring events, were GONE! from the calendar.  Bottom line: it's not a problem with T-bird or with the Lightning add-on. IMHO it has to do with something that causes a corruption of the cashe.sqlite calendar data file.  In my case, I believe it happened when I messed up (don't know how) porting calendar data from Win XP to Win 7 ... or something like that.  Anyway, I hope this fix works for you.  And it should work for any non-dismissable event.  Good luck!
So a proper fix should prevent creation of duplicate entries and in a safe way remove any exiting duplicate entries.
(In reply to Pander from comment #61)
> So a proper fix should prevent creation of duplicate entries and in a safe
> way remove any exiting duplicate entries.

Pander,

First, I should mention that I was using a Google calendar with the Provider for Google calendar add-on to create the calendar in Lightning before the bug showed up. And the event that I could not dismiss or snooze was not to be found in the Google calendar itself even though that same event showed up in Thunderbird Lightning calendar.  This is what gave me the idea that the data that Lightning was using had to be coming from some other source than directly from the Google calendar itself. And that's when I tracked down the cashe.sqlite file within my Profiles, calendar-data folder.

I thought that even if I totally destroyed the cashe.sqlite it didn't matter because I could still rebuild it by starting with a fresh install of a blank Lightning calendar and use Provider (or the built-in Ligthning feature of the latest version of T-bird) to pull the data from my Google calendar back in.  Plus, obviously you should backup the cashe.sqlite before you modify or otherwise tinker with it.

Actually, I thought about this a lot today and recalled that at one point, after creating a recurring weekly event with a recurring reminder, I believe that I tried to modify a single instance ("This event only") and that it might have been after this that the bug appeared.  So, it may have been a bug in the Lightning add-on after all that caused it to be created, i.e., trying to modify one instance of a recurring event possibly caused duplicate entries in the cashe.sqlite database file. This should not happen, of course.

But removing duplicate events from the cashe.sqlite file makes sense as a fix to the problem. You dismiss one of the reminders, but the other one pops up and says, "Guess what? I'm still here." and recreates itself again.  

I still have recurring events in my calendar that work fine and were not affected by removing the duplicates of the event that I no longer wanted.  At the same time it is a simple matter to just recreate the removed recurring event in the normal way in Lightning if you still want to have it.

So, I believe the short answer to your question is that the fix should cure the "can't dismiss or snooze" a reminder bug if it is caused by duplicate entries in the cashe.sqlite database file.  But if you can't find a duplicate entry in the cashe.sqlite database and are still having this problem, then it is a different bug from the one that my fix solves. But I cannot promise that duplicate events won't show up in the future from the bug that caused the duplicate events in the first place.  Hope all of this helps.
Thanks for your elaboration. In any case, a final solution should not require a user to do anything with the file cashe.sqlite himself or herself. For the average user this is too technical or difficult to do. for debugging this issue this, it is an important point to the developers that are going to tackle this. Perhaps a new bug should be split off from this one doing frequent cache housekeeping? Throwing out also related garbage.
Yes, yes.  I see your point.  Probably the fault is mine for calling it a "fix."  I undoubtedly should have called it a "work-around" because it really does not cure whatever caused the duplicate entries in the first place.  

My work-around just gives the poor user a way to stop the annoying phenomenon of not being bothered by those undismissable and un-snoozable pop-up reminders without having to un-tick the "Show missed events" option.  Know what I mean?  

Thanks for your feedback and clarifying remarks.  I still hope that some somewhat sophisticated users can employ this work-around in order to get a little relief.  In the meantime, I hope the developers (I am clearly NOT one) can use what I documented in order to come up with a real fix.  Maybe they already knew about it.  Lightning is a damn fine T-bird add-on.  And I never once considered stopping using it.  There's nothing out there that does as good a job or has as many of Lightning's wonderful features.
The workaround that works for me is to go to the web Google Calendar and delete the reminder there. Then it stops from popping up again.
In my case there was no reminder to delete from the Google calendar. It was clean and did not have the event in it for which the undismissable reminder was showing up. I am guessing that the "Server" where the information had "recently changed" is actually in the cashe.sqlit file. So, Lightning was using an un-updated "server", i.e., the cashe.sqlite file, from which to get the reminder information.

But I am certainly glad to hear that you were able to find a much easier fix.
Let's keep in mind that the issue isn't related to Google Calendar: I had exactly the same issue in the course of my professional life during the past many years with Exchange, Zimbra and Google Calendar.

This said, good job orchond! That should indeed bring some developer much nearer to a solution, which should allow us to get a fix after those many years of waiting.

And I agree with what was said, there are two things to do:
1. add a housekeeping function to the cache routines to remove duplicate entries and other inconsistencies
2. find out how the cache get corrupted and remove the root cause

But the first approach might hide underlying issues, so that the 2nd becomes more difficult to tackle.
I agree with you, Eric. Got to eliminate the root cause 1st, then don't need to clean up the cashe.  What threw me off was the word "server" in the message box that popped up on an unsuccessful attempt to dismiss the reminder. When you see "server" you think, "Oh, must be a remote server on Google Calendar."  In my case they were talking about the cashe file being used as the server for the Lightning calendar.  Thanks for your comments.
i have (had) the same problem with Thunderbird 45.3 and Exchange on Windows 7 PC .

There where only 2 files in the mentioned folder \calendar-data\ . One was "delted.sqlite" and one local.sqlite.

As i have no clue, how to turn on logging i tried delting both files. This worked for me. After that only "local.sqlite" reappeared until i dismissed the old calendar reminder, then "delted.sqlite" appeared too.

I noticed this problem always appears after a password change on Exchange and mail login, if you didn't dismiss the invite before the password change (company policy... every 3 month^^ ).
Hi Blubber,
Hmmm ....  Your situation at least seems to confirm that "server" means something other than a remote server and in reality means entries in a .sqlite file within \calendar-data\.  Nice.
Same issue over here with Thunderbird 45.3.0, Lightning 4.7.3 on a Macbook with OS X El Capitan 10.11.6. Cannot dismiss reminders for recurring CalDav events. Pop-up keeps reappearing many times.
(In reply to Frank from comment #71)
> Same issue over here with Thunderbird 45.3.0, Lightning 4.7.3 on a Macbook
> with OS X El Capitan 10.11.6. Cannot dismiss reminders for recurring CalDav
> events. Pop-up keeps reappearing many times.

consider voting for this bug above to increase its prominence!
Additionally, Mozilla should do more reporting on bug votes per project. As I understood, and correct my if I am wrong, at the moment not many people are looking at votes.
To add information to the mix, I see precisely the same (recurrent notification) problem since I began using Radicale as the CalDAV server (http://radicale.org/) to consolidate our local calendars (ics) some months back.  I've been blaming Radicale, but the symptoms are just as folks have been describing for other servers, so the finger points to Thunderbird/Lightening.

I've disabled 'offline support' for the calendars to avoid creating the cache files (deleted.sqlite still gets created), but the problem persists.

Ed


Thunderbird 45.3.0
Lightening 4.7  (9/20/2016)
Linux Mint 17.3 Rosa  [Ubuntu 14.04]
Cinnamon 2.8.8
(In reply to blubbber from comment #69)
> i have (had) the same problem with Thunderbird 45.3 and Exchange on Windows
> 7 PC .
> 
> There where only 2 files in the mentioned folder \calendar-data\ . One was
> "delted.sqlite" and one local.sqlite.
> 
> As i have no clue, how to turn on logging i tried delting both files. This
> worked for me. After that only "local.sqlite" reappeared until i dismissed
> the old calendar reminder, then "delted.sqlite" appeared too.
> 
> I noticed this problem always appears after a password change on Exchange
> and mail login, if you didn't dismiss the invite before the password change
> (company policy... every 3 month^^ ).

I have the same problem on macOS 10.12 and Exchange-Server. I have removed all files containing header of invitation.

~/Library/Thunderbird/Profiles/XXXXXX.default//exchange-data/<UUID>.offlineCache.sqlite 
~/Library/Thunderbird/Profiles/XXXXXX.default//global-messages-db.sqlite 
~/Library/Thunderbird/Profiles/XXXXXX.default//ImapMail/127.0.0.1/Drafts-1 
~/Library/Thunderbird/Profiles/XXXXXX.default//ImapMail/127.0.0.1/INBOX 
~/Library/Thunderbird/Profiles/XXXXXX.default//ImapMail/127.0.0.1/Sent-1

macOS 10.12
Thunderbird 45.4.0
Exchange EWS Provider 3.8.0
Lightning 4.7.4
DavMail 4.7.2-2427
Same here. Too bad it is still not fixed as it is really annoying. I deleted the duplicate event and the alarm in the Sqlite cache DB and now it works. But I agree that this should be properly fixed.
I've just been able to solve the issues I had of:
- not being able to dismiss/snooze the alarms of my appointments
- Lightning not synchronizing with the calDAV server (Radicale) I use to cloudlessly sync my
  calendars between my notebook PC and Android smartphone.

In the faulty setup I had Thunderbird and Lightning were both installed from the repositories.
I've solved the issues as follows:

0 - In Thunderbird, open the Properties of each of your calendars and write down their locations
    (just in case you need them later ...)
1 - Close Thunderbird
2 - Uninstall Lightning package (xul-ext-lightning), using the package management tool or
    the CLI typing "apt-get uninstall xul-ext-lightning"
3 - Re-start Thunderbird, now running without Lightning calendar extension
4 - Install Lightning as an extension from inside Thunderbird:
    go to Tools->Add-ons->Extensions, search for "lightning" and then install it.
    If prompted, re-start Thunderbird
5 - Check that your calendar(s) are correctly set and if need be edit/add them using your notes
    as taken at previous point "0"

Now everything seems to run flawlessly.

I can just be grateful to all people writing on this post, especially Ed, as I alone would not been able to understand that "finger points to Thunderbird/Lightning" as clearlly stated three comments up from here.
Hope this might be of help to someone out there desperately struggling to solve all this, like I've being doing during the whole last week while my calendars were unreliable and unusable.

Lenovo Thinkpad T510
 Linux Mint 18 Sarah 64bit [Ubuntu 16.04]
 Mate 1.14.1
 Thunderbird 45.5.1
 Lightning   45.5.1, then Lightning extension 4.7.4
 Radicale  1.1.1

Samsung Galaxy SIII (GT-I9300)
 Android 4.3
 DAVdroid 1.3.4.1-ose (installed with F-Droid app from f-droid.org repository)
Buongiorno, seccolor -

Interesting solution.... and I'm willing to give it a try, though I DID install Lightning as a "direct" Thunderbird add-on (not via apt-get or the software manager), so "xul-ext-lightning" isn't on my system.

I've been carrying the TBird install along over several OS upgrades, so it's probably time I started afresh.  Unfortunately, I've made a lot of about:config changes and have been very poor about keeping notes!

If I survive, I'll post the results....


Thunderbird 45.5.1
Lightening 4.7.4  (10/18/2016)
Linux Mint 17.3 Rosa  [Ubuntu 14.04]
Cinnamon 2.8.8

Radicale 0.8
I have the same problem, using Lighting and Provider for GC to connect to my personal Google Calendar. 
I cannot dismiss a missed event that was shared with me by someone else.

Linux Ubuntu 16.10
Thunderbird 45.7.0
Lightening 4.7.4  
Provider for Google Calendar 3.1
I, too, am having this problem with a brand new install, on a new Windows 10 PC.  Thunderbird 45.8.0 with built-in Lightning.  

However, in checking in Lightning options, there was one called "Show reminders for past events" (or words like that).   It was checked by default.   So, I unchecked it.   

No more reminders for past reoccurring event.  :D
(In reply to Walt Amante from comment #80)
> I, too, am having this problem with a brand new install, on a new Windows 10
> PC.  Thunderbird 45.8.0 with built-in Lightning.  
> 
> However, in checking in Lightning options, there was one called "Show
> reminders for past events" (or words like that).   It was checked by
> default.   So, I unchecked it.   
> 
> No more reminders for past reoccurring event.  :D

Yes... it's actually "Show missed reminders".  That's been mentioned before (see the very first post in this thread and also comment #27.

The problem is (obvious when you think about it), that a reminder time may be passed without TB/L being active and, thus, the reminder won't be shown at all.  For example, a reminder is set for 8:00AM on Sunday, 4/9/2017, but TB/L isn't running at that time.  If TB/L is stated afterwards, and 'Show missed reminders' ISN'T checked, then the reminder for the event won't be shown.  (I just tested this, by the way - created an event with a reminder, shut down TB, waited until the time past, restarted TB: no reminder.)

You're correct that it IS a workaround, but not a real solution.  And, since this thread dates back at least five years (and the thread referenced at the top goes back to 2008), I wonder if it'll ever be fixed!
This may be fixed when I finish tests for the patch for bug 1344068. I've been running with this for a while and it works like a charm.
(In reply to Philipp Kewisch [:Fallen] from comment #82)
> This may be fixed when I finish tests for the patch for bug 1344068. I've
> been running with this for a while and it works like a charm.

We'll look forward to that! Thank you.
I am experiencing this issue also, when syncing with a Horde calendar. I had the issue in TB 45.8 and also now in TB 52 with the Lightning 5.4b4 version add-in. Past reminders pop up, which is fine, but the dismiss and dismiss all do not work and result in the "the item has been changed on the server. Submitting your changes will overwrite the changes made on the server." Selecting either option to this prompt never dismisses the alarm, and the next time TB is opened, the reminders pop up again. Happy to provide more info or test. No one else is shared or invited on my events. My events were imported from an outlook .ics file (and all fields seemed to have imported correctly)directly into Horde. And then a calendar was set up in TB, and the events synced. The events with reminders in Horde are synced correctly and have the correct reminder times set in them. TB reminder date/times are correct; the reminders just can't be dismissed and keep recurring.
For me too.   Its not so much the "old" reminder popping up, but rather that the "dismiss" and "dismiss all" do not work.  You can close the reminder pop up window.
c/can/can't/
I'm having this problem on a Mac OS X 10.9 system.  I just installed Thunderbird for the first time.  I have a dozen "reminders" up to a month old that I cannot dismiss.  I can, however, close the window.
I'm having the (basically) same problem with Ubuntu 16.04.

When it starts doing it (after a few days without), it won't let me even close the reminder window.

My solution is to unsubscribe to the calendar (through Office360) and resubscribe.

I'm using:

Lightning 4.7.8
ExQuilla 45.0.116
Exchange EWS Provider 3.9.0
(well, 'workaround')
Hi Everyone,

Thanks for your input so far. Have we come closer to a resolution?

Thanks :)
I'm going to dupe this bug against the one with the patch, I hope we can review and land it soon.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1344068
I just added my Nextcloud calendar to Thunderbird using CalDAV and got 20+ birthday reminders of the last month I can not dismiss. So I also would like to see a resolution soon. At the moment I deactivated reminders of this birthday calender because they are annoying me. Closing the window is working but the reminders come back every 15 minutes or so.
Any update on this? I'm running into this also now when using CalDAV to access Google Calendar

Thunderbord 52.9.1 (64-bit)
Lightning 5.4
You need to log in before you can comment on or make changes to this bug.