Closed Bug 7724 Opened 21 years ago Closed 20 years ago

<A> tag not getting closed.

Categories

(Core :: DOM: HTML Parser, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: harishd, Assigned: harishd)

References

Details

<HTML><HEAD><TITLE>Ich biete an</TITLE></HEAD>
<BODY><A HREF="biete.htm" TARGET="main"><P>Hello</A>there</BODY>
</HTML>

In the above example the text "there" should not be underlined.

Note: <P> is blocking <A> closure.
Target Milestone: M8
And not solely, 't'would appear, as a result of the <P> tag... with the Lose98
Apprunner build of 1999061108, access http://stardust.jpl.nasa.gov/, where an
anchor enclosing an image extends to text that follows it:

<a href=spacecraft/scnow.html><img src=spacecraft/sc3_s.jpg></a>
<br>
Current position of the STARDUST spacecraft,
about to cross the orbit of Mars.<br>

/* Text is underlined and linked to cited anchor */
Target Milestone: M8 → M9
This problem  should get resolved when the residual-style handling code is in
place. Moiving bug to M9.
*** Bug 10322 has been marked as a duplicate of this bug. ***
Moving residual-style related bugs to M10.
Target Milestone: M9 → M10
*** Bug 12852 has been marked as a duplicate of this bug. ***
*** Bug 9339 has been marked as a duplicate of this bug. ***
Priority: P3 → P1
Target Milestone: M10 → M11
Setting pririty to P1.
Priority: P1 → P2
Status: NEW → ASSIGNED
Target Milestone: M11 → M12
moving to m12.
I don't know if this is the appropriate place to make suggestions but here's
one anyway: when you implement the facility to handle broken HTML in a more
graceful manner, is it possible to have the browser display some sort of
notification that the page uses broken HTML but the browser will do its best
to display it? This might encourage people to produce correct HTML.

PS: I downloaded a nightly build last week and it was looking VERY good.
To all moz engineers, keep up the great work!
*** Bug 14939 has been marked as a duplicate of this bug. ***
Blocks: 13282
*** Bug 15960 has been marked as a duplicate of this bug. ***
*** Bug 9804 has been marked as a duplicate of this bug. ***
*** Bug 16768 has been marked as a duplicate of this bug. ***
*** Bug 16282 has been marked as a duplicate of this bug. ***
*** Bug 18661 has been marked as a duplicate of this bug. ***
*** Bug 8057 has been marked as a duplicate of this bug. ***
*** Bug 19418 has been marked as a duplicate of this bug. ***
I noticed someone mention residual style. Does that mean its related to bug 991?
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Fixed by landing of residual style handling.
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.