Last Comment Bug 776901 - Land in comm-central Instantbird's changes to chat/ - 2
: Land in comm-central Instantbird's changes to chat/ - 2
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 17.0
Assigned To: Florian Quèze [:florian] [:flo]
: instant-messaging
:
Mentors:
Depends on: 779117 799068 812921
Blocks: 753690 753807
  Show dependency treegraph
 
Reported: 2012-07-24 06:40 PDT by Florian Quèze [:florian] [:flo]
Modified: 2014-01-03 09:49 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
28 imported changesets (100.19 KB, patch)
2012-07-24 06:46 PDT, Florian Quèze [:florian] [:flo]
no flags Details | Diff | Splinter Review
14 changesets for Tb15 (39.16 KB, patch)
2012-07-24 08:59 PDT, Florian Quèze [:florian] [:flo]
bwinton: approval‑comm‑aurora+
bwinton: approval‑comm‑beta+
Details | Diff | Splinter Review

Description Florian Quèze [:florian] [:flo] 2012-07-24 06:40:34 PDT
There are lots of changesets touching the chat/ shared folder that have landed in hg.instantbird.org/instantbird and not comm-central since the previous sync in bug 753807.
Comment 1 Florian Quèze [:florian] [:flo] 2012-07-24 06:46:41 PDT
Created attachment 645280 [details] [diff] [review]
28 imported changesets

Bio 1469 - Add unit tests for building IRC messages, r=fqueze.
Bio 1472 - Handle a ChanServ entry message, r=fqueze.
Bio 1359 - Abstract the shared methods between ircChannel and ircConversation, r=fqueze.
Bio 1424 - Warning: GenericConvChatPrototype _init "setting a property that has only a getter", r=clokep.
Bio 1473 - IRC /topic help text is incorrect, r=fqueze.
Bio 1484 - Incorrect shutdown leads to the same tweets being fetched twice, r=clokep.
Bio 1427 - Fix up order and formatting of IRC tooltips, r=aleth.
Bio 1501 - Twitter's stream should the the moz-chunked-text XHR responseType, r=clokep.
Bio 1218 - Twitter Search API queries need some escaping, r=fqueze.
Bio 1499 - Avoid attempting to connect accounts while offline, and disconnect connecting accounts when going offline, r=fqueze.
Bio 1375 - Improve the margins around the unread ruler for the Bubbles theme, r=fqueze.
Bio 1203 - Fix logging in to Facebook Chat when the username contains uppercase letters, r=clokep.
Bio 1520 - Make autojoin and "Join Chat" handle excess whitespace better, r=clokep.
Bio 385 - Rejoin IRC channels after reconnect, r=clokep.
Bio 1518 - Don't display the topic system message again if it hasn't changed, r=clokep,fqueze.
Bio 1310 - Do not log channel keys when sending the JOIN command, r=aleth.
Bio 1519 - /invite doesn't work, r=aleth.
Bio 1534: Allow using a custom username for IRC, r=Mook.
Bio 1496 - test_ctcpFormatToText and test_mIRCColor aren't executed, r=fqueze.
Bio 1404 - Add "Your account is reconnected" system message, r=clokep,fqueze.
Bio 1296 - Unhandled IRC whois response messages 307 671 317, r=aleth.
Bio 1538 - Don't reset nick at reconnect if the last nick change was user initiated, r=clokep.
Bio 1540 - Handle 432: Erroneous nickname, r=clokep.
Bio 1552 - Handle 329: RPL_CREATIONTIME, r=aleth.
Bio 1551 - Remove whowas command, duplicate of whois, r=aleth.
Bio 1540 - Handle 432: Erroneous nickname tests, r=aleth,fqueze.
Bio 1477 - Handle NickServ messages when authenticating with PASS, r=fqueze,aleth.
Bio 1477 - Handle NickServ messages follow up for more cases, r=aleth.
Comment 2 Patrick Cloke [:clokep] 2012-07-24 07:13:30 PDT
(In reply to Florian Quèze from comment #1)
> Created attachment 645280 [details] [diff] [review]
> Bio 1473 - IRC /topic help text is incorrect, r=fqueze.
FWIW this is actually bio 1478, there was a typo in the commit message.
Comment 3 Florian Quèze [:florian] [:flo] 2012-07-24 08:59:41 PDT
Created attachment 645334 [details] [diff] [review]
14 changesets for Tb15

We (clokep, aleth and myself) triagged the 28 changesets in attachment 645280 [details] [diff] [review] and there are 14 changesets that I think we should take for Thunderbird 15:

Bio 1472 - Handle a ChanServ entry message, r=fqueze.
Bio 1359 - Abstract the shared methods between ircChannel and 
Bio 1424 - Warning: GenericConvChatPrototype _init "setting a property that has only a getter", r=clokep.
Bio 1484 - Incorrect shutdown leads to the same tweets being fetched twice, r=clokep.
Bio 1501 - Twitter's stream should the the moz-chunked-text XHR responseType, r=clokep.
Bio 1218 - Twitter Search API queries need some escaping, r=fqueze.
Bio 1499 - Avoid attempting to connect accounts while offline, and disconnect connecting accounts when going offline, r=fqueze.
Bio 1203 - Fix logging in to Facebook Chat when the username contains uppercase letters, r=clokep.
Bio 1520 - Make autojoin and "Join Chat" handle excess whitespace better, r=clokep.
Bio 1310 - Do not log channel keys when sending the JOIN command, r=aleth.
Bio 1538 - Don't reset nick at reconnect if the last nick change was user initiated, r=clokep.
Bio 1552 - Handle 329: RPL_CREATIONTIME, r=aleth.
Bio 1477 - Handle NickServ messages when authenticating with PASS, r=fqueze,aleth.
Bio 1477 - Handle NickServ messages follow up for more cases, r=aleth.


Here are the changesets that we don't think should go in aurora/beta, and why:

- Requires string changes:
Bio 1473 - IRC /topic help text is incorrect, r=fqueze. (actually bio 1478)
Bio 1427 - Fix up order and formatting of IRC tooltips, r=aleth.
Bio 385 - Rejoin IRC channels after reconnect, r=clokep.
Bio 1518 - Don't display the topic system message again if it hasn't changed, r=clokep,fqueze.
Bio 1519 - /invite doesn't work, r=aleth.
Bio 1404 - Add "Your account is reconnected" system message, r=clokep,fqueze.
Bio 1296 - Unhandled IRC whois response messages 307 671 317, r=aleth.
Bio 1540 - Handle 432: Erroneous nickname, r=clokep.
Bio 1551 - Remove whowas command, duplicate of whois, r=aleth.
Bio 1540 - Handle 432: Erroneous nickname tests, r=aleth,fqueze. (follow up to a changeset with string changes)

- Not useful for Tb 15:
Bio 1469 - Add unit tests for building IRC messages, r=fqueze.
ircConversation, r=fqueze. (test only change)
Bio 1375 - Improve the margins around the unread ruler for the Bubbles theme, r=fqueze. (trivial code cleanup)
Bio 1534: Allow using a custom username for IRC, r=Mook. (no user visible change)
Bio 1496 - test_ctcpFormatToText and test_mIRCColor aren't executed, r=fqueze. (test only change)
Comment 4 Florian Quèze [:florian] [:flo] 2012-07-24 09:57:52 PDT
(In reply to Florian Quèze from comment #3)
> Created attachment 645334 [details] [diff] [review]
> 14 changesets for Tb15
> 
> We (clokep, aleth and myself) triagged the 28 changesets in attachment
> 645280 [details] [diff] [review] and there are 14 changesets that I think we
> should take for Thunderbird 15:

Note: the triage happened in https://etherpad.mozilla.org/cc-chat-update
Comment 5 Blake Winton (:bwinton) (:☕️) 2012-07-25 12:15:23 PDT
Comment on attachment 645334 [details] [diff] [review]
14 changesets for Tb15

This seems like something we want for the initial IM release.

Thanks,
Blake.
Comment 6 Florian Quèze [:florian] [:flo] 2012-07-27 10:21:46 PDT
https://hg.mozilla.org/comm-central/rev/b6a08799d455
https://hg.mozilla.org/comm-central/rev/0f5ad81e7c60
https://hg.mozilla.org/comm-central/rev/1a78c4035abe
https://hg.mozilla.org/comm-central/rev/e9cc69e37805
https://hg.mozilla.org/comm-central/rev/6b357e98e5a0
https://hg.mozilla.org/comm-central/rev/3a0c9339357c
https://hg.mozilla.org/comm-central/rev/b2c968afb5c0
https://hg.mozilla.org/comm-central/rev/4c45c0375031
https://hg.mozilla.org/comm-central/rev/da7005079cd4
https://hg.mozilla.org/comm-central/rev/d67c1ed2c8d1
https://hg.mozilla.org/comm-central/rev/d3881c02ea77
https://hg.mozilla.org/comm-central/rev/b162ce0f8d14
https://hg.mozilla.org/comm-central/rev/6e0ccded9b96
https://hg.mozilla.org/comm-central/rev/f03b55eda4ce
https://hg.mozilla.org/comm-central/rev/8bdaa2fe9854
https://hg.mozilla.org/comm-central/rev/f0160c7f11c9
https://hg.mozilla.org/comm-central/rev/44d7af38bcb9
https://hg.mozilla.org/comm-central/rev/b4ad31c27ac6
https://hg.mozilla.org/comm-central/rev/d301f87aa1c5
https://hg.mozilla.org/comm-central/rev/f26baefb54f4
https://hg.mozilla.org/comm-central/rev/fa0ad045a7d6
https://hg.mozilla.org/comm-central/rev/9042d7a69df8
https://hg.mozilla.org/comm-central/rev/d3cb12cfa6c2
https://hg.mozilla.org/comm-central/rev/7707118a8069
https://hg.mozilla.org/comm-central/rev/ec9e9482fa48
https://hg.mozilla.org/comm-central/rev/9bef7c17269c
https://hg.mozilla.org/comm-central/rev/a9e6e87dde13
https://hg.mozilla.org/comm-central/rev/2554ae8db258

(In reply to Patrick Cloke [:clokep] from comment #2)
> (In reply to Florian Quèze from comment #1)
> > Created attachment 645280 [details] [diff] [review]
> > Bio 1473 - IRC /topic help text is incorrect, r=fqueze.
> FWIW this is actually bio 1478, there was a typo in the commit message.

I fixed this before the check-in (this affects only the comm-central check-in as that patch contained strings).

https://hg.mozilla.org/releases/comm-aurora/rev/8cdb59680404
https://hg.mozilla.org/releases/comm-aurora/rev/f0f189777f3e
https://hg.mozilla.org/releases/comm-aurora/rev/a53bab1f12f6
https://hg.mozilla.org/releases/comm-aurora/rev/f4f320941365
https://hg.mozilla.org/releases/comm-aurora/rev/ad27580359d8
https://hg.mozilla.org/releases/comm-aurora/rev/9837586641ed
https://hg.mozilla.org/releases/comm-aurora/rev/e7f31a1fb9b0
https://hg.mozilla.org/releases/comm-aurora/rev/e038afa1d3f6
https://hg.mozilla.org/releases/comm-aurora/rev/984dc1fe30b5
https://hg.mozilla.org/releases/comm-aurora/rev/6335bb979c06
https://hg.mozilla.org/releases/comm-aurora/rev/a39afa646460
https://hg.mozilla.org/releases/comm-aurora/rev/f586a05bcff3
https://hg.mozilla.org/releases/comm-aurora/rev/0dff2f2d166a

https://hg.mozilla.org/releases/comm-beta/rev/7a88ac158ad2
https://hg.mozilla.org/releases/comm-beta/rev/e7856d56d40d
https://hg.mozilla.org/releases/comm-beta/rev/95e37e5caaac
https://hg.mozilla.org/releases/comm-beta/rev/8712c807466c
https://hg.mozilla.org/releases/comm-beta/rev/a6c4193879d5
https://hg.mozilla.org/releases/comm-beta/rev/e5d018f89cd6
https://hg.mozilla.org/releases/comm-beta/rev/3f8671b2d6b4
https://hg.mozilla.org/releases/comm-beta/rev/c5558d8d206b
https://hg.mozilla.org/releases/comm-beta/rev/2f073cbbd9a1
https://hg.mozilla.org/releases/comm-beta/rev/7b51c0455855
https://hg.mozilla.org/releases/comm-beta/rev/f1306d0f43e5
https://hg.mozilla.org/releases/comm-beta/rev/26bb88c0ded8
https://hg.mozilla.org/releases/comm-beta/rev/78cb28ab7f4f

I've removed "Bio 1552 - Handle 329: RPL_CREATIONTIME, r=aleth." from the comm-aurora attachment before the check-in to comm-aurora and comm-beta as that patch depends on a patch that we didn't include for aurora (because it required string changes).
Comment 7 Patrick Cloke [:clokep] 2014-01-03 09:49:21 PST
Mapping to BMO bugs.

(In reply to Florian Quèze [:florian] [:flo] from comment #1)
> Created attachment 645280 [details] [diff] [review]
> 28 imported changesets
>
> Bug 954902 - Add unit tests for building IRC messages, r=fqueze.
> Bug 954905 - Handle a ChanServ entry message, r=fqueze.
> Bug 954793 - Abstract the shared methods between ircChannel and
> ircConversation, r=fqueze.
> Bug 954859 - Warning: GenericConvChatPrototype _init "setting a property that
> has only a getter", r=clokep.
> Bug 954906 - IRC /topic help text is incorrect, r=fqueze.
> Bug 954917 - Incorrect shutdown leads to the same tweets being fetched twice,
> r=clokep.
> Bug 954862 - Fix up order and formatting of IRC tooltips, r=aleth.
> Bug 954934 - Twitter's stream should the the moz-chunked-text XHR
> responseType, r=clokep.
> Bug 954650 - Twitter Search API queries need some escaping, r=fqueze.
> Bug 954932 - Avoid attempting to connect accounts while offline, and
> disconnect connecting accounts when going offline, r=fqueze.
> Bug 954809 - Improve the margins around the unread ruler for the Bubbles
> theme, r=fqueze.
> Bug 954635 - Fix logging in to Facebook Chat when the username contains
> uppercase letters, r=clokep.
> Bug 954952 - Make autojoin and "Join Chat" handle excess whitespace better,
> r=clokep.
> Bug 953828 - Rejoin IRC channels after reconnect, r=clokep.
> Bug 954950 - Don't display the topic system message again if it hasn't
> changed, r=clokep,fqueze.
> Bug 954742 - Do not log channel keys when sending the JOIN command, r=aleth.
> Bug 954951 - /invite doesn't work, r=aleth.
> Bug 954966: Allow using a custom username for IRC, r=Mook.
> Bug 954929 - test_ctcpFormatToText and test_mIRCColor aren't executed,
> r=fqueze.
> Bug 954839 - Add "Your account is reconnected" system message, r=clokep,fqueze.
> Bug 954728 - Unhandled IRC whois response messages 307 671 317, r=aleth.
> Bug 954970 - Don't reset nick at reconnect if the last nick change was user
> initiated, r=clokep.
> Bug 954972 - Handle 432: Erroneous nickname, r=clokep.
> Bug 954984 - Handle 329: RPL_CREATIONTIME, r=aleth.
> Bug 954983 - Remove whowas command, duplicate of whois, r=aleth.
> Bug 954972 - Handle 432: Erroneous nickname tests, r=aleth,fqueze.
> Bug 954910 - Handle NickServ messages when authenticating with PASS,
> r=fqueze,aleth.
> Bug 954910 - Handle NickServ messages follow up for more cases, r=aleth.

Note You need to log in before you can comment on or make changes to this bug.