All users were logged out of Bugzilla on October 13th, 2018

Status

P1
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: cshields, Assigned: cturra)

Tracking

Details

(Whiteboard: [tracker][2012q3][waiting][webtools][qa])

(Reporter)

Description

6 years ago
bouncer on pp-app-dist* needs to be replaced. I won't call it "unmaintainable" in its current state, but it certainly is not up to our standards.  Now that we know it is going to be kept and actively developed, we will build a new adm, dev, stage, prod environment for it that meets our current standards.
(Reporter)

Updated

6 years ago
Depends on: 786821
(Reporter)

Updated

6 years ago
Depends on: 786822
(Reporter)

Updated

6 years ago
Depends on: 786823
(Assignee)

Comment 1

6 years ago
bouncer-notes etherpad from initial discussions:

  https://etherpad.mozilla.org/bouncer-notes

Updated

6 years ago
See Also: → bug 750798
The current setup of bouncer stage / download.allizom.org (the PHP public side app) is out of Git (https://github.com/fwenzel/tuxedo/tree/master/bouncer) and should be able to be copied (the directory layout and Apache virtual host config) to the new cluster and also used to get the new dev and prod going

The bounceradmin side, which is a Django app, is going to require a few more steps to copy/setup

The current stage and prod setups are using a virtualenv (which we don't use in production deployments anywhere else) and it only has a https://github.com/fwenzel/tuxedo/blob/master/requirements.txt 

There is currently not a vendor submodule, like our Django/Playdoh apps, and I'm unsure of the level of effort to get the pure python dependencies packaged into a submodule
After reviewing https://etherpad.mozilla.org/bouncer-notes I realize I'd forgotten about the Perl sentry cron job stuff

This part I never did finish getting working in staging, I was focused on just verifying the PHP side worked in bug 750798, so that is an unknown quantity of work, as it's a set of Perl scripts and dependencies that were installed on a RHEL 5.5 box in SJC1, then we P2V'd into a VM in SCL3. I suspect this will take the longest and we may need a little help from :justdave to verify it's working, but all is possible with Mozilla IT

Let me know if I can shed any more light on things, as I did the bouncer stage setup and the migration of im-sentry01 to SCL3
Duplicate of this bug: 749207
Blocks: 750798
(Reporter)

Updated

6 years ago
Depends on: 788638
(Reporter)

Updated

6 years ago
Depends on: 788647
(Reporter)

Updated

6 years ago
Depends on: 788648
(Reporter)

Updated

6 years ago
Depends on: 788651
(Reporter)

Updated

6 years ago
Depends on: 788652
(Assignee)

Updated

6 years ago
Whiteboard: [tracker][2012q3][pending triage] → [tracker][2012q3][pending testing]

Comment 6

6 years ago
The dev and stage environments are alive and in use.

The new prod environment is completed, but not currently in "production"... need QA/webtools sign-off to do that after some testing.
Whiteboard: [tracker][2012q3][pending testing] → [tracker][2012q3][waiting][webtools][qa]

Comment 7

6 years ago
I think we're done here. Chris, anything left you're still planning to do or can we close this bug out? :)
Flags: needinfo?(cturra)
(Assignee)

Comment 8

6 years ago
:jakem - thnx for the reminder. yes, this bug can be closed. marking r/fixed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(cturra)
Resolution: --- → FIXED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.