Last Comment Bug 792021 - New app menu doesn't have EDIT menu
: New app menu doesn't have EDIT menu
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: 17 Branch
: x86_64 Windows 7
: -- normal (vote)
: Thunderbird 21.0
Assigned To: Richard Marti (:Paenglab)
:
:
Mentors:
Depends on:
Blocks: 789883 844432
  Show dependency treegraph
 
Reported: 2012-09-18 06:28 PDT by Mihovil Stanic [:Mikeyy - L10n HR]
Modified: 2013-02-23 02:29 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed fix (4.34 KB, patch)
2012-12-15 02:49 PST, Richard Marti (:Paenglab)
bwinton: review+
bwinton: ui‑review-
Details | Diff | Splinter Review
All in splitmenu popup (2.48 KB, patch)
2013-01-02 02:11 PST, Richard Marti (:Paenglab)
bwinton: review+
bwinton: ui‑review-
Details | Diff | Splinter Review
Edit menu with patch (8.29 KB, image/png)
2013-01-02 02:12 PST, Richard Marti (:Paenglab)
no flags Details
patch v2 (3.00 KB, patch)
2013-02-04 10:32 PST, Richard Marti (:Paenglab)
bwinton: review+
bwinton: ui‑review+
Details | Diff | Splinter Review
menu with patch v2 on OSX (17.58 KB, image/png)
2013-02-04 10:32 PST, Richard Marti (:Paenglab)
no flags Details

Description Mihovil Stanic [:Mikeyy - L10n HR] 2012-09-18 06:28:52 PDT
I was doing Litmus test 10: Summary for collapsed threads - One thread, in which you have instructions: click a single message, then Edit | Select | Thread

Guess what, there is no Edit menu in new app menu button. :)
Comment 1 Mihovil Stanic [:Mikeyy - L10n HR] 2012-09-18 06:40:21 PDT
My bad, there is EDIT menu item in new app menu, but it's grayed out, can't click on it.
I can open it by clicking on arrow right of EDIT, but it doesn't contain all options old EDIT menu contained.
Comment 2 Richard Marti (:Paenglab) 2012-09-18 09:12:03 PDT
The Edit menu is splitted in Edit and Find menus to be consistent to Firefox. 'Favorite Folder' and 'Folder Properties' are in Folder menu where, I think, they are better located.

But you are right I missed 'Delete Message', 'Select Thread' and 'Starred Messages'.
Comment 3 rsx11m 2012-09-20 15:24:37 PDT
(In reply to Mihovil Stanic [:Mikeyy - L10n HR] from comment #1)
> My bad, there is EDIT menu item in new app menu, but it's grayed out, can't
> click on it.

The "Edit" menu of the app button shows gray but shouldn't, its "Select All" item is selectable and active. That's probably a bug on its own.
Comment 4 Mihovil Stanic [:Mikeyy - L10n HR] 2012-09-20 23:30:41 PDT
Select All is working as it should.
Comment 5 rsx11m 2012-09-21 06:32:28 PDT
Yes, my point was that the "Edit" menu shouldn't appear disabled if at least one item in its submenu is enabled (and "Select All" usually is).
Comment 6 Richard Marti (:Paenglab) 2012-12-15 02:49:23 PST
Created attachment 692574 [details] [diff] [review]
proposed fix

I've added the 'Delete Message' and 'Select' menu to the 'Message' menu. I've also moved the 'Select All' from 'Edit' splitmenu to 'Select' menu to have all this entries together.

Blake, what do you think, should this go to TB 17 or is it okay to land for the public in TB 24?
Comment 7 Richard Marti (:Paenglab) 2013-01-01 08:52:52 PST
Mac try build with this patch applied: http://ftp.mozilla.org/pub/mozilla.org/thunderbird/try-builds/richard.marti@gmail.com-9da0349d8598
Comment 8 Blake Winton (:bwinton) (:☕️) 2013-01-01 13:02:01 PST
Comment on attachment 692574 [details] [diff] [review]
proposed fix

So, I think this might be one of the places where we need to differ from Firefox, since we have the concept of messages as well as pages, and going to the Message menu to select all the threads seems really odd.

Having the single delete menu item also breaks up the message menu more than I would like.

So, given all that, I think I would prefer to move those items back into the edit menu, if possible.

(The code looks fine, though.  ;)

Thanks,
Blake.
Comment 9 Richard Marti (:Paenglab) 2013-01-01 13:53:11 PST
Blake, do you mean to remove the Edit splitmenu and add a normal Edit menu, without the cut/copy/paste buttons, above the File menu or put the menuitems into the Edit splitmenu?
Comment 10 Blake Winton (:bwinton) (:☕️) 2013-01-01 16:26:15 PST
I meant put the menuitems into the Edit splitmenu.
Comment 11 Richard Marti (:Paenglab) 2013-01-02 02:11:10 PST
Created attachment 696966 [details] [diff] [review]
All in splitmenu popup
Comment 12 Richard Marti (:Paenglab) 2013-01-02 02:12:14 PST
Created attachment 696967 [details]
Edit menu with patch

For easier ui-r
Comment 13 Blake Winton (:bwinton) (:☕️) 2013-02-03 11:16:36 PST
Comment on attachment 696966 [details] [diff] [review]
All in splitmenu popup

ui-r-wise, it's close, but there are a couple of changes I want to see.

I think we should have the Delete menu use "⌫" instead of the word "Backspace", at least on Mac.
  (I tried to see how that was done in the regular menu, but couldn't find it…)

I also think that we should either put all the items in the first sub-menu (for ease of access), and name them:
  Select All
  Select Thread
  Select Starred Messages
or leave them in the sub-menu, and name them:
  All
  Thread
  Starred Messages
I would prefer the first option, I think.

The code itself is fine, though, so r=me.

Thanks, and I apologize for the delay,
Blake.
Comment 14 Richard Marti (:Paenglab) 2013-02-04 10:32:03 PST
Created attachment 709778 [details] [diff] [review]
patch v2

(In reply to Blake Winton (:bwinton) from comment #13)
> Comment on attachment 696966 [details] [diff] [review]
> All in splitmenu popup
> 
> ui-r-wise, it's close, but there are a couple of changes I want to see.
> 
> I think we should have the Delete menu use "⌫" instead of the word
> "Backspace", at least on Mac.
>   (I tried to see how that was done in the regular menu, but couldn't find
> it…)

I also haven't found how it is made (maybe made by OS). I fixed it with defining the acceltext instead of giving the key under OSX. I hope this hack is okay. My tests worked with this.

> I also think that we should either put all the items in the first sub-menu
> (for ease of access), and name them:
>   Select All
>   Select Thread
>   Select Starred Messages
> or leave them in the sub-menu, and name them:
>   All
>   Thread
>   Starred Messages
> I would prefer the first option, I think.

I implemented the first option.
Comment 15 Richard Marti (:Paenglab) 2013-02-04 10:32:48 PST
Created attachment 709779 [details]
menu with patch v2 on OSX
Comment 16 Blake Winton (:bwinton) (:☕️) 2013-02-17 13:30:39 PST
Comment on attachment 709778 [details] [diff] [review]
patch v2

Okay, ui-r=me, but I'ld like you to file a couple of followup bugs, if you don't mind.
1) The cut/copy/paste icons don't have a hover state, and I think they should act more like the ▶ icon.
2) The "Edit" text is always disabled, but I think it, too, should act like the ▶ icon.  (i.e. be enabled, and open the sub-menu when clicked.)

(If you wanted to fix either or both of those in this bug, I wouldn't object…  ;)

And the code itself seems fine, so I'll say r=me, too!

Thanks,
Blake.
Comment 17 Richard Marti (:Paenglab) 2013-02-17 14:08:10 PST
(In reply to Blake Winton (:bwinton) from comment #16)
> Comment on attachment 709778 [details] [diff] [review]
> patch v2
> 
> Okay, ui-r=me, but I'ld like you to file a couple of followup bugs, if you
> don't mind.
> 1) The cut/copy/paste icons don't have a hover state, and I think they
> should act more like the ▶ icon.

On Windows and Linux where is feedback because this are buttons. OSX has no feedback on hover -> I'll file a bug for OSX.

> 2) The "Edit" text is always disabled, but I think it, too, should act like
> the ▶ icon.  (i.e. be enabled, and open the sub-menu when clicked.)

Firefox uses this also only as label. I also don't know if this would be obvious when you hover the label on the left and a sub-menu opens on the right. And in between is a area with buttons and doesn't activate a sub-menu.
Comment 18 Ryan VanderMeulen [:RyanVM] 2013-02-18 06:46:38 PST
https://hg.mozilla.org/comm-central/rev/a2e5286e3d53
Comment 19 rsx11m 2013-02-19 20:37:15 PST
(In reply to Richard Marti [:Paenglab] from comment #17)
> > 2) The "Edit" text is always disabled, but I think it, too, should act like
> > the ▶ icon.  (i.e. be enabled, and open the sub-menu when clicked.)
> 
> Firefox uses this also only as label. I also don't know if this would be
> obvious when you hover the label on the left and a sub-menu opens on the
> right. And in between is a area with buttons and doesn't activate a sub-menu.

This is bug 834014 for Firefox and definitely an irritating behavior. "Edit" is the only menu with a submenu where the text is italic(?) and which is disabled even though it can be selected.

When you hover over the Edit's arrow to open the submenu, then move the mouse left and then down, the submenu stays open. The submenu of another item may open on top of it (not always reproducible, but frequently enough). So, there seems to be something wrong worthy of a bug report, the question is if you want to wait for a fix in the Firefox bug or investigate for Thunderbird in parallel.

Note You need to log in before you can comment on or make changes to this bug.