about:preferences do not work properly if browser.cache.offline.enable is false

VERIFIED FIXED in Firefox 32

Status

()

defect
VERIFIED FIXED
7 years ago
5 years ago

People

(Reporter: backy0175, Assigned: evilpie)

Tracking

15 Branch
mozilla32
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox32 verified)

Details

(Whiteboard: p=0 s=it-32c-31a-30b.3 [qa!])

Attachments

(2 attachments, 2 obsolete attachments)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

open about:preferences.


Actual results:

some part of about:preferences do not work properly.

open about:preferences then click "Content".
font settings has problems.

go back about:prefernces then click "Applications".
there is no applications.

I found error message on error console.
=====================================
Timestamp: 2012/10/01 7:51:20
Error: NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIApplicationCacheService.getGroups]
Source File: chrome://browser/content/preferences/in-content/advanced.js
Line: 332
=====================================

I checked about:config and found "browser.cache.offline.enable = false" is a cause.


Expected results:

about:preferences should work with "browser.cache.offline.enable = false".
I did't have any font problems on the 10/02 Nightly, but the Applications section is empty and I do get the same error in the Error Console.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
My bad. I was looking at the font, not the font settings. The font settings drop-down doesn't work for me either.
Component: Untriaged → Preferences
Product: Firefox → Toolkit
Blocks: fxdesktopbacklog
No longer blocks: fxdesktoptriage
Whiteboard: p=0
Duplicate of this bug: 727579
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
Whiteboard: p=0 → p=2
Posted patch v1 (obsolete) — Splinter Review
Attachment #8424481 - Attachment is patch: true
Attachment #8424481 - Attachment mime type: text/x-patch → text/plain
Attachment #8424481 - Flags: review?(jaws)
Comment on attachment 8424481 [details] [diff] [review]
v1

Review of attachment 8424481 [details] [diff] [review]:
-----------------------------------------------------------------

It would be nice if a test was included that opened the preferences and tried to switch to the advanced tab (window.selectCategory("paneAdvanced");), and see if the Advanced header is not hidden.

r=me with the test and the following change.

::: browser/components/preferences/in-content/advanced.js
@@ -460,5 @@
>      }
>  
> -    var cacheService = Components.classes["@mozilla.org/network/application-cache-service;1"].
> -                       getService(Components.interfaces.nsIApplicationCacheService);
> -    var groups = cacheService.getGroups();

There are three places within this file that use the application-cache-service. Can you fix the others too?
Attachment #8424481 - Flags: review?(jaws) → review+
Duplicate of this bug: 1012575
This also happens for me, and my browser.cache.offline.enable is true, the default setting. I get no error in the console when attempting to switch tabs, but I do get one each time I open the preferences:

NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsICacheService.visitEntries] (advanced.js:302)

This is the 2014-05-19 build.
I just fix it in my browser, setting browser.cache.disk.enable to true. Setting the value to false produces:

NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsICacheService.visitEntries] advanced.js:314

just opening the new inline preferences page 

using:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

32.0a1 (2014-05-19)
Me too: setting browser.cache.disk.enable to true fixes it.
Assignee: nobody → evilpies
Posted patch v2 (obsolete) — Splinter Review
Attachment #8424481 - Attachment is obsolete: true
Attachment #8430735 - Flags: review?(jaws)
Posted patch v2.1Splinter Review
Oh actually we can simplify _getOfflineAppUsage, groups is passed in anyway.
Attachment #8430735 - Attachment is obsolete: true
Attachment #8430735 - Flags: review?(jaws)
Attachment #8430739 - Flags: review?(jaws)
Duplicate of this bug: 1013890
Comment on attachment 8430739 [details] [diff] [review]
v2.1

Review of attachment 8430739 [details] [diff] [review]:
-----------------------------------------------------------------

This is a very straightforward test, looks good!

::: browser/components/preferences/in-content/tests/browser.ini
@@ +5,5 @@
>  
>  [browser_advanced_update.js]
>  [browser_bug410900.js]
>  [browser_bug731866.js]
> +[browser_bug795764.js]

Can you please add to the test name to make this more descriptive? See this thread for more background: https://mail.mozilla.org/pipermail/firefox-dev/2013-September/000957.html

You can change this test name to:
browser_bug795764_cachedisabled.js
Attachment #8430739 - Flags: review?(jaws) → review+
Comment on attachment 8430739 [details] [diff] [review]
v2.1

Review of attachment 8430739 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/preferences/in-content/advanced.js
@@ -431,5 @@
>    {
> -    var cacheService = Components.classes["@mozilla.org/network/application-cache-service;1"].
> -                       getService(Components.interfaces.nsIApplicationCacheService);
> -    if (!groups)
> -      groups = cacheService.getGroups();

You've removed the cacheService variable, but it is still referenced below on line 444.
Attachment #8430739 - Flags: review+ → review-
Okay sorry! I just reverted that stupid last minute change and pushed the patch. http://hg.mozilla.org/integration/mozilla-inbound/rev/07b5d912ff57
https://hg.mozilla.org/mozilla-central/rev/07b5d912ff57
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Whiteboard: p=2 → p=0 s=it-32c-31a-30b.3 [qa?]
Duplicate of this bug: 1018577
Whiteboard: p=0 s=it-32c-31a-30b.3 [qa?] → p=0 s=it-32c-31a-30b.3 [qa+]
QA Contact: camelia.badau
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.2 using latest Nightly 32.0a1 (buildID: 20140603030220).
Status: RESOLVED → VERIFIED
Whiteboard: p=0 s=it-32c-31a-30b.3 [qa+] → p=0 s=it-32c-31a-30b.3 [qa!]
I'm trying in Firefox nightly 32.0a1 (2014-06-04)
and does not work.

In the preference screen only appears in the left menu and clear the content area only a "?" symbol in a yellow box.

In consolose:

NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsICacheService.visitEntries] advanced.js:314
ReferenceError: reference to undefined property this._path osfile_win_front.jsm:837
Note: As Erik points out in #9 setting browser.cache.disk.enable=true solve the bug.
This is probably a different issue, let's just open a new bug and wrap that call in try { } catch as well.
You need to log in before you can comment on or make changes to this bug.