Closed Bug 809258 Opened 7 years ago Closed 7 years ago

A white bar(approx.20px height) appears at the bottom of browser when the browser started in maximized mode

Categories

(Firefox Graveyard :: SocialAPI, defect)

19 Branch
x86
Windows 7
defect
Not set

Tracking

(firefox17 unaffected, firefox18+ verified, firefox19+ verified)

VERIFIED FIXED
Firefox 19
Tracking Status
firefox17 --- unaffected
firefox18 + verified
firefox19 + verified

People

(Reporter: alice0775, Assigned: markh)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached image screen shot
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/f9c2c266e7aa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121106030712

This is similar to Bug 678039, bat different OS and regression window.
This happens even if with clean new profile.

Steps to reproduce(Step1-5: to avoid any notification bars in new profile):
  1. Start Firefox with clean new profile
  2. Close any dialog, any otification bar and tabs other than NewTab
  3. Exit
  4. Start Firefox again
  5. Close any dialog and any notification bar

  6. Maximize the browser
  7. Exit the browser
  8. Start Firefox again

Actual repsults:
  A white bar appears at the bottom of browser.
  (Browser started in Maximized mode and opened a HomeTab as expected.)

Expected results:
  No white bar appears.
 (Browser started in Maximized mode and opened a HomeTab as expected.)
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/50cd5f7339f6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121105011546
Bad:
http://hg.mozilla.org/mozilla-central/rev/358c9830d166
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121105072444
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=50cd5f7339f6&tochange=358c9830d166


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/4a5c43e5b7e2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121104173145
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/837ae727d237
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121104173545
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4a5c43e5b7e2&tochange=837ae727d237

Triggered by: Bug 798083
Component: Layout → SocialAPI
Product: Core → Firefox
Summary: A white bar appears at the bottom of browser when the browser started in maximized mode → A white bar(approx.20px height) appears at the bottom of browser when the browser started in maximized mode
I can't repro this on Windows 7, even though the bug summary lists that.  The screenshot looks like XP to me.

Are there any other steps needed to reproduce this?  It might also be related to bug 794124, which I also can't repro.
Attached image Screen shot AERO
This also happens in Windws7 Aero.

(The 1st screenshot is Windows7 classic)

And this happens regardless of HWA on/off
Component: SocialAPI → Widget: Win32
Product: Firefox → Core
I think the patch Bug 798083 exposed the problem.
(In reply to Mark Hammond (:markh) from comment #1)
> I can't repro this on Windows 7, even though the bug summary lists that. 
> The screenshot looks like XP to me.

See comment #2

> Are there any other steps needed to reproduce this?  It might also be
> related to bug 794124, which I also can't repro.

You should follow exact str in comment #0, and should not enable social API.
Since bug 798083 is expected to land in FF18, tracking for that release as well.
Assignee: nobody → mhammond
I still can't reproduce this and this is the only report of the issue I have seen.  Are any themes or addons being used which could influence this?
This bug is occurring for me for some time now every time when Nightly starts with opening just a single tab(be it custom home page,blank/newtab page or restored tab from last session).In bug[url=https://bugzilla.mozilla.org/show_bug.cgi?id=726285]#726285[/url](which is supposed to be a different one than this bug) i was told that there are 2 different bugs with different causes and that this bug we are commenting now is specific to new profile and was probably caused by social API.I can 100% reproduce this bug as Alice said by making new profile and restarting the browser few times to close the initial popups/notifications(know your rights and submit performance data).After that with no addons installed and no other settings changed i always have that white bar at the bottom.On the other hand in bug[url=https://bugzilla.mozilla.org/show_bug.cgi?id=726285]#726285[/url] i commented that on my dirty everyday profile it seems that specific addons(lastpass,x-notifier,'wiktionary and google translate') trigger the white bar and when those addons are disabled i no longer see the white bar on startup.So i am pretty confused how a clean profile exhibits this bug with no addons installed,but my dirty profile exhibits this bug only when specific addons are enabled and others are irrelevant to the bug.Maybe some of my other addons somehow "fix" this,but others(like the 3 addons i mentioned to expose the bug)are reverting/canceling the "fix".
Attached image DOM Inspector.png
My 'speed' steps:
1. Make sure Nightly starts in maximized window, so maximize it before closing
2. Set your homepage to http://forums.mozillazine.org/viewforum.php?f=23
3. If you do both, after Nightly restart you will see white bar at the bottom of browser

No theme, persona, addon or plugin cause this as clean fresh new profile on portable nightly is also affected.
(In reply to Mark Hammond (:markh) from comment #6)
> I still can't reproduce this and this is the only report of the issue I have
> seen.  Are any themes or addons being used which could influence this?

I can still reproduce with clean new profile(i.e. No addon. No theme(default theme)).
http://hg.mozilla.org/mozilla-central/rev/87928cd21b40
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121114102936
(In reply to Virtual_ManPL [:Virtual] from comment #8)
> Created attachment 682220 [details]
> DOM Inspector.png

I'm not sure what this is demonstrating - what is unexpected in this image?

Seeing as you are using the inspector, could you please reproduce the problem and look at the "pinnedchats" item, view its "Box Model" and see what the height of the chatbar is?  Mine shows 0px, which I'm guessing is the reason I can't reproduce it.

(FWIW, I just tried on various monitors and with various toolbar configurations, but still no joy)
Sorry for the noise - the last testing I did neglected to disable social.  I now can see this.
I add qawanted. 

And also I add cc'ing to bbajaj@mozilla.com , because I can reproduce in Aurora18.0a2 too.
http://hg.mozilla.org/releases/mozilla-aurora/rev/0d76df6f808d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121115042012
Whiteboard: qawanted
I can't really explain why this is happening, but adding hidden="true" as an attribute on the chatbar fixes the issue for me.  As social explicitly adjusts the hidden attribute as it boots up, everything still works as expected.
Attachment #682268 - Flags: review?(felipc)
(In reply to Mark Hammond (:markh) from comment #10)
> (In reply to Virtual_ManPL [:Virtual] from comment #8)
> > Created attachment 682220 [details]
> > DOM Inspector.png
> 
> I'm not sure what this is demonstrating - what is unexpected in this image?

I was asked in bug #726285 to identify the element with "DOM Inspector" and "Inspect Context" addons, so I think this screenshot belongs now here. Maybe it will be some kind of help.
Attachment #682268 - Flags: review?(felipc) → review+
https://hg.mozilla.org/mozilla-central/rev/ae2a55900702
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Are you going to Aurora approve this?
Component: Widget: Win32 → SocialAPI
Product: Core → Firefox
Target Milestone: mozilla19 → ---
Comment on attachment 682268 [details] [diff] [review]
Make the chatbar be hidden by default

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 798083
User impact if declined: In some circumstances, a white gap will appear at the bottom of the browser window.
Testing completed (on m-c, etc.): Landed on m-c
Risk to taking this patch (and alternatives if risky): Low risk, only social components affected.
String or UUID changes made by this patch: None
Attachment #682268 - Flags: approval-mozilla-aurora?
Comment on attachment 682268 [details] [diff] [review]
Make the chatbar be hidden by default

[Triage Comment]
Approving for FF18.

If this is landed on mozilla-aurora before ~11AM PT tomorrow, this will make the merge from Aurora 18 to Beta 18. If landed 11AM-5PM PT tomorrow on mozilla-beta, it will make the first FF18 Beta. If landed after that, it will end up in the second FF18 beta.
Attachment #682268 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Confirmed this is no longer reproducible for me.
Status: RESOLVED → VERIFIED
Whiteboard: qawanted
Target Milestone: --- → Firefox 19
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.