"Delete" context menu option should be "Undelete" on deleted messages.

RESOLVED FIXED in mozilla1.3beta

Status

SeaMonkey
MailNews: Message Display
RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: Oliver Jones, Assigned: neil@parkwaycc.co.uk)

Tracking

(Blocks: 1 bug, {polish})

Trunk
mozilla1.3beta
polish
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P0] dupme)

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

17 years ago
On messages "marked as deleted" the "Delete" option in the right click context 
menu should be renamed "Undelete" and it should undelete the message.

Similarly there should be an option in the edit or message menu, to mark and 
unmark a message for deletion.  

In Netscape 4 if you press the delete message tool bar button on choose delete 
from the edit menu twice when in "mark as deleted mode" the second press 
undeletes the message.  This is good behaviour however the UI should change to 
reflect that you are reversing the action.  Ie, the trash icon on the toolbar 
should change when you've selected a "deleted message" to show something being 
taken out of the trash and the menu item wording should change to "Undelete 
Message" etc...
(Reporter)

Updated

17 years ago
OS: Windows 2000 → All
(Reporter)

Comment 1

17 years ago
Oh yes... forgot to add platform info:

Platform: RedHat Linux 7.1, Mozilla/5 0.9
I'm pretty sure this is a dup.
Whiteboard: dupme

Updated

17 years ago
Severity: normal → enhancement
QA Contact: esther → sheelar

Comment 3

17 years ago
bug 61870 ?

Comment 4

17 years ago
reassign->karen tests imap delete model
QA Contact: sheelar → huang

Comment 5

17 years ago
Confirm bug to NEW
Better not mark dup for this bug....adding 59694 for this bug's dependance.
Ccing Ninoschka.
Status: UNCONFIRMED → NEW
Depends on: 59694
Ever confirmed: true
QA Contact: huang → nbaca

Comment 6

17 years ago
*** Bug 86816 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
This is not just an RFE since 
1) This makes it impossible (is there a work-around?) to "undelete" message in
"mark as deleted" IMAP mode.
2) 4xp's are bugs
Severity: enhancement → normal
Keywords: 4xp, mozilla1.0

Comment 8

17 years ago
I deleted a message, it was marked, then selected to Undo. It appeared to do 
nothing. After changing to another folder and back to the original folder 
then the mark was removed. This seems related to Bug# 69992 'Undo Delete Message 
doesn't show until selecting another folder or Get Msg for "Remove it 
immediately" mode'.

Karen, should another bug be written for the mark not being removed immediatley 
after selecting to Undo. 

Comment 9

17 years ago
"Undo" should work right away and reverse the "Delete" state of the message.

As for menus, Edit-->Delete Message" and the context menu "Delete", it would be 
good if these reversed the deleted state for a message as well.  The menu items 
for 4.x do reverse the delete state, but the text doesn't change (the menu items 
still say "Delete").  

cc'ing Robin for her opinion on toggling text from "Delete" to "Undelete" text.

Comment 10

17 years ago
The "Undo delete message" command does work: the message is still displayed as
deleted (with the X on it), but the message has in fact been undeleted: if you
then click on "Get messages" the message appears properly with no X on it.

An "undelete" command would be much better though: if you delete a message then
do  other things you are forced to "Undo" everything you have done to get the
message back.

Comment 11

17 years ago
No undelete option in 0.9.2. build 200107xx
(Assignee)

Comment 12

17 years ago
Why not mark the delete menuitem and/or mail button as "checked" so that it's
more obvious that clicking delete will actually undelete. Although there is then
the question of whether the news mark button should show as "checked" when the
current message is read.

Updated

17 years ago
QA Contact: nbaca → olgam
Whiteboard: dupme → [Hixie-P0] dupme
Keywords: nsbeta1
Hardware: PC → All

Comment 13

17 years ago
My "production" mail client is Netscape Messenger 4.7x, and I can tell you
that I very much lack a proper "Undelete" action in Mozilla. I really hope
that this can be included in the next release (I am testing 0.9.7 on Linux
now).

Please do not confuse the currently missing "Undelete" action with the "Undo
Delete Message" feature which *is* available. The Undo.. is OK if you just
marked a single message for deletion and changed your mind, but it is next
to useless if you are doing a major tidyup of a big mailbox with hundreds
of messages.

Conclusion: The Undo.. feature is fine, but "Undelete" is even more basic.
Please put it in!

When you implement it, as far as I am concerned you may also mimic the
workings of the DEL button in Netscape Messenger. That is, the DEL button
actually toggles the deletetion mark for the message(s) in focus. But first
and foremost, an Undelete choice on the menu-click menu ...

Comment 14

17 years ago
Sorry for being unclear in comment #13 .. when referring to the "DEL button"
I actually meant the PC keyboard key marked "Delete" or "Del".

Comment 15

17 years ago
reassigning to ssu.
Assignee: sspitzer → ssu
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2
*** Bug 124388 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 17

16 years ago
ssu, do you mind if I have a crack at this one?

Comment 18

16 years ago
I'm not about to turn down any help :)
(Assignee)

Comment 19

16 years ago
Created attachment 69472 [details] [diff] [review]
Proposed Patch
(Assignee)

Comment 20

16 years ago
I've copied the logic from SelectedMessagesAreRead/Flagged so I hope it's OK.
Keywords: patch, polish, review
(Assignee)

Comment 21

16 years ago
Created attachment 69650 [details] [diff] [review]
Patch including standalone window

I'd forgotton that the standalone message window has a Delete function :-)

There seems to be some duplication of code, so I hope to make a patch which
moves the common code into mailWindowOverlay.js
Attachment #69472 - Attachment is obsolete: true

Comment 22

16 years ago
looking at the patch now.

Comment 23

16 years ago
After testing the patch and looking at what the current build does, I'm thinking
that this is not a bug, or rather not the right problem.

This bug indicates that the 'Delete' menu command in the context menu needs to
toggle between 'Undelete/Undo Delete' and 'Delete'.  I don't think that the
'Delete' command on the context menu should do that.  I see that command being
the same as the 'Delete Message' command in the 'Edit' menu, which does not
toggle between 'Undelete/Undo Delete' and 'Delete Message'.  It's always just
'Delete Message'.

I think the problem here is that the context menu is missing the 'Undo' and
'Redo' menu items like what's in the 'Edit' menu.

Jennifer, Scott, what do you guys think?
Status: NEW → ASSIGNED

Comment 24

16 years ago
This has nothing to do with the "Undo" functionality. "Undo" is not sensitive to
a single message (undo the last thing I've done), so thus is makes sense to be
missing from the context menu. Note I can undelete a message *eons* after I
deleted it, as long as I don't expunge the box.

This has everything to do with the fact that, in IMAP, messages are marked to be
deleted, to later be expunged or recovered.

If the menu "Delete" also has the same problem than the context one, IT needs to
be fixed as well. The *current* semantics (well, last time I checked) is
*right*. When the message is deleted, and you hit this option, it is undeleted.
Now, what's missing is to give the proper label to the menu item. You can't
delete a deleted message. You can only "Undelete" it. So name the action
"Undelete" is this is the action that will be taken when the user hits the
button. This is what, I think, Outlook does... Another options is to create
another entry called "Undelete" that is greyed out when the message is not
deleted, and grey out the "delete" option when the message is deleted... Either
scenario works, but I think it's a waste of real state, since both options are
mutually exclusive, and related (one reverts the other).

As for the suggestion of a "check" toggle, I think it's bad, because you'd have
to name it "deleted" (so the check means yes/no), but that will confuse the hell
out of the users, as not deleted messages' menus will contain an option that
reads "deleted"... :^>
(Reporter)

Comment 25

16 years ago
As reporter of this bug I completely agree with Luiz-Otavio Zorzella.  What
surprises me is that it has taken so long for this bug to be 'fixed'.

Comment 26

16 years ago
I think it should toggle between "delete" and "undelete" (or some other term
that means the same thing).
(Assignee)

Comment 27

16 years ago
Created attachment 70057 [details] [diff] [review]
Patch including context menus

This patch now uses the new whizzy command="cmd_delete" to propogate the label
and accesskey to all the context menus as well.
Attachment #69650 - Attachment is obsolete: true

Comment 28

16 years ago
If the IMAP delete model is being used, a message is selected and is not 
marked as deleted, menu item says "Delete". A message is selected and 
message is already marked as deleted, menu item should say "Undelete" (if 
that is the correct term). 

Comment 29

16 years ago
Suggest using "Undo Delete" instead of "Undelete."

Comment 30

16 years ago
My concern with "Undo Delete" is that it is similar to "Undo Delete Message" and
they are different actions.  

Comment 31

16 years ago
The current ctrl+Z "Undo delete message" isn't really a substitute for an
"undelete" option.  For a user who is used to an undelete option, the undo one
is a bit unintuitive.

With moz 0.9.8, if I mark two messages as deleted, then select the first deleted
message and press C-z, the second message gets undeleted (pressing again
undeletes the first message, of course).  It would be nice to have a command
that "undeletes _this_ message".
(Assignee)

Comment 32

16 years ago
James, that was bug 59694 which has now been fixed, the problem is that the menu
still says "Delete" when in fact it will now undelete as well.
Comment on attachment 70057 [details] [diff] [review]
Patch including context menus

this patch looks good, sr=sspitzer

but I'm sure it has bit rotted, I see part of #77687 in there.

neil, please attach an update to date patch.

it looks like there was some debate over what the value of undeleteMsgCmd.label
should be.  if that is still an open issue when you are ready to check in,
please open a new bug for it.
Attachment #70057 - Flags: superreview+
(Assignee)

Comment 34

16 years ago
Created attachment 71655 [details] [diff] [review]
Update for "bitrot"

If only I had a better way to track multiple patches... or fewer patches :-)
Attachment #70057 - Attachment is obsolete: true

Comment 35

16 years ago
Comment on attachment 71655 [details] [diff] [review]
Update for "bitrot"

looks fine. transfering sr.
Attachment #71655 - Flags: superreview+
Attachment #71655 - Flags: review+

Updated

16 years ago
Keywords: mozilla0.9.9

Comment 36

16 years ago
I had found some problems with the initial patch.  making sure it's not in the
lastest patches before checking it in for Neil.

Comment 37

16 years ago
The patch looks good.  It does not exhibit the problemI noticed in the ealier
patches.  Could also have been a problem with the earlier mozilla builds, but I
had to make sure.

However, I have filed a new bug (bug 128916) that relates to this bug and bug
30560.  Once bug 30560 is checked in, the context menu will not display the
correct string when an already delete message (but not yet selected and the
selection is currently on a non-deleted message) is right-mouse clicked on.  It
will not show 'Undelete Message', but rather 'Delete Message' still.

seeking a= for neil's patch for trunk.

Comment 38

16 years ago
Comment on attachment 71655 [details] [diff] [review]
Update for "bitrot"

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #71655 - Flags: approval+

Comment 39

16 years ago
patch checked in to trunk only.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 40

16 years ago
Verified with the Server Setting 'When I delete a message': 'Mark it as deleted'.
03-06-2002 trunk build, Win2K, Linux, Max OSX.

For option: 'Move it to the Trash Folder'- bug 128916.
Status: RESOLVED → VERIFIED

Comment 41

16 years ago
I still see the toolbar button of 3-pane window always saying "Delete" while
only the right-click-on-header menu has undelete. BuildId 2002030417 and
2002030616 on RedHat Linux 7.2
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 42

16 years ago
Created attachment 73258 [details]
Screenshot with appropriate parts highlighted.

Comment 43

16 years ago
Oops, we did not look at Toolbar. Should it be a different bug?
(Assignee)

Comment 44

16 years ago
The "Mark" button doesn't change for read/unread items and I doubt you want the
overhead of changing the "Delete" button for normal/deleted items, although
that's not to say it couldn't be done.

Comment 45

16 years ago
> The "Mark" button doesn't change for read/unread items

Well, no matter whether you mark message read or unread it's still marking it.
In fact, currently "Mark" does not do anything when the message is already
marked as read at this is not nearly as confuusing as having to press "Delete"
to undelete messages.

> and I doubt you want the
> overhead of changing the "Delete" button for normal/deleted items

The button itslef is OK, only the text needs updating. I have no idea what it
would cost to keep changing the text there and if it's large we might consider
some more neutral text (e.g. "[Un]delete" or something similar).

Comment 46

16 years ago
I have tested this in 0.9.9 and it works much as I am used to!

One request though: When a single deleted message is selected (in "Mark as
deleted" mode) and I press Del to undelete, I expect the selection to move to
the next message just the same it would do if I was pressing Del on a
not-deleted message.

Hmm, did that make sense? :-)

Comment 47

16 years ago
Using 2002031803 in W2K, and IMAP with "mark as deleted":
There is a problem with this item and context menus: If the message is not
selected first via left click, but directly right clicked on, the context menu
does not update the Deleted/Undeleted information. 

To reproduce:
1. Have IMAP folder with at least 1 message marked as deleted and at least one
other message. 
2. Select the deleted message (left click)
3. Right click another, non-deleted message (without left clicking)

Result:
Context menu says "Undelete Message", should say: "Delete"

This also works the other way round (select non-deleted, then right click
deleted, ...)

Sean, can you confirm this? Should I file a new bug about this issue? 
(Assignee)

Comment 48

16 years ago
Andreas, Sean has already filed bug 128916.

Comment 49

16 years ago
Comment on attachment 71655 [details] [diff] [review]
Update for "bitrot"

obsoleting checked in patch.
Attachment #71655 - Attachment is obsolete: true

Comment 50

16 years ago
*** Bug 134952 has been marked as a duplicate of this bug. ***

Comment 51

16 years ago
Here's some additional data:
The undelete/delete context menu appears to reflect the choice for the message
that is currently selected, not the one that you're getting the context menu
for.  To reproduce in RC 1 (Build 2002041711):

With an IMAP message list (IMAP in mark deleted mode), including some messages
which are marked deleted and some which are not:

Case A:
1) Select a message which is not marked deleted
2) Right click on that message.  Note that the context menu says "Delete Message"
3) Right click on a message which is marked deleted.  Note that the context menu
still says "Delete Message"
4) Just for yucks, right click on a message which is not marked deleted.  Note
that the context menu says "Delete Message"

Case B:
1) Select a message which is marked deleted
Repeat the steps in Case A, but notice that the context menu now says "Undelete
Message".

Expected behavior:
Context menu should reflect deleted/undeleted state for the message under the
right-click, not the currently selected message.

Updated

16 years ago
Blocks: 158011

Comment 52

16 years ago
I remove nsbeta1- keyword - it was for MachV.
Keywords: nsbeta1-

Comment 53

16 years ago
Now I add 'nsbeta1' keyword for Buffy. Sorry, it's faster to edit multiple bugs
at once than manually go to each and remove minus.
Keywords: nsbeta1

Comment 54

16 years ago
Mail triage team: nsbeta1-
Keywords: nsbeta1-

Updated

16 years ago
Keywords: nsbeta1
neil says that his fix in bug #161333 will fix this.
Assignee: ssu → neil
Status: REOPENED → NEW
Depends on: 161333
accepting, on neil's behalf.
Status: NEW → ASSIGNED
Target Milestone: mozilla1.2alpha → mozilla1.3beta
(Assignee)

Comment 57

15 years ago
Fixed by checking to bug 161333.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey

Comment 58

13 years ago
*** Bug 207488 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.