Applications crashes when started without network connectivity

RESOLVED DUPLICATE of bug 824677

Status

--
critical
RESOLVED DUPLICATE of bug 824677
6 years ago
6 years ago

People

(Reporter: gerard-majax, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Previously, we had things like bug 809184. Now, when starting Marketplace and having no network connectivity, it simply crashes badly. It was not present with gecko/gaia from past week-end. Current tree: gecko @ dfcb8d6, gaia @ 97cdcec.

Steps to reproduce:
 1. disconnect from network
 2. tap on marketplace
 3. admire crash:
E/GeckoConsole(   77): Content JS INFO at app://system.gaiamobile.org/js/window_manager.js:1087 in createFrame: %%%%% Launching Marketplace as remote (OOP)
I/Gecko   (   77): [Parent 77] WARNING: waitpid failed pid:240 errno:10: file /home/alex/codaz/B2G/gecko/ipc/chromium/src/base/process_util_posix.cc, line 260
I/Gecko   (   77): [Parent 77] WARNING: waitpid failed pid:240 errno:10: file /home/alex/codaz/B2G/gecko/ipc/chromium/src/base/process_util_posix.cc, line 260
I/Gecko   (   77): [Parent 77] WARNING: Failed to deliver SIGKILL to 240!(3).: file /home/alex/codaz/B2G/gecko/ipc/chromium/src/chrome/common/process_watcher_posix_sigchld.cc, line 118
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?
Can't reproduce on the 1/4/2013 build.
Status: NEW → RESOLVED
blocking-basecamp: ? → ---
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

6 years ago
Which is cool, since I'm talking about a build from TODAY, i.e. 1/5/2013.
(In reply to Alexandre LISSY :gerard-majax from comment #2)
> Which is cool, since I'm talking about a build from TODAY, i.e. 1/5/2013.

Ah...I'll go retest then.
Status: RESOLVED → REOPENED
Keywords: regression
Resolution: WORKSFORME → ---
I confirm I see this bug on today’s build, too. Re-opening.
blocking-basecamp: --- → ?
Well I guess that confirms it's a regression over the past day - so at least we have a regression window.

Updated

6 years ago
Duplicate of this bug: 826747
(Reporter)

Updated

6 years ago
Summary: Marketplace crashes when started without network connectivity → Applications crashes when started without network connectivity
(Reporter)

Comment 7

6 years ago
Turns out I can also reproduce it with Maps.
Can't reproduce it on a 1/5/2013 build. I'm getting the network connection error as expected. No crash seen.

Needs more info on why this is only happening to certain people.
Keywords: qawanted
(Reporter)

Comment 9

6 years ago
Can you compare your git head with mine ? Maybe it got fixed meanwhile ?
(In reply to Alexandre LISSY :gerard-majax from comment #9)
> Can you compare your git head with mine ? Maybe it got fixed meanwhile ?

  <project name="releases/gecko.git" path="gecko" remote="mozillaorg" revision="bb75a23e13b9c8a1498de35773fde0bb4574c2bc"/>
  <project name="releases/gaia.git" path="gaia" remote="mozillaorg" revision="67b917fa8146708828708cd1077ed007200fa2c9"/>

If you are building from tip then my guess the regression literally must have happened hours ago then. I am using - https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18-unagi/latest/.
(Reporter)

Comment 11

6 years ago
$ git log --oneline bb75a23e13b9c8a1498de35773fde0bb4574c2bc..master
dfcb8d6 Bug 823789 - Pass enableHighAccuracy geolocation changes to the chrome process. r=dougt a=bbajaj

$ git log --oneline 67b917fa8146708828708cd1077ed007200fa2c9..master
97cdcec Merge pull request #7297 from davidflanagan/bug826621
cef2c56 Bug 826621 - when we clear a media frame, remember that we cleared it r=daleharvey a=blocking+
86c5b91 Merge pull request #7296 from mozsquib/email-autoconfig-xhr-workaround
447509a Bug 826468 - [Email] Change in XHR behaviour makes autoconfig fail on "Looking in local file store" for all domains not in gaia/apps/email/autoconfig/ (workaround); r=asuth, a=blocking-basecam
61c9080 Fix unit test instructions in readme
83aa465 Merge pull request #7293 from Pike/bug-824621-l12y-email-address
3012db3 bug 824621, localize email address placeholder in ftu
cd82895 Merge pull request #6845 from jedp/811528-pref-identity-on
a6b9bd8 Merge pull request #7290 from timdream/scm/remove-cpulock-when-manual-off
7f2ea65 Bug 826366 - Remove on call cpu wakelock if the screen is not turned off by proximity event
9c8474d Merge pull request #7291 from ttaubert/cardsview/bug-826354-dont-show-when-locked
321c4f7 Bug 826354 - Don't show cards view when screen is locked
b67e7f5 Merge pull request #7289 from etiennesegonzac/bug-826177-call-waiting-notification
fa40ea0 Bug 826177 - Vibrate every 2 secs as long as a call is waiting. r=alive
c4e98b9 Bug 811528 - pref native identity on
(Reporter)

Comment 12

6 years ago
Trying to bisect: alex@portable-alex:~/codaz/B2G/gaia$ git bisect bad 97cdcec5276640c45942517603a3ce83fe60e5a0
You need to start by "git bisect start"
Do you want me to do it for you [Y/n]? y
alex@portable-alex:~/codaz/B2G/gaia$ git bisect good 67b917fa8146708828708cd1077ed007200fa2c9
Bisecting: a merge base must be tested
[ea2b9f64921e80f6068e906eae880fcb7ea3f4cf] Merge pull request #7286 from michalbe/non-selectable-card
alex@portable-alex:~/codaz/B2G/gaia$ git bisect bad ea2b9f64921e80f6068e906eae880fcb7ea3f4cf
The merge base ea2b9f64921e80f6068e906eae880fcb7ea3f4cf is bad.
This means the bug has been fixed between ea2b9f64921e80f6068e906eae880fcb7ea3f4cf and [67b917fa8146708828708cd1077ed007200fa2c9].
Just a note re: the bug that I opened. I am definitely seeing this even *with* network connectivity, so I'm not sure that this bug is an exact dupe.
(In reply to Bob Silverberg from comment #13)
> Just a note re: the bug that I opened. I am definitely seeing this even
> *with* network connectivity, so I'm not sure that this bug is an exact dupe.

Okay. I just reopened that bug.
Looks like this is a dupe of bug 824677.
Status: REOPENED → RESOLVED
blocking-basecamp: ? → ---
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 824677

Updated

6 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.