'Video can't be played because the file is corrupt' on some HTC Gingerbread devices

RESOLVED INCOMPLETE

Status

()

Core
Audio/Video: Playback
RESOLVED INCOMPLETE
5 years ago
12 days ago

People

(Reporter: AdrianT, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox18 unaffected, firefox19 unaffected, firefox20+ wontfix, firefox21- affected, firefox22- affected, relnote-firefox 20+, fennec+)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Aurora 20.0a2 2012-01-09
HTC Desire Z (Android 2.3.3)

Steps to reproduce:
1) Go to fandango.com - continue to the website when asked to download the app
2) Search for any movie- for e.g. Monsters Inc
3) Tap the Play Trailer button

Expected results:
The Trailer is played

Actual results:
Nothing happens

Note:
The trailer is played in the Video app if opened on the Stock Browser
This may be the same/related to bug 825158
I am not 100% but at some point this may have worked on Firefox Mobile unless Fandango has changed their website
(Reporter)

Comment 1

5 years ago
Sorry for the mistake in Comment 0 the issue was tested on Aurora 20.0a2 2013-01-09 on the HTC Desire Z (Android 2.3.3)
Works for me (Galaxy Nexus Android 4.1.2) it downloads and plays in the gallery application.

I/ActivityManager(  389): START u0 {act=android.intent.action.VIEW dat=file:///storage/emulated/0/Download/343655-3-750.mp4 typ=video/mp4 flg=0x4000000 cmp=com.google.android.gallery3d/com.android.gallery3d.app.MovieActivity} from pid 10360
D/GeckoAppShell(10360): GeckoAppShell.showAlertNotification
D/GeckoAppShell(10360): - image = 'drawable://alert_download'
D/GeckoAppShell(10360): - title = '343655-3-750.mp4'
D/GeckoAppShell(10360): - text = 'Download complete'
D/GeckoAppShell(10360): - cookie = ''
D/GeckoAppShell(10360): - name = 'download:///storage/emulated/0/Download/343655-3-750.mp4'
I/ActivityManager(  389): Displayed com.google.android.gallery3d/com.android.gallery3d.app.MovieActivity: +974ms
(Reporter)

Comment 3

5 years ago
Created attachment 701086 [details]
log

Log from the Asus EEE Transformer TF101 (Android 4.0.3) running Nightly 21.0a1 2013-01-10. The same issue is reproducible.
Ok, I see what's going on here. We've lost playback support in Nightly all of a sudden, filed as bug 829655. In Aurora, I get playback working fine on Fandango though, so that must be a different problem.
This works for me now with the recent m-c prefs bustage (affected Stagefright).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

5 years ago
This is still broken on Nightly 21.0a1 2013-01-17 on the HTC Desire Z (Android 2.3.3). I still don't get any action after I press the play trailer button.

Please see the video capture: http://youtu.be/pH3E1RRZXcE. I have also waited alot of time after for a download or anything to start but with no results
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I/MediaPluginHost(  947): Loading OMX Plugin: nullptr
Blocks: 787228
Summary: Unable to play movie trailers at Fandango.com → Unable to play movie trailers at Fandango.com in Android 2.3 -- I/MediaPluginHost(): Loading OMX Plugin: nullptr

Updated

5 years ago
Component: General → Video/Audio
Product: Firefox for Android → Core

Updated

5 years ago
This is reproducible on my Nexus One (Android 2.3) →  http://video.fandango.com/mobile/FandangoMovies/343649-1/343649-1-750.mp4

I/MediaPluginHost(  947): Loading OMX Plugin: nullptr

Updated

5 years ago
tracking-firefox19: --- → ?

Updated

5 years ago
Status: REOPENED → NEW

Updated

5 years ago
status-firefox18: affected → unaffected
tracking-firefox19: ? → ---
tracking-firefox20: --- → ?

Updated

5 years ago
status-firefox19: affected → unaffected

Comment 9

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #8)
> This is reproducible on my Nexus One (Android 2.3) → 
> http://video.fandango.com/mobile/FandangoMovies/343649-1/343649-1-750.mp4
> 
> I/MediaPluginHost(  947): Loading OMX Plugin: nullptr

Would you mind bisecting?
tracking-firefox20: ? → +
Keywords: regressionwindow-wanted
QA Contact: aaron.train

Comment 10

5 years ago
(In reply to adrian tamas from comment #6)
> This is still broken on Nightly 21.0a1 2013-01-17 on the HTC Desire Z
> (Android 2.3.3). I still don't get any action after I press the play trailer
> button.

Have gingerbread phones been un-blacklisted? If not, this would be expected behaviour. What happens if you have "stagefright,force-enabled" set to true?
Using the same URL I posted; force enabling stagefright, I get a general GeckoConsole error indicating that the selected media resource could not be decoded 

E/GeckoConsole(  732): [JavaScript Warning: "Media resource http://link.theplatform.com/s/kyWZtB/RxIS0BKwApasCdWh_kiDcDDDY3j6pugp?metafile=false could not be decoded." {file: "http://video.fandango.com/mobile/FandangoMovies/343649-1/343649-1-750.mp4" line: 0}]
(In reply to Chris Double (:doublec) from comment #10)
> (In reply to adrian tamas from comment #6)
> > This is still broken on Nightly 21.0a1 2013-01-17 on the HTC Desire Z
> > (Android 2.3.3). I still don't get any action after I press the play trailer
> > button.
> 
> Have gingerbread phones been un-blacklisted? If not, this would be expected
> behaviour.

It looks like this never happened yet

https://bugzilla.mozilla.org/show_bug.cgi?id=823253
Chris, passing this on to you based on 823253/787228 . Please feel free to re-assign if needed :)
Assignee: nobody → chris.double
tracking-fennec: ? → +
Keywords: qawanted

Comment 14

5 years ago
Given URL works for me on a Samsung Galaxy S2 with GB running nightly

Comment 15

5 years ago
Also works for me on an HTC EVO Design running 2.3.4. Nexus One issue mentioned in comment 8 is possibly bug 817868.
Is the best approach to take here to uplift the removal of GB phones from the blacklist in but 823253?  If so please nominate the uplift this week so we can get this landed & verified in FF20 beta 4 which goes to build next Tues Mar 12th in the morning PT.

Comment 17

5 years ago
I'd like to hear from the original submitted and/or Aaron Train first to hear if nightly builds work on their devices.
Flags: needinfo?(adrian.tamas)
I'm still able to reproduce this issue on Asus EEE Transformer TF101 (Android 4.0.3) running Nightly 22.0a1(2013-03-07). Nothig happens when pressing on the "Play Trailer" button

On HTC Desire Z (Android 2.3.3) running the same build, after pressing on "Play Trailer", the player is created but the video won't play. "Video can't be played because the file is corrupt" message is displayed in player.

On Samsung Galaxy R (Android 2.3.4) videos are played correctly
Flags: needinfo?(adrian.tamas)
Regression range found on Asus EEE Transformer TF101:
Good build: 01-11-2012
Bad build: 02-11-2012
Possible range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5bd5bb168eb1&tochange=556b9cfb269f
Keywords: regressionwindow-wanted
So http://hg.mozilla.org/mozilla-central/rev/f710f9f6f7ec ?
Chris is there anything that jumps out from that window? If the above change-set is the issue, why would the implementation of StageFright decoding break the TF101 in particular? Is there an initial blocklist on the device above?
Flags: needinfo?(chris.double)
Keywords: qawanted
(In reply to Aaron Train [:aaronmt] from comment #21)
> If the above change-set is the issue, why would the implementation of StageFright
> decoding 

^blocklisting

Comment 23

5 years ago
If you have "stagefright.force-enabled" set to true then the blocklist isn't used so I can't see how that patch would have affected things. Without that setting the Asus would be blocklisted but the Desire Z should be fine.
Flags: needinfo?(chris.double)
Catalin, can you try that out on your devices?
Flags: needinfo?(catalin.suciu)
I saved one of the Fandango video's to http://people.mozilla.com/~kbrosnan/tmp/829454/829454.mp4

On similar hardware a HTC G2 I get 

03-18 17:16:49.640 E/GeckoConsole(14888): [JavaScript Warning: "Media resource http://people.mozilla.com/~kbrosnan/tmp/829454/829454.mp4 could not be decoded."
{file: "http://people.mozilla.com/~kbrosnan/tmp/829454/829454.mp4" line: 0}]
Created attachment 726427 [details]
VLC debug message log

I am attaching a VLC Message log of the start of playback of the video I saved. Maybe it contains some interesting info about the file?

Comment 27

5 years ago
Created attachment 726524 [details]
screenshot HTC

HTC Desire Z (Android 2.3.3)
Nightly 22.0a1 2012-01-09 

- play button triggers the trailer page , but this canțt be displayed 
- corruption message displayed
Flags: needinfo?(catalin.suciu)

Comment 28

5 years ago
Asus Eee Transformers (Android 4.0.3)
Nightly 22.0a1 2012-01-09 

- play button doesn't trigger the trailer page (the spin icon from URL appears, stops - same page display )
Are you able to play any other video on the device? (e.g, http://people.mozilla.org/~atrain/mobile/tests/media.html) ?
Flags: needinfo?(ioana.chiorean)

Comment 30

5 years ago
noupe - "No video with supported format and MIME type found " on both devices.
Flags: needinfo?(ioana.chiorean)
Same here on my Motorola Droid Bionic (Android 2.3.4) w/Nightly (03/19)

03-19 14:52:58.218  2115  2124 E GeckoConsole: [JavaScript Warning: "HTTP "Content-Type" of "video/mp4" is not supported. Load of media resource http://people.mozilla.org/~atrain/mobile/tests/test.mp4 failed." {file: "http://people.mozilla.org/~atrain/mobile/tests/media.html" line: 0}]
03-19 14:52:58.218  2115  2124 E GeckoConsole: [JavaScript Warning: "All candidate resources failed to load. Media load paused." {file: "http://people.mozilla.org/~atrain/mobile/tests/media.html" line: 0}]

Same video works fine on my LG Nexus 4 (Android 4.2.2) w/ Nightly (03/19)
On my Sony Xperia Play (Android 2.3.4) w/Nightly (03/19)
http://people.mozilla.com/~kbrosnan/tmp/829454/829454.mp4

→ I/MediaPluginHost( 1807): Loading OMX Plugin: nullptr


Force-enabling stagefright yields a crash, bug 818363.
relnote-firefox: --- → ?

Comment 33

5 years ago
I've requested a Sony Xperia Play for testing.

Comment 34

5 years ago
Testing on the Play shows the media not playing is due to the device being blocklisted. I suspect this is the reason for all the other devices not playing it too. For enabling stagefright on the Play results in bug 818363.

Comment 35

5 years ago
Ioana, if you visit http://cd.pn/b on the HTC Desire Z and press the play button, does the video play?
Flags: needinfo?(ioana.chiorean)

Comment 36

5 years ago
Aaron, if you visit http://cd.pn/b on the Motorola Droid  Bionic, with stagefight.force-enabled set to true, does the video play?
Flags: needinfo?(aaron.train)
(In reply to Chris Double (:doublec) from comment #36)
> Aaron, if you visit http://cd.pn/b on the Motorola Droid  Bionic, with
> stagefight.force-enabled set to true, does the video play?

Correct; albeit with bug 841647 still an issue.
Flags: needinfo?(aaron.train)
On my Motorola Droid Pro (Android 2.3.4)

http://people.mozilla.com/~kbrosnan/tmp/829454/829454.mp4
03-21 23:19:25.557  3037  3046 I MediaPluginHost: Loading OMX Plugin: nullptr
(In reply to Aaron Train [:aaronmt] from comment #38)
> On my Motorola Droid Pro (Android 2.3.4)
> 
> http://people.mozilla.com/~kbrosnan/tmp/829454/829454.mp4
> 03-21 23:19:25.557  3037  3046 I MediaPluginHost: Loading OMX Plugin: nullptr

Plays with stagefight.force-enabled with bug 841647 an issue on this device too.
(In reply to Chris Double (:doublec) from comment #35)
> Ioana, if you visit http://cd.pn/b on the HTC Desire Z and press the play
> button, does the video play?

Video is not played on HTC Desire Z. 'Video can't be played because the file is corrupt' message is displayed.
Flags: needinfo?(ioana.chiorean)

Comment 41

5 years ago
From what I can tell this bug is a a number of different things

1) Loading OMX Plugin: nullptr
   This is the result of a device being blocklisted. A bug should be raised for that device to be supported. Force enabling stagefright should result in playback but may show other bugs (eg. the crash on the Xperia Play and the corrupted video image on the Droid Pro, both of which have bugs for them).

2) "No video with supported format and MIME type found"
   This is the same as (1) but is the error that gets reported via the video controls. (1) is what is shown in "adb logcat".

3) 'Video can't be played because the file is corrupt'
   This seems to be on some HTC gingerbread devices, notably the HTC Desire Z. I think this bug's title should be changed to match this and I'll attempt to get an HTC Desire Z to reproduce the error so I can fix it.

Can any of the bug reports in this bug let me know if anything sounds incorrect with the above.
(In reply to Chris Double (:doublec) from comment #41)
> 3) 'Video can't be played because the file is corrupt'
>    This seems to be on some HTC gingerbread devices, notably the HTC Desire
> Z. I think this bug's title should be changed to match this and I'll attempt
> to get an HTC Desire Z to reproduce the error so I can fix it.

Given this, I think anything actionable in this bug in particular is past the mozilla-20 time-frame now; I'll let a driver make that call here.
Flags: needinfo?(lsblakk)
Agreed, we're going to build our final FF20 beta today so this is going to have to be wontfixed and work continued for FF21.
status-firefox20: affected → wontfix
status-firefox22: --- → affected
tracking-firefox21: --- → +
tracking-firefox22: --- → +
Flags: needinfo?(lsblakk)
relnote-firefox: ? → 20+
(In reply to Catalin Suciu from comment #40)
> (In reply to Chris Double (:doublec) from comment #35)
> > Ioana, if you visit http://cd.pn/b on the HTC Desire Z and press the play
> > button, does the video play?
> 
> Video is not played on HTC Desire Z. 'Video can't be played because the file
> is corrupt' message is displayed.

same on a asus transformer pad tf300t with android 4.2.1 firefox 21beta

Updated

4 years ago
Duplicate of this bug: 859250
As per a report from bug 859250, this is also an issue (when force-enabling stagefright) on the HTC Desire HD (Android 2.3.3)
(In reply to Chris Double (:doublec) from comment #41)
> From what I can tell this bug is a a number of different things
> 
> 1) Loading OMX Plugin: nullptr
>    This is the result of a device being blocklisted. A bug should be raised
> for that device to be supported. Force enabling stagefright should result in
> playback but may show other bugs (eg. the crash on the Xperia Play and the
> corrupted video image on the Droid Pro, both of which have bugs for them).
> 
> 2) "No video with supported format and MIME type found"
>    This is the same as (1) but is the error that gets reported via the video
> controls. (1) is what is shown in "adb logcat".

After landing bug 823253 (removing the blocklist) in FF21, I'm assuming we'll need to follow up on the following bugs that may/will now crop up, so we've tracked them.

Sony Xperia Play & Sony Ericsson ST18i - crash in bug 818363 (fix/blocklist?)
Motorola Droid Pro - bug 841647 (fix/blocklist?)
A number of Samsung devices - bug 847837 (sounds like we'll blocklist)

> 3) 'Video can't be played because the file is corrupt'
>    This seems to be on some HTC gingerbread devices, notably the HTC Desire
> Z. I think this bug's title should be changed to match this and I'll attempt
> to get an HTC Desire Z to reproduce the error so I can fix it.

Done.
Summary: Unable to play movie trailers at Fandango.com in Android 2.3 -- I/MediaPluginHost(): Loading OMX Plugin: nullptr → 'Video can't be played because the file is corrupt' on some HTC Gingerbread devices
We've blocklisted related devices for FF22, and see little reason to continue tracking.
tracking-firefox21: + → -
tracking-firefox22: + → -

Comment 49

3 years ago
Does this still happen?

Comment 50

3 years ago
The issue is still present at least for videos on german news site spiegel.de:

  http://m.spiegel.de/video/

Just pick a random video and try to play it in Firefox - it won't play but say "Video can't be played because the file is corrupt.'

Firefox 31 on LG Nexus 4 with Cyanogenmod 10.2.1

e.g. http://video.spiegel.de/flash/13/51/1511531_iphone.mp4

% wget -S http://video.spiegel.de/flash/13/51/1511531_iphone.mp4
--2014-08-01 20:06:28--  http://video.spiegel.de/flash/13/51/1511531_iphone.mp4
Resolving video.spiegel.de (video.spiegel.de)... 85.183.195.59, 85.183.195.115
Connecting to video.spiegel.de (video.spiegel.de)|85.183.195.59|:80... connected.
HTTP request sent, awaiting response... 
  HTTP/1.1 200 OK
  Server: Apache
  ETag: "d8a383e544e74b78c69d697d7437eb23:1406728268"
  Last-Modified: Wed, 30 Jul 2014 13:51:08 GMT
  Accept-Ranges: bytes
  Content-Length: 3696978
  Content-Type: video/mp4
  Cache-Control: max-age=55258
  Expires: Sat, 02 Aug 2014 09:27:26 GMT
  Date: Fri, 01 Aug 2014 18:06:28 GMT
  Connection: keep-alive
Length: 3696978 (3.5M) [video/mp4]
Saving to: '1511531_iphone.mp4'

100%[===============>] 3,696,978    749KB/s   in 4.8s   

2014-08-01 20:06:33 (754 KB/s) - '1511531_iphone.mp4' saved [3696978/3696978]

% sha1sum 1511531_iphone.mp4
3a77ec86fcee7cbc8fdd468709cf930f4e399e9a  1511531_iphone.mp4

% avprobe 1511531_iphone.mp4
avprobe version 0.8.12-6:0.8.12-0ubuntu0.13.10.1, Copyright (c) 2007-2014 the Libav developers
  built on Jun 10 2014 15:33:35 with gcc 4.8.1
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '1511531_iphone.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2mp41
    encoder         : Lavf55.36.100
  Duration: 00:01:13.80, start: 0.046440, bitrate: 400 kb/s
    Stream #0.0(eng): Video: mpeg4 (Simple Profile), yuv420p, 480x270 [PAR 1:1 DAR 16:9], 334 kb/s, 25 fps, 25 tbr, 12800 tbn, 25 tbc
    Stream #0.1(eng): Audio: aac, 44100 Hz, stereo, s16, 64 kb/s

Comment 51

3 years ago
I'm sorry if i used the wrong bug - my issue is related to Jelly Bean (4.3.1) on LG Nexus 4 devices with CyanogenMod.
filter on [mass-p5]
Priority: -- → P5

Updated

3 years ago
Assignee: cajbir.bugzilla → nobody
Component: Audio/Video → Audio/Video: Playback

Comment 53

12 days ago
Gingerbread is no longer supported.
Status: NEW → RESOLVED
Last Resolved: 5 years ago12 days ago
Priority: P5 → --
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.