Closed Bug 831923 Opened 10 years ago Closed 9 years ago

Story - Use the Firefox Start Top Sites tile group in full screen view

Categories

(Tracking Graveyard :: Metro Operations, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: asa, Assigned: ally)

References

Details

(Whiteboard: feature=story c=firefox_start u=metro_firefox_user p=13 status=verified)

Attachments

(1 file)

No description provided.
Priority: -- → P1
Whiteboard: c=Awesome_screen u= p= → c=Awesome_screen u=metro_firefox_user p=
Assignee: nobody → asa
Assignee: asa → nobody
Priority: P1 → P2
Whiteboard: c=Awesome_screen u=metro_firefox_user p= → c=Awesome_screen u=metro_firefox_user p=13
Summary: Use the Awesome screen Top Sites tile group → Story – Use the Awesome screen Top Sites tile group
Whiteboard: c=Awesome_screen u=metro_firefox_user p=13 → c=Awesome_screen u=metro_firefox_user p=13 feature=story
OS: Windows 8 → Windows 8 Metro
Whiteboard: c=Awesome_screen u=metro_firefox_user p=13 feature=story → feature=story c=Awesome_screen u=metro_firefox_user p=0
Summary: Story – Use the Awesome screen Top Sites tile group → Story – Use the Firefox Start Top Sites tile group
Whiteboard: feature=story c=Awesome_screen u=metro_firefox_user p=0 → feature=story c=Awesome_screen u=metro_firefox_user p=13
Whiteboard: feature=story c=Awesome_screen u=metro_firefox_user p=13 → feature=story c=firefox_start u=metro_firefox_user p=13
Summary: Story – Use the Firefox Start Top Sites tile group → Story - Use the Firefox Start Top Sites tile group
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---
Depends on: 794028
Assignee: nobody → ally
Blocks: metrov1it3
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Depends on: 848155
Hi Asa,

Can you remove 848155 and convert it into it's own story as Ally recommended or does it need to stay to truly complete the story as described?
Flags: needinfo?(asa)
QA Contact: jbecerra
As per the email ont eh metro mailing list, I would like to call this 'done' with a defect story, and a new feature in bug 848155
QA Contact: jbecerra
Blocks: metrov1backlog
No longer blocks: metrov1it3
(In reply to Marco Mucci [:MarcoM] from comment #1)
> Hi Asa,
> 
> Can you remove 848155 and convert it into it's own story as Ally recommended
> or does it need to stay to truly complete the story as described?

I don't think that's really a story. Maybe we close this story and treat 848155 as a defect or change?
Flags: needinfo?(asa)
Thanks Asa.  OK, we can treat 848155 as a separate Change Story.
Blocks: metrov1it4
No longer blocks: metrov1backlog
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Flags: needinfo?(jbecerra)
QA Contact: jbecerra
Depends on: 851576
Tested on 2013-03-15 using Nightly built from http://hg.mozilla.org/mozilla-central/rev/0f7261e288f2
- (defect?) Tested with a new profile opening more than 9 sites. After restart and opening a new tab, I see the Top Sites group with 8 tiles. I can tap of any of them to open the intended site. Filed bug 851576.
- In snapped view the top sites link does not work, so I added 835999 to the list of bugs this depends on.

The story says that with a new profile a user should see 9 blank tiles. This is not the case. It the Top Sites area is empty, and that seems right but I would like the story to be revised to account for this.
Flags: needinfo?(jbecerra)
Flags: needinfo?(asa)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
From Juan's Testing:

Tested on 2013-03-15 using Nightly built from http://hg.mozilla.org/mozilla-central/rev/0f7261e288f2
- Tested with a new profile opening more than 9 sites. After browser restart and opening a new tab, I see the Top Sites group with 8 tiles.

Steps:
1. Install Firefox anew
2. Open Firefox for Metro and open more than 9 sites
3. Close the browser and reopen it
4. Open a new tab.

Expected: Top Sites list should have 9 tiles

Actual: Top Sites list has 8 tiles
Depends on: 851592
No longer depends on: 851592
(In reply to Marco Mucci [:MarcoM] from comment #6)
> Expected: Top Sites list should have 9 tiles
> 
> Actual: Top Sites list has 8 tiles

This is not a bug, this was a change as requested by Yuan, blessed by Asa, and filed as a defect, bug 848999(though if one wishes to split hairs, it is a change story because when the first topsites code landed in october, the directive was 9). 

This was discussed at the monday meeting.
(In reply to juan becerra [:juanb] from comment #5)
> - In snapped view the top sites link does not work, so I added 835999 to the
> list of bugs this depends on.

Not part of this story, that is part of story 831894. In general, the snapped actions are separate from the full screen stories, so please bear that in mind when testing.
Summary: Story - Use the Firefox Start Top Sites tile group → Story - Use the Firefox Start Top Sites tile group in full screen view
Depends on: 848999
Thanks Ally.  Bug 848999 wasn't linked to 831923.  I've added that dependency.
Flags: needinfo?(asa)
Flags: needinfo?(jbecerra)
I'll mark this as verified, per comments.

QA note: Story should reflect 8 vs. 9 tiles and snapped view behavior is a separate story.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Flags: needinfo?(jbecerra)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Whiteboard: feature=story c=firefox_start u=metro_firefox_user p=13 → feature=story c=firefox_start u=metro_firefox_user p=13 status=verified
Depends on: 875924
Tested as per Comment 5 but noticed that the thumbnails do not always show up. Posted bug 875924 for that.
No longer depends on: 875924
Depends on: 873171
Depends on: 878207
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20130707 Firefox/25.0
Build ID: 20130707031138

WFM for iteration-9
Tested on Windows 8.1 preview using latest nightly build from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-07-03-11-38-mozilla-central/
I used same steps given in user story.
I am getting expected result.
Depends on: 891214
Depends on: 872243
Depends on: 895519
No longer depends on: 878207
Depends on: 875924
No longer depends on: 873171
OS: Windows 8 Metro → Windows 8.1
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.