Closed Bug 831952 Opened 7 years ago Closed 7 years ago

Story - Context menu for selected text

Categories

(Tracking Graveyard :: Metro Operations, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: asa, Assigned: jimm)

References

Details

(Whiteboard: feature=story c=Context_menus u=metro_firefox_user p=3 status=verified)

Attachments

(1 file)

No description provided.
Priority: -- → P2
Whiteboard: c=Context_menus u= p= → c=Context_menus u=metro_firefox_user p=
OS: Windows 8 → Windows 8 Metro
Summary: Selection context menu → Story - Selection context menu
Whiteboard: c=Context_menus u=metro_firefox_user p= → feature=story c=Context_menus u=metro_firefox_user p=0
Summary: Story - Selection context menu → Story - Context menu for selected text
Depends on: 782810
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: feature=story c=Context_menus u=metro_firefox_user p=0 → feature=story c=Context_menus u=metro_firefox_user p=0 status=for_testing
Blocks: metrov1legacy
No longer blocks: metrov1backlog
Tested on 2013-02-21 Nightly built from http://hg.mozilla.org/mozilla-central/rev/d57a813c77a4
- Reopening because long press on selected text does not bring up the context menu for the selection.
- Also, the context menu that can be opened with the right click on the trackpad only brings up "Copy" as an option, when it does bring a context menu (it mostly doesn't).

Main success scenarios 1, 2, and 4 are not working, and after several attempts to bring up the context menu with the trackpad I was not able to test 3.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Sorry, I don't remember why I closed this, but shouldn't have. This is dependent on selection in content.
Depends on: 831985
Priority: P2 → P4
Blocks: metrov1planning
No longer blocks: metrov1legacy
Priority: P4 → P3
Whiteboard: feature=story c=Context_menus u=metro_firefox_user p=0 status=for_testing → feature=story c=Context_menus u=metro_firefox_user p=0
To clarify, this works for pointer-based selection in today's most recent build http://hg.mozilla.org/mozilla-central/rev/702d2814efbf, but not for a touch selection.
Walking through the context menu on 02/22 build today, most context menu works properly for me. Well done. 


I noticed I didn't provide the spec for the text clipboard context menu. Here is my opinion.

Currently the menu contains: 
- Copy
- Paste
- Search Bing for ".."

I don't think Search on Bing is an useful option in this context. Users' focus on creating/editing, so they don't want to be directed to a search page. Also, on desktop, there is no "Search google" for selected texts in text field.

We should change the menu to: 
- Cut
- Copy
- Paste

The most standard sequence.

If there is no text in the clipboard that can be pasted into text that the user can edit, the default context menu should be:
- Cut
- Copy


Lastly, I did notice the context menu is closer to the touch point. It'd be even better if we follow the MS standard, which is the context menu should be centered above the object that it is acting on. (I can file a bug on that)
(In reply to Yuan Wang(:Yuan) – Firefox UX Team from comment #5)
> Walking through the context menu on 02/22 build today, most context menu
> works properly for me. Well done. 
> 
> 
> I noticed I didn't provide the spec for the text clipboard context menu.
> Here is my opinion.
> 
> Currently the menu contains: 
> - Copy
> - Paste
> - Search Bing for ".."
> 
> I don't think Search on Bing is an useful option in this context. Users'
> focus on creating/editing, so they don't want to be directed to a search
> page. Also, on desktop, there is no "Search google" for selected texts in
> text field.
> 
> We should change the menu to: 
> - Cut
> - Copy
> - Paste
> 
> The most standard sequence.
> 
> If there is no text in the clipboard that can be pasted into text that the
> user can edit, the default context menu should be:
> - Cut
> - Copy
> 
> 
> Lastly, I did notice the context menu is closer to the touch point. It'd be
> even better if we follow the MS standard, which is the context menu should
> be centered above the object that it is acting on. (I can file a bug on that)

Bugs on both please. We have positioning rules we can tweak to get the right position based on where the touch point is on the screen. Also, please take into account left and right hand users in any spec.

http://mxr.mozilla.org/mozilla-central/source/browser/metro/base/content/helperui/MenuUI.js#396
Blocks: 844658
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Flags: needinfo?(jbecerra)
Resolution: --- → FIXED
Hey Jim and Juan, I am going to temporarily Reopen this story so I can add it to Iteration #3.  As soon as it is added I will change the status back to Resolved/Fixed.  

Jim, before I Reopen it, can you provide a point estimate for this story.
Flags: needinfo?(jmathies)
Blocks: metrov1it3
No longer blocks: metrov1planning
Whiteboard: feature=story c=Context_menus u=metro_firefox_user p=0 → feature=story c=Context_menus u=metro_firefox_user p=3
Flags: needinfo?(jmathies)
Status: RESOLVED → REOPENED
Flags: needinfo?(jbecerra)
Resolution: FIXED → ---
Assignee: nobody → jmathies
Priority: P3 → P2
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Flags: needinfo?(jbecerra)
Resolution: --- → FIXED
Tested on 2013-03-05 using a nightly built from: http://hg.mozilla.org/mozilla-central/rev/015da7030aab

- Tested context menu on selected text in content and it shows a Copy and Search Bing for "...". This is as described by the story.
- I will mark this as verified based on the above.

- I don't know if we have a story for context menus in selected text in editable text (like text boxes), but I think that needs to be defined. I will ping Marco to create a story for this if it doesn't exist already.

You can try http://www.utexas.edu/learn/forms/boxes.html as an example.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jbecerra)
Whiteboard: feature=story c=Context_menus u=metro_firefox_user p=3 → feature=story c=Context_menus u=metro_firefox_user p=3 status=verified
Hi Asa, can you see Juan's last point in comment #8.
Flags: needinfo?(asa)
QA Contact: jbecerra
It looks like bug 844371 might cover comment #8
(In reply to juan becerra [:juanb] from comment #10)
> It looks like bug 844371 might cover comment #8

Yes, I created a new story for text context menus in text edit fields. This verification is solid.
Flags: needinfo?(asa)
Depends on: 854072
Depends on: 867499
Depends on: 867502
Re-verified using http://hg.mozilla.org/mozilla-central/rev/97aa3da59001
Tested content context menu with mouse and touch
Depends on: 884169
Went through the following "Story" for iteration #8 testing and found a "Defect". Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-17-03-11-12-mozilla-central/

- Copied several paragraphs using the context menu and pasted into Paste Bin without any issues (using both mouse & touch)
- Copied several words and ensured that the context menu appeared correctly (using both mouse & touch)
- Copied several words and ensured selecting "Search Bing for "..." opened a new tab, dismissed the "App Bar" and searched the correct term (both mouse & touch)
- Ensured that the above test cases also worked in "Filled View"

Notes:

- Bug 867502 is still an issue and reproduced several times when going through iteration #8 testing
- Bug 867499 is still an issue and reproduced several times when going through iteration #8 testing
- Bug 854072 is still an issue and reproduced several times when going through iteration #8 testing
- Created Bug 884169
No longer depends on: 884169
Depends on: 883554
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20130707 Firefox/25.0
Build ID: 20130707031138

WFM for iteration-9
Tested on Windows 8.1 preview using latest nightly build from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-07-03-11-38-mozilla-central/
I used same steps given in user story.
I am getting expected result.
User Agent:Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:25.0) Gecko/20130724 Firefox/25.0
Build ID: 20130724030204

WFM.

Tested on Windows 8.1 preview for iteration 10 using latest nightly from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-24-03-02-04-mozilla-central/

I followed user story and got expected result.
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130808030205
Built from http://hg.mozilla.org/mozilla-central/rev/fd4cf30428b0

WFM
Tested on windows 8 using latest nightly for iteration-11.I followed user story and got expected result
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130825030201
Built from http://hg.mozilla.org/mozilla-central/rev/01576441bdc6

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in user story and got expected result.
No longer depends on: 867499
No longer depends on: 854072
OS: Windows 8 Metro → Windows 8.1
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.