Last Comment Bug 841950 - Flip the pref to enable <input type=range> for release builds
: Flip the pref to enable <input type=range> for release builds
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Jonathan Watt [:jwatt]
:
Mentors:
Depends on: 840820 841941 841948 842163 845808 846883 849524 849552 851090 851777 851779 853525 853808 854133 855301 857034 859139 862518 863634
Blocks: 344618
  Show dependency treegraph
 
Reported: 2013-02-15 15:41 PST by Jonathan Watt [:jwatt]
Modified: 2013-05-20 11:45 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jonathan Watt [:jwatt] 2013-02-15 15:41:08 PST

    
Comment 1 Florian Bender 2013-05-04 09:52:45 PDT
Looks like bug 853525 is rather a nice to have than a dependency. All other Bugs are resolved. Can we flip the pref now for Fx 23?
Comment 2 Jonathan Watt [:jwatt] 2013-05-05 05:08:44 PDT
The pref is already on for Fx 23.

With regards to the conversion to Decimal, we need that for actual release in my opinion. The only thing blocking that bug from landing is bug 868814, and if needs be I can work around that to get the Decimal conversion landed for v23. I'd rather hold off on a workaround to see if we can get a "proper" fix though.
Comment 3 Florian Bender 2013-05-05 06:21:05 PDT
Is it plausible to have a proper fix in time for early/mid Auroras (v23) so it can be uplifted easily? If not, another solution could be providing a stopgap fix only for Aurora (that rides the trains) but not for m-c. Or disable the pref once again (but IMO it would be nice to have this feature working in the next ESR).
Comment 4 Jonathan Watt [:jwatt] 2013-05-05 13:59:35 PDT
I have a workaround in hand which can be landed before the v23 uplift if needs be.
Comment 5 Jonathan Watt [:jwatt] 2013-05-06 10:58:39 PDT
(In reply to Jonathan Watt [:jwatt] from comment #4)
> I have a workaround in hand which can be landed before the v23 uplift if
> needs be.

I landed with that workaround since the real fix to the linking of mozglue.dll looks unlikely to make v23.
Comment 6 Jonathan Watt [:jwatt] 2013-05-06 12:14:36 PDT
All done here and good to release. Any further improvements or requests for changes should be marked as blocking bug 853822.

Note You need to log in before you can comment on or make changes to this bug.