Enable on-demand decompression

RESOLVED FIXED in Firefox 26

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
Firefox 24
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox24 disabled, firefox25 disabled, firefox26 fixed)

Details

Attachments

(3 attachments)

Assignee

Description

6 years ago
No description provided.
Assignee

Updated

6 years ago
Depends on: 848770
Assignee

Comment 1

6 years ago
This alone would regress apk size by more than 500KB, but bug 848770 brings this back to a few KB regression (except, probably, for x86, but 848773 should set things straight). We'll have to track startup times and possible problems with weird phones after this lands.
Attachment #722227 - Flags: review?(blassey.bugs)
Assignee

Updated

6 years ago
Depends on: 848773
Assignee

Updated

6 years ago
Depends on: 848385
Attachment #722227 - Flags: review?(blassey.bugs) → review+
Assignee

Updated

6 years ago
Depends on: 857151
Assignee

Updated

6 years ago
Depends on: 857161
Assignee

Updated

6 years ago
Depends on: 859705
Assignee

Updated

6 years ago
Depends on: 860235
Assignee

Comment 3

6 years ago
If this needs to be disabled for some reason, please only change mobile/android/confvars.sh. The configure.in change should stay.
Assignee

Updated

6 years ago
Depends on: 863245
I was looking at the graphs on areweslimyet.com/mobile, and if you zoom in to the data around april 18 there's a spike in memory usage on the inbound build for bfc7718d631a that disappears on the next build when it was disabled. The about:memory dumps show, among other things, an increase of ~34 MB in resident memory usage in the size/shared-libraries/shared-libraries-mozilla/libxul.so memory reporter (which I believe is taken straight from the smaps file). I can provide the full memory dumps and a diff if that's useful in any way.
Assignee

Comment 7

6 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)
> I was looking at the graphs on areweslimyet.com/mobile, and if you zoom in
> to the data around april 18 there's a spike in memory usage on the inbound
> build for bfc7718d631a that disappears on the next build when it was
> disabled. The about:memory dumps show, among other things, an increase of
> ~34 MB in resident memory usage in the
> size/shared-libraries/shared-libraries-mozilla/libxul.so memory reporter
> (which I believe is taken straight from the smaps file). I can provide the
> full memory dumps and a diff if that's useful in any way.

The smaps data would be useful, but i doubt it's pointing to anything real. It probably just points deficiencies in how we could memory usage.
Note that the smaps data isn't actually in this file; the about:memory page reads some of the smaps data and just reports some of it. The attached patch has the dump from the build prior to on-demand decompression landing. The next patch has the dump from the build that includes on-demand decompression turned on.
Assignee

Comment 10

6 years ago
Yeah, so this is exactly what i thought. The fact that we're counting RSS instead of PSS is hurting, because the extra 30+MB of libxul are a writable view of the same things that are mapped elsewhere.
Assignee

Updated

6 years ago
Depends on: 865583
https://hg.mozilla.org/mozilla-central/rev/ef5b7b1039ac
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
As noted in comment 6, this patch does cause a RSS regression:

Regression: Mozilla-Inbound - Tp4 Mobile NoChrome (Main RSS) - Android 2.2 (Native) - 37% increase
---------------------------------------------------------------------------------------------
    Previous: avg 90637775.000 stddev 593265.832 of 12 runs up to revision be1d72a1f228
    New     : avg 124135500.000 stddev 572542.734 of 12 runs since revision ef5b7b1039ac
    Change  : +33497725.000 (37% / z=56.463)
    Graph   : http://mzl.la/16FEZ3w
Flags: needinfo?(mh+mozilla)
(In reply to Nick Alexander :nalexander from comment #14)
> Seems like there's a typo in
> 
> http://mxr.mozilla.org/mozilla-central/source/testing/testsuite-targets.
> mk#460
> 
> The latter should be host/bin.

This is breaking l10n nightly builds:
https://tbpl.mozilla.org/php/getParsedLog.php?id=23220111&tree=Mozilla-Central
Assignee

Comment 16

6 years ago
(In reply to Nick Alexander :nalexander from comment #14)
> Seems like there's a typo in
> 
> http://mxr.mozilla.org/mozilla-central/source/testing/testsuite-targets.
> mk#460
> 
> The latter should be host/bin.

Nope, that's purposeful, as indicated in the comment.
Flags: needinfo?(mh+mozilla)
Assignee

Comment 17

6 years ago
(In reply to Mark Finkle (:mfinkle) from comment #15)
> (In reply to Nick Alexander :nalexander from comment #14)
> > Seems like there's a typo in
> > 
> > http://mxr.mozilla.org/mozilla-central/source/testing/testsuite-targets.
> > mk#460
> > 
> > The latter should be host/bin.
> 
> This is breaking l10n nightly builds:
> https://tbpl.mozilla.org/php/getParsedLog.php?id=23220111&tree=Mozilla-
> Central

I don't believe that particular failure is due to this bug. However https://tbpl.mozilla.org/php/getParsedLog.php?id=23200287&tree=Mozilla-Central#error10 is.
Assignee

Updated

6 years ago
Depends on: 874783
All mobile nightly repacks are broken; I suspect this change.

http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-central-l10n/mozilla-central-android-l10n_1-unknown-bm63-build1-build8.txt.gz

06:26:02     INFO -  /bin/sh: line 1: host/bin/szip: No such file or directory
06:26:02    ERROR -  make[1]: *** [repackage-zip] Error 127
06:26:02     INFO -  make[1]: Leaving directory `/builds/slave/m-cen-and-l10n_1-0000000000000/build/mozilla-central/obj-l10n/mobile/android/locales'
06:26:02     INFO -  make: *** [repackage-zip-ar] Error 2
06:26:02    ERROR - Return code: 2
Assignee

Comment 19

6 years ago
(In reply to Aki Sasaki [:aki] from comment #18)
> All mobile nightly repacks are broken; I suspect this change.
> 
> http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-
> central-l10n/mozilla-central-android-l10n_1-unknown-bm63-build1-build8.txt.gz
> 
> 06:26:02     INFO -  /bin/sh: line 1: host/bin/szip: No such file or
> directory
> 06:26:02    ERROR -  make[1]: *** [repackage-zip] Error 127
> 06:26:02     INFO -  make[1]: Leaving directory
> `/builds/slave/m-cen-and-l10n_1-0000000000000/build/mozilla-central/obj-l10n/
> mobile/android/locales'
> 06:26:02     INFO -  make: *** [repackage-zip-ar] Error 2
> 06:26:02    ERROR - Return code: 2

That's bug 874783
Assignee

Updated

6 years ago
Depends on: 875824
Assignee

Updated

6 years ago
Depends on: 886736
Depends on: 907957
Assignee

Comment 21

6 years ago
Backed out because bug 873569 broke the non MOZ_ENABLE_SZIP case. Filing a separate bug for that issue.
https://hg.mozilla.org/releases/mozilla-beta/rev/59d74640f7bd
Just for bookkeeping the bug referenced in comment 21 is bug 912377
Assignee

Comment 24

6 years ago
Ryan, would you mind backing this out from beta? (per bug 886736 comments 66 to 68)
Flags: needinfo?(ryanvm)
You need to log in before you can comment on or make changes to this bug.