[MP] Story - Fix jank in start screen scrolling

RESOLVED FIXED

Status

defect
P2
normal
RESOLVED FIXED
6 years ago
4 months ago

People

(Reporter: mbrubeck, Assigned: jimm)

Tracking

({perf})

Details

(Whiteboard: [Metro Preview] feature=story c=Awesome_screen u=metro_firefox_user p=10)

Attachments

(1 attachment)

Comment hidden (empty)
Flags: needinfo?(asa)
Priority: -- → P2
QA Contact: jbecerra
Flags: needinfo?(asa)
Hey Matt.  Here's the story Asa has prepared.  Please outline the work items.  If you feel the number of work items will carry over an iteration please let me know and we'll divide it.  Once you have the work items laid out let me know and I'll move everything over to Iteration #4.
Flags: needinfo?(mbrubeck)
(Reporter)

Updated

6 years ago
Depends on: 851130
(Reporter)

Comment 3

6 years ago
I added one work item (bug 851130) for moving the content into a browser element, which is our plan to make the start page faster by taking advantage of async panning and zooming.  I also added a dependency on work bug 851130 (integration with AsyncPanZoomController) since we won't see the full benefit until that work lands.

This story is ready to move into iteration 4.
Depends on: 801154
Flags: needinfo?(mbrubeck)
Thanks Matt.  I'm moving it now.
Blocks: metrov1it4
No longer blocks: metrov1onhold
Duplicate of this bug: 849322
Blocks: metrov1it5
No longer blocks: metrov1it4
Blocks: metrov1it6
No longer blocks: metrov1it5
No longer depends on: 801154
Summary: Story - Smoothly scroll the Firefox Start screen → Story - Smoothly scroll the Firefox Start screen - Part I
Blocks: 865714
See Also: → 865714
(Assignee)

Updated

6 years ago
Blocks: 831920, 849331
Blocks: metrov1it7
No longer blocks: metrov1it6
(Assignee)

Updated

6 years ago
No longer blocks: 849331
Blocks: metrov1it8
No longer blocks: metrov1it7

Updated

6 years ago
No longer blocks: metrov1it8
Assignee: mbrubeck → nobody
No longer blocks: 831920
Whiteboard: feature=story c=Awesome_screen u=metro_firefox_user p=13 → [Metro Preview] feature=story c=Awesome_screen u=metro_firefox_user p=13
Summary: Story - Smoothly scroll the Firefox Start screen - Part I → [MP] Story - Smoothly scroll the Firefox Start screen - Part I
(Assignee)

Updated

6 years ago
Assignee: nobody → jmathies
Blocks: metrov1it12
No longer blocks: metrov1backlog
(Assignee)

Updated

6 years ago
Depends on: 879562
(Assignee)

Updated

6 years ago
Duplicate of this bug: 865714
(Assignee)

Updated

6 years ago
No longer blocks: 865714
(Assignee)

Updated

6 years ago
Summary: [MP] Story - Smoothly scroll the Firefox Start screen - Part I → [MP] Story - Fix jank in start screen scrolling
(Assignee)

Updated

6 years ago
Whiteboard: [Metro Preview] feature=story c=Awesome_screen u=metro_firefox_user p=13 → [Metro Preview] feature=story c=Awesome_screen u=metro_firefox_user p=5
(Assignee)

Updated

6 years ago
Whiteboard: [Metro Preview] feature=story c=Awesome_screen u=metro_firefox_user p=5 → [Metro Preview] feature=story c=Awesome_screen u=metro_firefox_user p=8
(Assignee)

Updated

6 years ago
Depends on: 887975
(Assignee)

Updated

6 years ago
Depends on: 902937
(Assignee)

Updated

6 years ago
Depends on: 898106
(Assignee)

Updated

6 years ago
Depends on: 903333
(Assignee)

Updated

6 years ago
Depends on: 903364
(Assignee)

Updated

6 years ago
Depends on: 903368
(Assignee)

Updated

6 years ago
Whiteboard: [Metro Preview] feature=story c=Awesome_screen u=metro_firefox_user p=8 → [Metro Preview] feature=story c=Awesome_screen u=metro_firefox_user p=10
(Assignee)

Updated

6 years ago
No longer depends on: 903368
(Assignee)

Updated

6 years ago
No longer depends on: 898106
(Assignee)

Updated

6 years ago
No longer depends on: 887975
(Assignee)

Updated

6 years ago
Depends on: 903541
Blocks: metrov1it13
No longer blocks: metrov1it12
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Depends on: 911526
Went through the following "Story" for iteration #13 without any issues. Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-08-31-03-02-24-mozilla-central/

Awesome work! Really like how smooth it is now, having over 20 tabs opened still gives the user a smooth experience.

- Went through the attached story in comment #0 without any issues
- Opened 25 different tabs and ensured that scrolling through them was smooth
- Swiped the Tab Navigation Bar and watched the tabs scroll through without any issues. Swiped it the other direction watching the tabs scroll by themselves without any issues
- Swiped the Navigation App Bar back and forth while it was moving without any issues (Example: Swipe to the right and then in the middle of the scrolling swipe back to the left)
- Ensured that the Navigation App Bar slides into view and then retracts without any issues & jank
- Ensured that the Navigation App Bar scrolling is still smooth after closing several tabs
- Went through the above test cases in filled view without any issues

Issues:

When creating new tabs while having several tabs opened, you'll notice some jank when the new tab slides into the navigation app bar. Created Bug 911526
OS: Windows 8 Metro → Windows 8.1

Updated

4 months ago
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.