Flickering when panning content and the richgrid on the start UI

RESOLVED FIXED in mozilla26

Status

()

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jwilde, Assigned: mbrubeck)

Tracking

Trunk
mozilla26
x86
Windows 8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-team][preview])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
When you pan the start UI, the richgrid will periodically disappear. See attached video.
This is all changing with the async pan zoom controller, we should re-evaluate if this is a bug when that lands and is switched on.
(Reporter)

Comment 2

5 years ago
Created attachment 768541 [details]
video of flickering

Updated

5 years ago
Blocks: 841214

Comment 3

5 years ago
I'm pretty sure this is in layers code. If we can assure ourselves it's not in the front end we should update the product/component so gfx folks see it.

jwilde, can you reproduce this in mc tip with "gfx.direct2d.disabled" set to true?
No longer blocks: 841214

Updated

5 years ago
OS: Mac OS X → Windows 8 Metro
(Reporter)

Comment 4

5 years ago
Updated to mc tip and clobbered/rebuilt:

Without gfx.direct2d.disabled: flicker.
With gfx.direct2d.disabled: no flicker.

Updated

5 years ago
Component: General → Graphics: Layers
Product: Firefox for Metro → Core
Version: unspecified → Trunk

Updated

5 years ago
Duplicate of this bug: 891214

Updated

5 years ago
Duplicate of this bug: 891358
Bas, thoughts?
Flags: needinfo?(bas)

Comment 8

5 years ago
reproducible on this page:

https://developer.mozilla.org/en-US/docs/HTML/HTML_Elements/textarea#HTML_Content

down near the bottom where the page has an embedded iframe with a text area in it.
Summary: Flickering when panning richgrid on the start UI → Flickering when panning content and the richgrid on the start UI
(In reply to Milan Sreckovic [:milan] from comment #7)
> Bas, thoughts?

Hrm, I'm not sure what the behavior of Metro is at the moment with Direct2D disabled, definitely looks like a graphics problem but I have no initial idea on what the cause is. Also no Windows 8 machine with me in SF to try and debug this.
Flags: needinfo?(bas)
Hi Bas, we have Metro team members in SF who could show you on a Win 8 device.
Flags: needinfo?(bas)
(In reply to Marco Mucci [:MarcoM] from comment #10)
> Hi Bas, we have Metro team members in SF who could show you on a Win 8
> device.

I'd be more than happy to look at it, I'm at the 7th floor on Elika's desk. I can probably give some pointers as well but I doubt I can do significant debugging right now.
Flags: needinfo?(bas)
Hi Ally, can you see Comments 9,10,11.
Flags: needinfo?(ally)
Bas, headed your way
Flags: needinfo?(ally)
Had a look at Ally's machine. ContentHostDoubleBuffered::UpdateThebes and ThebesLayerBuffer::BeginPaint is kind of where all the mess of moving the buffer around in memory and making sure front and back buffer are in sync happens. This bug looks to me like sometimes the syncing is not correct (i.e. the content in the middle, which is not being redrawn, is in one of the buffers but not in the other). It's particularly interesting that as you scroll it can re-appear, meaning it either gets redrawn or we're just ending up with 'the other' buffer of the swap chain where the content is still present.
Thanks for looking into it Bas.  Anything you can do to help you would great.
Blocks: 859003
Whiteboard: [gfx-team]
(Assignee)

Updated

5 years ago
Duplicate of this bug: 893258

Updated

5 years ago
Duplicate of this bug: 894218

Comment 18

5 years ago
on latest tip (Wed Jul 24 05:36:15 2013 PDT), I can't reproduce.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 19

5 years ago
Oddly enough, this is now back with apz enabled.
Blocks: 886321
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

5 years ago
No longer blocks: 859003
(Assignee)

Comment 20

5 years ago
I'm also seeing this again with APZC disabled, though for a while it went away.
On machines with Atom processors the tiles disappear when you pan left or right.
I get that sometime with my sony vaio which is intel
Whiteboard: [gfx-team] → [gfx-team][preview]
No longer blocks: 886321
Blocks: 865714
Does it work with the patch from bug 900742?

Updated

5 years ago
Blocks: 850737
No longer blocks: 865714

Comment 24

5 years ago
(In reply to Milan Sreckovic [:milan] from comment #23)
> Does it work with the patch from bug 900742?

Doesn't look like an event related patch like that would help but I can take it for a spin to see.

One interesting thing I noticed about this today, when we scroll via the mouse wheel we don't see a flicker. Mouse wheel translates into scrollBy calls on the start ui panel. Not sure why it would not reproduce in that case, but reproduce when dragging the scrollbar with the mouse to scroll.
(Assignee)

Comment 25

5 years ago
Created attachment 786642 [details] [diff] [review]
work-around: remove "watermark" background image

I discovered today that removing the background image ("Firefox" watermark) from the start page fixes the flickering on my system.  Is this an acceptable band-aid until we can find a fix or workaround that lets us scroll correctly with the image in place?
Assignee: nobody → mbrubeck
Status: REOPENED → ASSIGNED
Attachment #786642 - Flags: ui-review?(ywang)
Attachment #786642 - Flags: review?(ally)
That's acceptable with me. The improved performance is definitely a bigger win here.
Duplicate of this bug: 902254

Comment 28

5 years ago
We should spin this patch off into a metro bug so the gfx bug stays open (or change up this bug and file a new gfx bug.) We still want a bug open on the compositor / layers painting problem. (I've seen this occasionally in content as well.)
Let's spin a new gfx bug for that and CC kats, that issue will probably be one he, or BenWa has to fix. It would be ideal if we could use jing to capture a short video of the problem happening on content. It's just a software that you install, press a button to record your screen, and it gives you a link you can use online.
Jim if you can reproduce that easily you can also try tweaking some of these prefs:
http://mxr.mozilla.org/mozilla-central/source/gfx/layers/ipc/AsyncPanZoomController.cpp#146
Comment on attachment 786642 [details] [diff] [review]
work-around: remove "watermark" background image

Review of attachment 786642 [details] [diff] [review]:
-----------------------------------------------------------------

Does what it says on the box. Though I hope we get a real gfx fix soon. :)
Attachment #786642 - Flags: review?(ally) → review+
(Assignee)

Comment 32

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/4e2e139c6b83

As discussed above, we'll close this bug and open a new bug to track the underlying graphics or layout issue.
https://hg.mozilla.org/mozilla-central/rev/4e2e139c6b83
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
(Assignee)

Updated

5 years ago
Attachment #786642 - Flags: ui-review?(ywang)

Updated

5 years ago
Blocks: 903383

Comment 34

5 years ago
(In reply to Matt Brubeck (:mbrubeck) from comment #32)
> https://hg.mozilla.org/integration/fx-team/rev/4e2e139c6b83
> 
> As discussed above, we'll close this bug and open a new bug to track the
> underlying graphics or layout issue.

Did we file a new bug yet?

Updated

5 years ago
Blocks: 903421

Updated

5 years ago
No longer blocks: 850737, 903383

Comment 35

5 years ago
(In reply to Jim Mathies [:jimm] from comment #34)
> (In reply to Matt Brubeck (:mbrubeck) from comment #32)
> > https://hg.mozilla.org/integration/fx-team/rev/4e2e139c6b83
> > 
> > As discussed above, we'll close this bug and open a new bug to track the
> > underlying graphics or layout issue.
> 
> Did we file a new bug yet?

filed bug 903421.

Updated

5 years ago
Blocks: 917429
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.