Closed Bug 852460 Opened 9 years ago Closed 9 years ago

B2G MMS: provide nsIDOMMobileMessageManager.onreceived event (follow-up fix)

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla22
blocking-b2g -
Tracking Status
firefox20 --- wontfix
firefox21 --- wontfix
firefox22 --- fixed
b2g18 + fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix

People

(Reporter: airpingu, Assigned: ctai)

References

Details

Attachments

(2 files, 3 obsolete files)

+++ This bug was initially created as a clone of Bug #849741 +++

Ctai and I discovered some potential bugs when attempting to have integration with the Gaia end to receive MMS. Let's fire this follow-up fix for bug 849741.
Attached patch Patch (obsolete) — Splinter Review
Attachment #726546 - Flags: review?(vyang)
Attachment #726546 - Flags: review?(ctai)
Assignee: gene.lian → ctai
Attached patch Patch v1.1 (obsolete) — Splinter Review
Attachment #726546 - Attachment is obsolete: true
Attachment #726546 - Flags: review?(vyang)
Attachment #726546 - Flags: review?(ctai)
Attached patch Patch v1.1 (obsolete) — Splinter Review
Attachment #726560 - Attachment is obsolete: true
Attachment #726561 - Flags: review?(gene.lian)
Attached patch Patch v1.2Splinter Review
Attachment #726561 - Attachment is obsolete: true
Attachment #726561 - Flags: review?(gene.lian)
Attachment #726564 - Flags: review?(gene.lian)
Attachment #726564 - Flags: review?(vyang)
Attachment #726564 - Flags: review?(gene.lian) → review+
Attachment #726564 - Flags: review?(vyang) → review+
https://hg.mozilla.org/mozilla-central/rev/2f4cfeefb5c2
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
Given that this is already fixed let's just track instead of blocking and get an uplift approval nomination on this patch.
blocking-b2g: leo? → -
tracking-b2g18: --- → +
Comment on attachment 726564 [details] [diff] [review]
Patch v1.2

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 849741
User impact if declined: without this, the SMIL value of a received MMS cannot be correctly exposed to the content. In detail, it should be exposed as a string way instead of a blob way based on the MMS DOM API spec.
Testing completed: yes
Risk to taking this patch (and alternatives if risky): no
String or UUID changes made by this patch: no

Note: this is just a simple follow-up for bug 849741 to correct some internal logic within the MMS module only, which doesn't touch other modules at all, so I believe this is pretty safe to land.
Attachment #726564 - Flags: approval-mozilla-b2g18?
Comment on attachment 726564 [details] [diff] [review]
Patch v1.2

Review of attachment 726564 [details] [diff] [review]:
-----------------------------------------------------------------

Approving for uplift - self-contained, low risk.
Attachment #726564 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
Whiteboard: [target 3/22] → [NO_UPLIFT]
Added [NO_UPLIFT] per recent commercial RIL compatibility issue. Waiting on further decision to keep the patch in b2g18 or to back it out.

------------------------------
If we really want to back them out, backing the following MMS bugs should be enough to make the commercial RIL compatible:

Bug 854422 - B2G MMS: should call .NotifyResponseTransaction() with MMS_PDU_STATUS_RETRIEVED after an MMS is retrieved under the RETRIEVAL_MODE_AUTOMATIC mode (a follow-up for bug 845643)
Bug 850680 - B2G MMS: broadcast "sms-received" and "sms-sent" system messages
Bug 850530 - B2G MMS: Use the same attribute name for delivery (s/state/delivery) like SMS
Bug 852911 - B2G MMS: fail to expose correct nsIDOMMozMmsMessage.attachments.
Bug 853725 - B2G MMS: fail to read nsIDOMMozMmsMessage.receivers for a received MMS (a follow-up of bug 849741).
Bug 853329 - B2G MMS: other Android phones cannot read attachments sent from FFOS
Bug 852471 - B2G MMS: provide nsIDOMMobileMessageManager interface (with sendMMS() first) (follow-up fix)
Bug 852460 - B2G MMS: provide nsIDOMMobileMessageManager.onreceived event (follow-up fix)
Bug 849741 - B2G MMS: provide nsIDOMMobileMessageManager.onreceived event
Bug 847756 - B2G MMS: provide nsIDOMMobileMessageManager.markMessageRead().
Bug 847736 - B2G MMS: provide nsIDOMMobileMessageManager.delete().
Bug 847738 - B2G MMS: provide nsIDOMMobileMessageManager.getMessage(). 
Bug 844431 - B2G MMS: provide nsIDOMMobileMessageManager interface (with sendMMS() first)
Bug 845643 - B2G MMS: Save retrieved MMS into database.
Following the previous comment, some more needs to back out:

Bug 792321 - Check max values of MMS parameters in sendRequest.
Bug 833291 - B2G SMS & MMS: getMessages it's not working with PhoneNumberJS
Bug 844429 - B2G SMS & MMS: move SMS codes into dom/mobilemessage to make it generic for MMS
Bug 839436 - B2G MMS: make DB be able to save MMS messages.
Confirming with Michael to see we should back out to Bug 839436 or just Bug 844431 (if we eventually decide to back out). Please see Bug 857632, comment #17.
Please see bug 845643 comment #31.
Per off-line discussion with Michael, we decided not to back out the MMS bugs that have already been in mozilla-b2g18. Removing [NO_UPLIFT] to make the check-in status sync'ed.
Whiteboard: [NO_UPLIFT]
You need to log in before you can comment on or make changes to this bug.