Closed Bug 853329 Opened 8 years ago Closed 8 years ago

B2G MMS: other Android phones cannot read attachments sent from FFOS

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla22
Tracking Status
firefox20 --- wontfix
firefox21 --- wontfix
firefox22 --- fixed
b2g18 + fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix

People

(Reporter: airpingu, Assigned: airpingu)

References

Details

Attachments

(2 files, 1 obsolete file)

After some cross-evaluations, eventually, I found out the root cause is we need to fill in the |params.name|, which seems a major field used for Android phones to display the received attachment name (however, iPhone doesn't need it). Not very sure if it is really related to the SMIL, but for every MMS sent from other Android phones, this field always has a value which is the same as the content-location.

This is a critical issue for sure.
Attached patch Patch (obsolete) — Splinter Review
In addition to the fix, I rewrite some debug messages.
Attachment #727542 - Flags: review?(vyang)
OMA-TS-MMS-CONF-V1_3-20110913-A section 10.2.2 "Message Content Encoding":

  A name for multipart object SHALL be encoded using name-parameter for Content-Type
  header in WSP multipart headers. In decoding, name-parameter of Content-Type SHALL
  be used if available. If name-parameter of Content-Type is not available, filename
  parameter of Content-Disposition header SHALL be used if available. If neither
  name-parameter of Content-Type header nor filename parameter of Content-Disposition
  header is available, Content-Location header SHALL be used if available.
Attachment #727542 - Flags: review?(vyang) → review+
r=vicamo and add the comment #2 into codes. Ready to land.
Attachment #727542 - Attachment is obsolete: true
Attachment #727558 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/88bf3f7c0e2b
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
blocking-b2g: leo? → ---
tracking-b2g18: --- → ?
We'll use b2g18-approval to uplift this after nominating for it.
Comment on attachment 727558 [details] [diff] [review]
Patch, V1.1 (checked-in)

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 844431
User impact if declined: without this, some Android phones cannot successfully interpret the MMS SMIL info sent from our FFOS phone. We need to fill in some extra attributes for the MMS header, which are necessary for some Android phones in the field.
Testing completed: yes
Risk to taking this patch (and alternatives if risky): this is just a simple patch to correct some internal logic within the MMS module only, which doesn't touch other modules at all, so I believe this is pretty safe to land.
String or UUID changes made by this patch: no
Attachment #727558 - Flags: approval-mozilla-b2g18?
Attachment #727558 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
Whiteboard: [by 3/22] → [NO_UPLIFT]
Added [NO_UPLIFT] per recent commercial RIL compatibility issue. Waiting on further decision to keep the patch in b2g18 or to back it out.

------------------------------
If we really want to back them out, backing the following MMS bugs should be enough to make the commercial RIL compatible:

Bug 854422 - B2G MMS: should call .NotifyResponseTransaction() with MMS_PDU_STATUS_RETRIEVED after an MMS is retrieved under the RETRIEVAL_MODE_AUTOMATIC mode (a follow-up for bug 845643)
Bug 850680 - B2G MMS: broadcast "sms-received" and "sms-sent" system messages
Bug 850530 - B2G MMS: Use the same attribute name for delivery (s/state/delivery) like SMS
Bug 852911 - B2G MMS: fail to expose correct nsIDOMMozMmsMessage.attachments.
Bug 853725 - B2G MMS: fail to read nsIDOMMozMmsMessage.receivers for a received MMS (a follow-up of bug 849741).
Bug 853329 - B2G MMS: other Android phones cannot read attachments sent from FFOS
Bug 852471 - B2G MMS: provide nsIDOMMobileMessageManager interface (with sendMMS() first) (follow-up fix)
Bug 852460 - B2G MMS: provide nsIDOMMobileMessageManager.onreceived event (follow-up fix)
Bug 849741 - B2G MMS: provide nsIDOMMobileMessageManager.onreceived event
Bug 847756 - B2G MMS: provide nsIDOMMobileMessageManager.markMessageRead().
Bug 847736 - B2G MMS: provide nsIDOMMobileMessageManager.delete().
Bug 847738 - B2G MMS: provide nsIDOMMobileMessageManager.getMessage(). 
Bug 844431 - B2G MMS: provide nsIDOMMobileMessageManager interface (with sendMMS() first)
Bug 845643 - B2G MMS: Save retrieved MMS into database.
Following the previous comment, some more needs to back out:

Bug 792321 - Check max values of MMS parameters in sendRequest.
Bug 833291 - B2G SMS & MMS: getMessages it's not working with PhoneNumberJS
Bug 844429 - B2G SMS & MMS: move SMS codes into dom/mobilemessage to make it generic for MMS
Bug 839436 - B2G MMS: make DB be able to save MMS messages.
Confirming with Michael to see we should back out to Bug 839436 or just Bug 844431 (if we eventually decide to back out). Please see Bug 857632, comment #17.
Per off-line discussion with Michael, we decided not to back out the MMS bugs that have already been in mozilla-b2g18. Removing [NO_UPLIFT] to make the check-in status sync'ed.
Whiteboard: [NO_UPLIFT]
You need to log in before you can comment on or make changes to this bug.