Closed Bug 867748 Opened 7 years ago Closed 7 years ago

OAuth2 Error recovery flow from account settings

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

defect
Not set
normal

Tracking

(blocking-b2g:tef+, b2g18 verified, b2g18-v1.0.1 verified)

RESOLVED FIXED
1.0.1 IOT1 (10may)
blocking-b2g tef+
Tracking Status
b2g18 --- verified
b2g18-v1.0.1 --- verified

People

(Reporter: jlal, Assigned: jlal)

References

Details

(Keywords: late-l10n, Whiteboard: [status: needs review])

Attachments

(1 file)

No description provided.
We need to parse WWW-Authenticate response header in the status 401 case to determine the cause and if it looks like expiry we notify the main thread (propagate up through CalDAV lib) to show the OAuth2 flow again to force a re-authentication. The UX here is still being decided upon.
Blocks: gaia-caldav2
Keywords: late-l10n
Depends on: 869227
Depends on: 869230
blocking-b2g: --- → tef?
Summary: Handle refresh_token expiry in oauth2 cases and allow the user to reauthenticate → OAuth2 Error recovery flow from account settings
Blocks: 870664
Depends on: 868197
Comment on attachment 747774 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9652

OK- here is the new error handling logic... In addition to your usual through reviews It would be majorly helpful to go through and retry _everything_ related to setting up and editing accounts...

To test a normal CalDAV case changing your password is required.

For the Google OAuth2 case you must follow these steps:

Click your username somewhere
Click account
Click security (on the left )
Directly under "Connected applications and sites" and on the right click "manage access" revoke "testing oauth"
Attachment #747774 - Flags: review?(kgrandon)
Attachment #747774 - Flags: review?(gaye)
blocking-b2g: tef? → tef+
Target Milestone: --- → 1.0.1 IOT1 (10may)
Whiteboard: [NO_UPLIFT]
For reference, I think the URL of the page to invalidate tokens is: https://accounts.google.com/b/0/IssuedAuthSubTokens
Whiteboard: [NO_UPLIFT]
Assignee: nobody → jlal
Whiteboard: [status: needs review]
Attachment #747774 - Flags: review?(gaye) → review+
Attachment #747774 - Flags: review?(kgrandon) → review+
Duplicate of this bug: 864329
in master https://github.com/mozilla-b2g/gaia/commit/3750ff08a12bbef1e76dc9dab30b729113329d37
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Keywords: verifyme
QA Contact: jsmith
Whiteboard: [status: needs review] → [status: needs review][NO_UPLIFT]
Whiteboard: [status: needs review][NO_UPLIFT] → [status: needs review]
Depends on: 836780
Depends on: 836784
in v1-train: b2bef0fe6130d12b0961e8f81147f21a1d093800
Marking verified to indicate that there has been an informal test pass done on this feature. Note that there's more testing to be done here in a more formal analysis, but I'm marking verified to indicate that this has been looked at.
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.