If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FEATURE] Better status/progress feedback

VERIFIED FIXED

Status

SeaMonkey
UI Design
P2
normal
VERIFIED FIXED
19 years ago
9 years ago

People

(Reporter: don, Assigned: Bill Law)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-][nsbeta3+])

(Reporter)

Updated

19 years ago
Priority: P3 → P1
Target Milestone: M8
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Target Milestone: M8 → M9
(Assignee)

Description

19 years ago
Must defer till M9; this really needs to await Necko since it will be
imposing substantive changes in this area.

Updated

18 years ago
Blocks: 10575
(Reporter)

Updated

18 years ago
Target Milestone: M9 → M10
(Reporter)

Comment 1

18 years ago
Move this to M10.

Updated

18 years ago
Blocks: 11349
(Reporter)

Updated

18 years ago
Target Milestone: M10 → M11
(Reporter)

Updated

18 years ago
Depends on: 11708

Updated

18 years ago
No longer blocks: 11349

Updated

18 years ago
Blocks: 15164

Updated

18 years ago
QA Contact: beppe → claudius

Comment 2

18 years ago
is there any status/progress on this?

Updated

18 years ago
Blocks: 16654
(Assignee)

Comment 3

18 years ago
Gagan has got notifications flowing so the status bar is back to where it was
pre-Necko.  Still need to enhance the progress meter.  May be getting a
volunteer from outside.

Updated

18 years ago
Blocks: 16950

Updated

18 years ago
Blocks: 17432

Updated

18 years ago
Whiteboard: [PDT+][DOGFOOD]

Updated

18 years ago
Summary: [FEATURE] Better status/progress feedback → [FEATURE][DOGFOOD] Better status/progress feedback
Whiteboard: [PDT+][DOGFOOD] → [PDT+]

Comment 4

18 years ago
Putting on PDT+/Dogfood radar.
(Reporter)

Updated

18 years ago
Target Milestone: M11 → M12

Updated

18 years ago
Blocks: 17907

Updated

18 years ago
Blocks: 18471
(Reporter)

Updated

18 years ago
Whiteboard: [PDT+] → [PDT+] 12/3??? completion
(Reporter)

Updated

18 years ago
Whiteboard: [PDT+] 12/3??? completion → [PDT+] 12/3 completion
(Reporter)

Comment 5

18 years ago
Bill says he may be able to bring this in to 11/26.

Updated

18 years ago
Blocks: 18951

Updated

18 years ago
Whiteboard: [PDT+] 12/3 completion → [PDT-] 12/3 completion

Comment 6

18 years ago
Changing to PDT- per discussion of PDT long poles.  The most we could rate as
dogfood is an indication that some progress is taking place.  It is not
necessary to see better percentage values etc. for dogfood.
(Reporter)

Updated

18 years ago
Target Milestone: M12 → M13
(Reporter)

Comment 7

18 years ago
OK, moving out to M13.

Updated

18 years ago
Blocks: 20203

Updated

18 years ago
Blocks: 22176
(Reporter)

Updated

18 years ago
No longer blocks: 10575
(Reporter)

Updated

18 years ago
Priority: P1 → P2
Summary: [FEATURE][DOGFOOD] Better status/progress feedback → [FEATURE] Better status/progress feedback
Whiteboard: [PDT-] 12/3 completion
Target Milestone: M13 → M14
(Reporter)

Comment 8

18 years ago
Move to M14.
(Reporter)

Updated

18 years ago
Target Milestone: M14 → M13
(Reporter)

Comment 9

18 years ago
Ooops.  Should be M13.
(Reporter)

Comment 10

18 years ago
*** Bug 22973 has been marked as a duplicate of this bug. ***
spam: added self to cc list.

Comment 12

18 years ago
Sorry to be clueless, but does this bug deal with progress bar and status in
save as dialogues or the page loading status bar at the bottom of browser
window, or both.
(Assignee)

Comment 13

18 years ago
This bug refers to the progress meter at the bottom of the browser window.  It
is supposed to switch to thermometer mode when loading big/slow pages (and the
status bar should say something like "3% of 47K at 3.2K/sec").

Comment 14

18 years ago
Good, then I'm in the right place. I was trying to verify bug 16386, which deals
with a trivial spelling error in 'transferring data' that used to appear there,
but I don't see that anymore. Is that related to this?
(Reporter)

Updated

18 years ago
Depends on: 13374
(Reporter)

Comment 15

18 years ago
Added dependency on bug #13374, Travis' webshell work.
(Assignee)

Updated

18 years ago
Target Milestone: M13 → M14
(Assignee)

Comment 16

18 years ago
Moving out to M14 as the requisite changes to the webshell and uri loader won't
happen till post-M13.

Updated

18 years ago
Blocks: 24206
(Reporter)

Comment 17

18 years ago
*** Bug 20972 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 18

18 years ago
Adding this from bug #20972:

1. The progress bar message does not change at all when a new page is loaded.
During loading, it shows the "Document: Done (xx seconds)" message of the
previous page loaded; instead it should display "Contacting server", "Waiting
for reply", etc.

2. If a page load is interrupted, the progress message shows "Document: DOne (xx
seconds)" where xx seconds is the time between clicking on a link and clicking
on the stop button.  This is slightly confusing, since whatever is shown in
theprogress bar should apply to the page currently viewed.

Comment 19

18 years ago
Just FYI, bug #18724 handles mostly this same thing. Should this depend on
it?
(Reporter)

Comment 20

18 years ago
Move to M16 ...
Target Milestone: M14 → M16

Updated

18 years ago
Keywords: nsbeta2
Target Milestone: M16 → M17

Comment 21

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.
Whiteboard: [nsbeta2-]
(Reporter)

Comment 22

18 years ago
Move to M20 target milestone.
Target Milestone: M17 → M20

Updated

18 years ago
Blocks: 34175

Updated

18 years ago
No longer blocks: 17432

Updated

18 years ago
No longer blocks: 17907

Updated

18 years ago
No longer blocks: 18471

Updated

18 years ago
No longer blocks: 18951

Updated

18 years ago
No longer blocks: 20203

Updated

18 years ago
No longer blocks: 22176

Updated

18 years ago
No longer blocks: 24206
Component: XP Apps → XP Apps: GUI Features
QA Contact: claudius → sairuh
whoops, almost thought this had to do with the downloading status dialog.
chatted with claudius, who clarified things (yay) --back to him. :-)
QA Contact: sairuh → claudius

Comment 24

17 years ago
Nav triage team: [nsbeta3+]; look at Don's 2/01 comment
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3+]
Adding nsbeta3 keyword to bugs which already have nsbeta3 status markings so 
the queries don't get all screwed up.
Keywords: nsbeta3
(Assignee)

Comment 26

17 years ago
I'm going to resolve this FIXED.  Progress/status messages are pretty good 
nowadays.  One sees (typically):

Resolving host <host>
Connected to <host>
Reading <url>
Document: Done

Plus, a percentage read, when applicable.

There might still be some flakiness, but those should be addressed via separate 
bugs (which might already exist, for all I know); those bugs aren't likely to be 
nsbeta3'ers.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 27

17 years ago
marking VERIFIED Fixed with 2000082108 builds (note there exist other, documented bugs)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.