[Mac] Biff alert cannot be turned off

RESOLVED DUPLICATE of bug 876497

Status

--
major
RESOLVED DUPLICATE of bug 876497
5 years ago
5 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

({dogfood, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Under "When new messages arrive:", the "Show an alert" checkbox is hidden on Mac.  Now that bug 728385 is fixed, the checkbox should be made visible on Mac.

It's #ifndef mac here:
http://hg.mozilla.org/comm-central/annotate/default/mail/components/preferences/general.xul#l61

I used about:config to set mail.biff.show_alert to false and it worked.  So I think it just needs to be moved out of the ifndef block. (It might be sensible for it to be visible based on whether Growl / Notification Center are installed.)
(Reporter)

Comment 1

5 years ago
(I noticed this soon after updating from Thunderbird 17 to Thunderbird Beta 22).

Comment 2

5 years ago
I don't know if this would equally apply to Thunderbird, but SeaMonkey is using the following to hide the alert-related elements in their pref-notifications.js:

> xxx.hidden = !("@mozilla.org/alerts-service;1" in Components.classes);

That was introduced with bug 158711 and is still in the current trunk code.
A patch is already awaiting review in bug 876497.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 876497
You need to log in before you can comment on or make changes to this bug.