Closed Bug 896003 Opened 8 years ago Closed 8 years ago

[theme] Support for Synthetic APKs (Fennec / Android)

Categories

(Tracking :: User Story, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 874686

People

(Reporter: cgalimidi, Unassigned)

References

Details

User Story

APK FACTORY
- A Cloud service to make APKs from Open Web Apps
1. Verify input is valid
2. Generate APK signing key for each developer*
3. Sign the APK

- Cache the APK for use at install time
- Create new APK signing keys for most developers
- Store and use legacy APK signing keys for Android-savvy developers

DOWNLOAD / INSTALL
- native flow, with standard install confirmation dialog
- dialog lists permissions requested by privileged apps
- user must enable “unknown sources”; Marketplace/Firefox can help explain/direct
- reinstall from same Marketplace will update existing app, but reinstall from different Marketplace may duplicate app
- TBD how to handle reinstall of app installed as bookmark

USE & MANAGE
- launch via native Home, All Apps, and Recents screens
- quit, switch, and manage apps via native interfaces
- app appears like native app in all Android interfaces
- runtime prompts to access privileged APIs, à la FxOS
- TBD crash reporting and permissions management

UPDATE & REMOVE
- runtime will periodically check for and download updates
- should be similar to native update
- native remove flow
- if user removes Firefox, app prompts user to reinstall it
- TBD persist app data after Firefox removal
No description provided.
Depends on: 888391
No longer depends on: 857730, 862157, 862835, 862861, 879366, 862853
Depends on: 896005
Depends on: 896007
Depends on: 835405
Depends on: 911285
Depends on: 930389
User Story: (updated)
User Story: (updated)
Depends on: 936667
Depends on: 936669
Depends on: 936725
No longer depends on: 835405
No longer depends on: 896005
No longer depends on: 911285
No longer depends on: 936669
Depends on: 941926
No longer depends on: 896007
Depends on: 941934
No longer depends on: 936667
No longer depends on: 930389
No longer depends on: 936725
Depends on: 929382
Depends on: 945007
Depends on: 958329
Depends on: 930389
No longer depends on: 888391
No longer depends on: 929382
No longer depends on: 930389
No longer depends on: 941926
No longer depends on: 945007
No longer depends on: 958329
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 874686
You need to log in before you can comment on or make changes to this bug.