UA Override for m.youtube.com still exists on leo partner build from 7/21/2013

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: Youngjun Kim)

Tracking

(Depends on: 1 bug)

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [POVB])

(Reporter)

Description

5 years ago
Testing the YouTube app on device shows that the YouTube UA override is still present on the build. This shouldn't be present on the 7/21/2013 build.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
Whiteboard: [POVB]
(Reporter)

Comment 1

5 years ago
Build ID: 20130721095109
(Reporter)

Comment 2

5 years ago
Note - bug 887454 fixed this and was landed on July 10th 2013.
Flags: needinfo?(leo.bugzilla.gaia)

Updated

5 years ago
Depends on: 896952

Updated

5 years ago
Depends on: 896953

Updated

5 years ago
Depends on: 896956

Updated

5 years ago
Depends on: 896960

Updated

5 years ago
Depends on: 896970

Updated

5 years ago
Depends on: 894249
Hi Youngjun,

As discussed over email, this is essential for the device to launch with youtube preloaded. We can discuss the separate bugs you've found in the respective bug trackers.
I am assigning this to you so you can have this reviewed before your next build.
Assignee: nobody → jjoons79
(Assignee)

Comment 4

5 years ago
Leo'll apply the patch of bug 887454 before next build. Then I'll share the result.
(Assignee)

Updated

5 years ago
Flags: needinfo?(leo.bugzilla.gaia)
Triage - leo+, we can close this bug once this has been verified on the new build.
blocking-b2g: leo? → leo+

Comment 6

5 years ago
Leo applied the patch of bug 887454 on 7/30.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 7

5 years ago
After applying the patch of bug 887454, we can't play the Youtube contents. So we reverted it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 8

5 years ago
(In reply to Leo from comment #7)
> After applying the patch of bug 887454, we can't play the Youtube contents.
> So we reverted it.

Umm...what? We haven't seen like that in daily smoke tests. Please provide accurate STR for what you are seeing.

Comment 9

5 years ago
When we tested, youtube was serving us video with rtsp links, not with embedded media elements. So this was causing issue.
If youtube is sending you rtsp links, this means the UA that the device is sending to youtube is the Android UA, meaning the UA override is still in place for that build.

If the UA override is not in place and the device is correctly sending the normal Firefox OS UA with the 18.1 version (for 1.1), then youtube will send embedded media elements. This is the way it has been on the b2g18 branch for a while now, and this is the way YT certified the app.
(Reporter)

Comment 11

5 years ago
(In reply to Donovan Preston from comment #10)
> If youtube is sending you rtsp links, this means the UA that the device is
> sending to youtube is the Android UA, meaning the UA override is still in
> place for that build.

Actually that isn't entirely correct. The Android UA would get you a mobile youtube site with Android intents served for each YouTube video available. What probably happened here instead is that leo removed the UA override and saw the outdated RTSP youtube site. Which leads me to believe that they might have uncovered a regression on YouTube's side that happened temporarily.

Followup items:

1. Leo - Can you confirm my analysis above? If so, I'll followup with Vishy and Donovan to ping YouTube about this.

2. Leo - Can you retest this? This works on our Mozilla builds.
A screenshot would be helpful.

I just tested a 1.1 Unagi nightly build, 20130730230204, and I got served the expected youtube site with the embedded media elements.
(Reporter)

Comment 13

5 years ago
Leo - What country was the testing done in comment 7?
Flags: needinfo?(leo.bugzilla.gaia)
Could this be due to Leo is testing with a customized UA string as browser default? 


Leo,
Please test with a default firefox UA string and see if you get different results?

Comment 15

5 years ago
It'a UA String problem. If we test with a default UA string, it works well. So We are change it to apply it. Thank you for your help.
Flags: needinfo?(leo.bugzilla.gaia)

Updated

5 years ago
Depends on: 900359

Updated

5 years ago
Depends on: 900501
can you check to see if you have patch from bug 871485 in your build please?

Comment 17

5 years ago
You tube will be updating their content servers to account for the custom UA string. ETA for this is Thursday Pacific time

Comment 18

5 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #16)
> can you check to see if you have patch from bug 871485 in your build please?

Yes, It's applied.

Updated

5 years ago
Depends on: 903279
(Reporter)

Comment 19

5 years ago
Resolved a while back, no need to keep this open anymore.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.