Remove UA override for m.youtube.com upon passing YouTube certification testing

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: fzzzy)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

Details

(Whiteboard: [leoVB-])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Under the current plan, we should remove the UA override for m.youtube.com when we pass certification testing for 1.1 for YouTube (we're assuming right now this will go to plan, btw). This is because when we pass certification, YouTube will plan to turn on their mobile site support for a Firefox OS user agent with media content served as h264. 

This bug tracks the work to remove the UA override from m.youtube.com when we have the go ahead from YouTube. If in the worst case that we fail certification, we'll need to instead pull the app from the build customization.
(Reporter)

Updated

5 years ago
Blocks: 877024
blocking-b2g: --- → leo?
blocking-b2g: leo? → leo+
Do we have a date for certification that would allow us to put a milestone on this bug to expect resolution by?
Flags: needinfo?
(Assignee)

Comment 2

5 years ago
I'll have more info about the timelines after our meeting at noon pacific today.
Flags: needinfo?
(Assignee)

Comment 3

5 years ago
It sounds like the earliest YT can turn this on is Wednesday July 10th. This date would be before we pass certification, with the understanding that the only 1.1 devices currently available are testing builds. This will allow for easier testing by the oem and others while YT completes the certification (currently targeting July 19)

So far things are looking good for us to pass cert.
(Assignee)

Comment 4

5 years ago
Created attachment 773309 [details]
Remove UA override
Assignee: nobody → dpreston
Attachment #773309 - Flags: review?
(Assignee)

Updated

5 years ago
Attachment #773309 - Flags: review? → review?(bfrancis)
Comment on attachment 773309 [details]
Remove UA override

r+me
Attachment #773309 - Flags: review?(bfrancis) → review+
Merged into master in https://github.com/mozilla-b2g/gaia/commit/792b0e2b8d44df88eeb42d77d407a7937b19efd8

Requires uplift
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
status-b2g-v1.1hd: --- → affected
(Assignee)

Updated

5 years ago
Duplicate of this bug: 827636
(Assignee)

Comment 8

5 years ago
Would it be possible to uplift this before tonight's nightly? We need to give it to YT tomorrow to test, on a tight schedule from the OEM. Thanks.
Flags: needinfo?(ryanvm)
302 jhford
Flags: needinfo?(ryanvm)
Flags: needinfo?(jhford)
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 792b0e2b8d44df88eeb42d77d407a7937b19efd8
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(dpreston)
[v1-train 680c72c]
status-b2g18: affected → fixed
Flags: needinfo?(jhford)
No longer blocks: 890004
(Assignee)

Updated

5 years ago
status-b2g18: fixed → affected
Flags: needinfo?(dpreston)
(Assignee)

Updated

5 years ago
status-b2g18: affected → fixed

Updated

5 years ago
Depends on: 896952

Updated

5 years ago
Depends on: 896953

Updated

5 years ago
Depends on: 896956

Updated

5 years ago
Depends on: 896960

Updated

5 years ago
Depends on: 896970
v1.1.0hd: 680c72ccbd2d5045e590a6ba08de2aac6af71953
status-b2g-v1.1hd: affected → fixed
Fix verified on Leo 1.1 mozilla RIL.  Attempting to play a YouTube video launches the video on the YouTube page instead of using the Video app UI.

Build ID: 20130725070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/142cb317a178
Gaia: b1945e7eca58c9176d91998390871864f5e8eb3e
Platform Version: 18.1
status-b2g18: fixed → verified

Updated

5 years ago
Whiteboard: [leoVB+]

Updated

5 years ago
Whiteboard: [leoVB+] → [leoVB-]

Updated

5 years ago
Depends on: 900501
Depends on: 903279
You need to log in before you can comment on or make changes to this bug.