[User Story] Call Hold and Call Waiting improvements

RESOLVED DUPLICATE of bug 977588

Status

Firefox OS
Gaia::Dialer
P1
normal
RESOLVED DUPLICATE of bug 977588
5 years ago
3 years ago

People

(Reporter: WDM, Assigned: rexboy)

Tracking

(Depends on: 1 bug, {feature})

unspecified
x86
Mac OS X
feature
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: [u=commsapps-user c=dialer p=0] [status: waiting for conf-call to be completed and then verify])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
User Story:

As a user I want a way not to accidentally put a call on hold. I also want to be able to switch between the callers easily.

Acceptance Criteria:

* I am asked if I want to put the current call on hold or reject the new incoming call
* I am able to click on a icon/button/text to specifically put call on hold
* I am able to see if a call is currently on hold
* i am able to swap between both calls easily
* i am able to put a call on hold make a second call and hang up on the second call and return to the first call.
(Reporter)

Updated

5 years ago
(Reporter)

Comment 1

5 years ago
this will form work already performed by UX and Eng on Conference call work for v1.2
blocking-b2g: koi? → koi+
Created attachment 786813 [details]
Dialer UX Spec 0.5.pdf

Attaching Dialer spec v0.5 to address this bug.
Whiteboard: [u=commsapps-user c=dialer p=0]
batch update: waiting for conference call feature to be completed, then QA to verify these
Whiteboard: [u=commsapps-user c=dialer p=0] → [u=commsapps-user c=dialer p=0] [status: waiting for conf-call to be completed and then verify]
Assignee: nobody → rexboy
Created attachment 796001 [details]
Visual. Call on hold and a second call active
Created attachment 796019 [details]
Visual. 2nd incoming call
to backlog 891754
Blocks: 891754
No longer blocks: 887455
blocking-b2g: koi+ → koi?
This is a feature. If we really want this, let's prioritize each dependencies for 1.3.
blocking-b2g: koi? → ---
Flags: needinfo?(wmathanaraj)
(Reporter)

Comment 8

4 years ago
Victoria - can you give me a run down on what the changes are we want to do here? I thought this was done as part of the cnf call activity - or did I miss something here?
Flags: needinfo?(wmathanaraj) → needinfo?(vpg)
Hi Wilfred,
What I have posted is the visual material to work with when implementing this feature. If implementation as I saw it needs a lot of polish, let me post the errors I saw and the exact spacing and font size for all.

Thanks.


(In reply to Wilfred Mathanaraj [:WDM] from comment #8)
> Victoria - can you give me a run down on what the changes are we want to do
> here? I thought this was done as part of the cnf call activity - or did I
> miss something here?
Flags: needinfo?(vpg)

Comment 10

4 years ago
Fyi, two bugs have been open regarding how the screen is presented when dealing with several calls. Bug 920422 and bug 920423.

Also, as Victoria mentioned in previous comment, a polish follow up bug will be open to track the differences observed between the visuals and the current screens shown for call waiting and call hold. The functionality is as described, but there are several visuals issues.
Depends on: 920526
(Reporter)

Updated

4 years ago
Blocks: 920625
(Reporter)

Updated

4 years ago
No longer blocks: 920625
blocking-b2g: --- → backlog
Hi,

* Specific option to place a call on hold in the active call screen will be covered within Bug 977588 (also the possibility of easily switching between the callers)
* Availability for ending a held call will be covered within Bug 859628
* All the polish work will be performed as part of 2.0 Visual Refresh stuff (meta Bug 950760)

so marking this bug as RESOLVED DUPLICATE of Bug 977588
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 977588
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.