Closed Bug 950760 (dialer-visual-refres) Opened 6 years ago Closed 5 years ago

(Dialer VDR) [meta] Dialer Visual Refresh

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86
macOS
defect
Not set

Tracking

(tracking-b2g:backlog)

RESOLVED FIXED
tracking-b2g backlog

People

(Reporter: padamczyk, Unassigned)

References

Details

(Whiteboard: ux-tracking, visual design, visual-tracking, bokken, [ucid:, 2.0, ft:comms] )

Attachments

(34 files, 58 obsolete files)

3.96 MB, application/pdf
Details
15.77 KB, image/png
Details
20.99 KB, image/png
Details
17.54 KB, image/png
Details
17.74 KB, image/png
Details
164.84 KB, image/png
Details
157.44 KB, image/png
Details
156.96 KB, image/png
Details
152.43 KB, image/png
Details
156.89 KB, image/png
Details
97.50 KB, image/png
Details
129.47 KB, image/png
Details
129.13 KB, image/png
Details
149.07 KB, image/png
Details
185.68 KB, image/png
Details
36.51 KB, image/png
Details
23.05 KB, image/png
Details
157.89 KB, image/png
Details
289.65 KB, image/png
Details
335.52 KB, image/png
Details
280.62 KB, image/png
Details
116.57 KB, image/png
Details
283.93 KB, image/png
Details
220.20 KB, image/png
Details
266.33 KB, image/png
Details
218.97 KB, image/png
Details
137.31 KB, image/png
Details
181.13 KB, image/png
Details
148.83 KB, image/png
Details
162.29 KB, image/png
Details
228.26 KB, image/png
Details
298.39 KB, image/png
Details
241.78 KB, image/png
Details
175.57 KB, application/zip
Details
Visual design refresh bug for dialer.
Alias: Dialer-1.4-VSD
No longer depends on: 950212
No longer blocks: contacts-visual-refr
Depends on: 950843
No longer depends on: 950843
Blocks: 965889
No longer blocks: 965889
Attachment #8369916 - Attachment description: Dialer_0004_DIALER_Hitstate.png → VDR Mockup: Dialer hit state
Attached image VDR Mockup: CALL outgoing (obsolete) —
Attached image VDR Mockup: CALL dialpad (obsolete) —
Attached image VDR Mockup: CALL on hold (obsolete) —
Attached file Visual refresh Spec for dialer (obsolete) —
PDF document indicating the changes happening between current design and the light version of the refresh proposed. Includes Dialer, call screens and Call log.
Attached image VDR Mockup: CALL LOG edit mode - fixed (obsolete) —
Attachment #8370021 - Attachment is obsolete: true
Attached file Visual refresh Spec for dialer (obsolete) —
Attachment #8370017 - Attachment is obsolete: true
Attached file Visual refresh Spec for dialer (obsolete) —
Attachment #8370031 - Attachment is obsolete: true
Attached image VDR Mockup: CALL LOG edit mode - fixed (obsolete) —
Attachment #8370030 - Attachment is obsolete: true
Alias: Dialer-1.4-VSD → Dialer-1.5-VSD
Summary: [meta] 1.4 Dialer Visual Refresh → [meta] 1.5 Dialer Visual Refresh
Depends on: 974320
Depends on: 972833
Depends on: 976506
Depends on: 976509
Depends on: 899926
Depends on: 974348
Depends on: 977036
Depends on: 977040
Depends on: 977044
Depends on: 977054
Depends on: 977056
Depends on: 977062
Depends on: 977064
No longer depends on: 972833
Depends on: 976512
Blocks: comms_2.0
Whiteboard: ux-tracking, visual design, visual-tracking, bokken → ux-tracking, visual design, visual-tracking, bokken, [ucid:, 1.5, ft:comms]
Depends on: 985909
Depends on: 985944
Depends on: 985995
Depends on: 959011
Attached image VDR Mockup: CALL LOG idle mode (obsolete) —
Attachment #8370019 - Attachment is obsolete: true
Attached image VDR Mockup: CALL LOG edit mode (obsolete) —
Attachment #8370723 - Attachment is obsolete: true
Attached file Visual refresh Spec for dialer (obsolete) —
Attachment #8370141 - Attachment is obsolete: true
I have just updated all the documentation to reflect the color change in the Comms Headers. This green color happens only for the Comms Apps and it is part of a larger intention of theming the different apps of the system grouping them by type (Media, Productivity, Comms and Settings).

This change will happen at a Building Block level, so it does not mean any extra effort from the Comms team. (https://bugzilla.mozilla.org/show_bug.cgi?id=985995)

Thanks.
Depends on: 987061
Depends on: 987075
No longer depends on: 987061
No longer depends on: 987075
Attached file Assets. SVG. Dialer (obsolete) —
Assets in svg format
Alias: Dialer-1.5-VSD → Dialer
Summary: [meta] 1.5 Dialer Visual Refresh → [meta] Dialer Visual Refresh
Target Milestone: --- → 1.5 S2 (23may)
Alias: Dialer
Hi Anthony, what do you think about creating dependencies between this bug and the accessibility related ones such as bug 923139 or bug 969553 as you mentioned me via email? :) Just to keep track of them ;-) Didn't want to do it myself since I am not sure about the degree of this dependency/blocking :p Thanks!
Flags: needinfo?(anthony)
Since it is blocking or at least needed for bug 951604
Depends on: 987075
Attached file Visual refresh Spec for Dialer (obsolete) —
This document includes the new screens that reflects the feature incorporation for "decline call with predefined message"
Attachment #8394813 - Attachment is obsolete: true
Depends on: 990536
(In reply to gtorodelvalle from comment #29)
> Hi Anthony, what do you think about creating dependencies between this bug
> and the accessibility related ones such as bug 923139 or bug 969553 as you
> mentioned me via email? :) Just to keep track of them ;-) Didn't want to do
> it myself since I am not sure about the degree of this dependency/blocking
> :p Thanks!
The "blocking" part is just on myself. The bugs are not really blocking each other. Since I'm doing most reviews this day, I'll just pay attention, no need to increase bugmail.
Flags: needinfo?(anthony)
Summary: [meta] Dialer Visual Refresh → (Dialer VDR) [meta] Dialer Visual Refresh
Attached file Assets. SVG. Dialer (obsolete) —
I have added the sprites for Dialer icons.
Attachment #8396295 - Attachment is obsolete: true
Attached file Assets. SVG. Dialer (obsolete) —
Attachment #8401195 - Attachment is obsolete: true
Attached file Assets. SVG. Dialer (obsolete) —
Attachment #8401211 - Attachment is obsolete: true
Added a 2 style notes that were missing in the previoous version.
Attachment #8397953 - Attachment is obsolete: true
Ty for the upload, Victoria.

(In reply to Victoria Gerchinhoren [:vicky] from comment #36)
> Created attachment 8403318 [details]
> Visual refresh Spec for Dialer (2)
> 
> Added a 2 style notes that were missing in the previoous version.
Depends on: 993951
Alias: dialer-visual-refres
blocking-b2g: --- → backlog
Whiteboard: ux-tracking, visual design, visual-tracking, bokken, [ucid:, 1.5, ft:comms] → ux-tracking, visual design, visual-tracking, bokken, [ucid:, 2.0, ft:comms]
Depends on: 992915
Attached file Assets. PNG. Dialer (obsolete) —
These new assets using PNG format replace the old SVG ones.
Attachment #8402582 - Attachment is obsolete: true
Attached file Assets. PNG. Dialer (obsolete) —
Attachment #8410079 - Attachment is obsolete: true
Attached image Visual Spec: Expandable Areas. Dialer (obsolete) —
Specs showing fluid and fixed areas of the visual design.
Attached file Assets. PNG. Dialer (obsolete) —
Attachment #8410122 - Attachment is obsolete: true
Depends on: 920011
Thanks for those mockups.

Pau: On attachment 8410133 [details], for the bottom part, it has a 13% flexible height but also a 6rem (4+1+1) fixed height. I suppose we should let margins be flexible but that's not visible on the spec. Can you confirm?

attachment 8410133 [details], attachment 8410134 [details] and attachment 840136 are missing margins for the 2nd area starting from the button (message button or mute/keypad/add call/speaker buttons or contact info respectively)
Flags: needinfo?(b.pmm)
Yes, you're right. It was a misunderstanding, sorry for that. I'm going to update them now and I will upload them again.

Thanks!
Flags: needinfo?(b.pmm)
Attachment #8410133 - Attachment is obsolete: true
Attachment #8410134 - Attachment is obsolete: true
Attachment #8410136 - Attachment is obsolete: true
Attachment #8410135 - Attachment is obsolete: true
Attachment #8410137 - Attachment is obsolete: true
Attachment #8410131 - Attachment is obsolete: true
Depends on: 991062
Depends on: 987061
Attached image Visual Spec: Expandable Areas. Dialer (obsolete) —
Depends on: 972833
Depends on: 995128
blocking-b2g: backlog → 2.0?
Reset the blocking-b2g flag to backlog.
We no longer mark feature works to be 2.0+ now.  
For COMMS team's committed feature, it blocks the meta bug comms_2.0.
NI? Stephany if there's question.
blocking-b2g: 2.0? → backlog
Flags: needinfo?(swilkes)
Attached file Assets. PNG. Dialer (obsolete) —
Attachment #8410138 - Attachment is obsolete: true
Attached file Assets. PNG. Dialer (obsolete) —
Attachment #8412441 - Attachment is obsolete: true
Depends on: 1002491
New spec for Dialer colors.
Attachment #8410970 - Attachment is obsolete: true
Attached file Assets. PNG. Dialer (obsolete) —
New colors updated according to the contrast ratio issue.
Attachment #8412538 - Attachment is obsolete: true
Attachment #8369913 - Attachment is obsolete: true
Attachment #8369914 - Attachment is obsolete: true
Attachment #8369916 - Attachment is obsolete: true
Attachment #8369917 - Attachment is obsolete: true
Attachment #8369921 - Attachment is obsolete: true
Attachment #8369924 - Attachment is obsolete: true
Attachment #8369927 - Attachment is obsolete: true
Hi Vicky, as requested by Anthony, would you be so kind to include the digit, letters and icons separation values in attachment 8413816 [details] , please? Thanks!
Flags: needinfo?(vpg)
Attachment #8369932 - Attachment is obsolete: true
Flags: needinfo?(vpg)
Attachment #8369934 - Attachment is obsolete: true
Attachment #8369935 - Attachment is obsolete: true
Attachment #8394809 - Attachment is obsolete: true
Attachment #8394810 - Attachment is obsolete: true
Attachment #8369928 - Attachment is obsolete: true
Attachment #8403318 - Attachment is obsolete: true
Attachment #8413816 - Attachment is obsolete: true
All mockups and specs have been updated with the new colors, please check them and ask for UI review on the changes.

Thanks!
Flags: needinfo?(pacorampas)
Flags: needinfo?(oteo)
Flags: needinfo?(noef)
Flags: needinfo?(gtorodelvalle)
Flags: needinfo?(anthony)
Flags: needinfo?(oteo)
QA Contact: echang
Flags: needinfo?(noef)
Flags: needinfo?(pacorampas)
Attached file Assets. PNG. Dialer (obsolete) —
New "paused call" icon added.
Attachment #8415081 - Attachment is obsolete: true
@Vicky: Roger that! ;-)
Flags: needinfo?(gtorodelvalle)
Attachment #8403318 - Attachment is obsolete: false
Blocks: 1007747
feature-b2g: --- → 2.0
Attached file Assets. PNG. Dialer (obsolete) —
Call screen proceed icon added.
Attachment #8417323 - Attachment is obsolete: true
Flags: needinfo?(swilkes)
Depends on: 1008821
Flags: needinfo?(anthony)
Target Milestone: 2.0 S2 (23may) → ---
No longer blocks: 1007747
Depends on: 1007747
Attached file Assets. PNG. Dialer (obsolete) —
Attachment #8419974 - Attachment is obsolete: true
Depends on: 1009464
No longer depends on: 1009464
Depends on: 1009596
Depends on: 1008432
Depends on: 1010129
Flags: in-moztrap?(nhirata.bugzilla)
No longer depends on: 1008432
Height specs of the upper panel have been updated.
Visual Spec for "Call status bar"
Attached file Assets. PNG. Dialer (obsolete) —
Icons for "call status bar" screen added.
Attachment #8421567 - Attachment is obsolete: true
Attachment #8415265 - Attachment is obsolete: true
Depends on: 1013330
Depends on: 1014495
Attached file Assets. PNG. Dialer (obsolete) —
Lockscreen left and right arrow icons added.
Attachment #8424768 - Attachment is obsolete: true
Visual refresh cases by Naoki
http://mzl.la/1rbDapc 

Regression test cases
http://mzl.la/1t1JHhN
Flags: in-moztrap?(nhirata.bugzilla) → in-moztrap+
Attached file Assets. PNG. Dialer
I have updated some of the sprites with 3 icon states as requested.
Thanks!
Attachment #8428657 - Attachment is obsolete: true
Depends on: 1016909
Depends on: 1018167
Depends on: 1018283
Depends on: 1019090
Who is working on this? It's not assigned and this is the last week of Sprint 3.
Flags: needinfo?(whuang)
^ Disregard - wrong bug! ^ :)
Flags: needinfo?(whuang)
No longer depends on: 977056
Depends on: 1019076
Clear feature-b2g flag for this is meta bug which may include bigger set rather than must-have feature works.
feature-b2g: 2.0 → ---
Depends on: 1020744
No longer depends on: 959011
No longer depends on: 1019090
Depends on: 1018495
Depends on: 1019546
Depends on: 1019426
Depends on: 1023032
Depends on: 1024373
This bug is verified but with a non-blocking bug:

In Conference call user can't see list with existing & non-existing contacts.
https://bugzilla.mozilla.org/show_bug.cgi?id=1025843
Depends on: 1029955
Depends on: 1029954
No longer depends on: 1015883
Closing this meta-bug since all the work is already done ;) Thanks!
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.