Closed Bug 921965 Opened 7 years ago Closed 5 years ago

[Keyboard][User Story] Text Selection (editable text)

Categories

(Firefox OS Graveyard :: Runtime, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.2+, tracking-b2g:backlog, ux-b2g:2.2)

RESOLVED FIXED
feature-b2g 2.2+
tracking-b2g backlog
ux-b2g 2.2

People

(Reporter: bhuang, Assigned: pchang)

References

Details

(Whiteboard: [FT:System-Platform])

Attachments

(2 files, 14 obsolete files)

3.16 MB, application/zip
Details
2.88 MB, application/pdf
Details
As a user, I want to be able to select text easily in order to perform actions on the selection (insert/delete/copy/cut, etc)
Whiteboard: [ucid:SystemPlatform26, ft:system-platform, 1.3:p2][NPOTB]
Update whiteboard tag to follow format [ucid:{id}, {release}:p{1,2}, ft:{team-id}]
Whiteboard: [ucid:SystemPlatform26, ft:system-platform, 1.3:p2][NPOTB] → [ucid:SystemPlatform26, 1.3:p2, ft:system-platform][NPOTB]
This user story will track text selection for editable text fields.
Summary: [Keyboard][User Story] Text Selection → [Keyboard][User Story] Text Selection (editable text)
Assignee: nobody → janjongboom
Whiteboard: [ucid:SystemPlatform26, 1.3:p2, ft:system-platform][NPOTB] → [ucid:SystemPlatform26, 1.4:p2, ft:system-platform][NPOTB]
No longer blocks: 1.3-system-platform
Target Milestone: --- → 1.3 C5/1.4 S5(28feb)
Need info Carrie to ask the UX spec. for text selection.
Flags: needinfo?(cawang)
Depends on: 955987
No longer depends on: 955987
The spec is same as the one attached in Bug 921964.
It includes both cursor movement and the text selection.
Thanks!
Flags: needinfo?(cawang)
Move this feature to v1.5.
Whiteboard: [ucid:SystemPlatform26, 1.4:p2, ft:system-platform][NPOTB] → [ucid:SystemPlatform26, 1.5, ft:system-platform][NPOTB]
Target Milestone: 1.3 C5/1.4 S5(28feb) → ---
No longer blocks: 1.4-system-platform
Assign to Steven Lee for filing the implementation bugs and link those to this user story bugs.
Assignee: janjongboom → slee
Depends on: 987040
No longer depend on bug 908495. The implementation will go for bug 987040.
No longer depends on: 908495
Depends on: 994447
Add latest text selection & copy/Paste UX spec.
Status: NEW → ASSIGNED
Depends on: 987718
Duplicate of this bug: 908495
Attachment #8364875 - Attachment is obsolete: true
Attachment #8412542 - Attachment description: [keyboard] v1.5 text selection and copy paste v0.3.pdf → [keyboard] v2.0 text selection and copy paste v0.3.pdf
Attachment #8412542 - Attachment filename: [keyboard] v1.5 text selection and copy paste v0.3.pdf → [keyboard] v2.0 text selection and copy paste v0.3.pdf
Attachment #8410054 - Attachment is obsolete: true
Whiteboard: [ucid:SystemPlatform26, 1.5, ft:system-platform][NPOTB] → [ucid:SystemPlatform26, 2.0, ft:system-platform][NPOTB]
feature-b2g: --- → 2.0
Hi Carol, for text selection, we need your help to provide 2 small icons, please refer to spec p.4, the bottom Notes part, there are Tilt cursor handles, one tilts to the right and one to the left. Thank you.
Flags: needinfo?(chuang)
Depends on: 1011365
Hi Carol, we also need your help to provide the bubble icons and layout spec for this. Thank you.
Flags: needinfo?(chuang)
Attached file text caret_visual spec_0520.zip (obsolete) —
Hi Morris,
The attachment is the visual spec for "Text Selection". 
Let me know if you have any question,thanks!
Attached file Text_Selection_Visual Spec_0523.zip (obsolete) —
Update Text_Selection_Visual Spec:Added Utility Bubble menu UI Spec.
Attachment #8425309 - Attachment is obsolete: true
Carol, thanks for the spec. @Alive, the layout spec and icons are out, please proceed the gaia work, thank you.
Flags: needinfo?(alive)
Flags: needinfo?(alive)
Blocks: 747798
Need functional test, move to 2.1
feature-b2g: 2.0 → 2.1
Hi Carol,
I need more UI information for text-selection, like dialog background color, item size, distance btw dialog and selected box... etc.
Attached file Text_Selection_Visual Spec_0603.zip (obsolete) —
text selection visual spec update: "Utility bubble menu" corner radius: 2px
Attachment #8427569 - Attachment is obsolete: true
Depends on: 1020725
The latest UX spec update.
p.14 Revising “Dismiss keyboard” description
p.15 Revising “A lot of text selected” rule
p.16 Revising the typo
Attachment #8412542 - Attachment is obsolete: true
Latest UX spec update:
p.14 Revising “Dismiss keyboard” description
p.15 Adding “Mode transition”
(for bug 1016184.)
Attachment #8435794 - Attachment is obsolete: true
Blocks: 1029446
No longer blocks: 1029446
Blocks: 1029465
Blocks: 1029437
No longer blocks: 747798
Whiteboard: [ucid:SystemPlatform26, 2.0, ft:system-platform][NPOTB] → [ucid:SystemPlatform26, 2.1, ft:system-platform][NPOTB]
No longer blocks: 2.0-system-platform
Here is the Updated UX spec for FxOS 2.1.
Mainly adding non-editable text selection.
Attachment #8439660 - Attachment is obsolete: true
Team, can you confirm that the initial selection and handles also work right to left? For example: if I tap on a letter, can I then select more text by dragging left (i.e. from the right)? The spec implies this should be possible but I want to confirm this will actually work for 2.1 planning. Thanks!
Flags: needinfo?(ofeng)
ux-b2g: --- → 2.1
Blocks: gaia-rtl
@Stephany, do you mean p.5 Single Handle in the spec?

@Bruce & CJ, can we do this in 2.1?
Flags: needinfo?(ofeng)
Flags: needinfo?(cku)
Flags: needinfo?(bhuang)
Hi Stephany, RTL selection is supported in current implementation, thanks.
Resolving as fixed based on comment #25. Thank you, Howie! It looked good on 2.0 but I wanted to check.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Clear ni since Howie had given answer.
Flags: needinfo?(cku)
Two dependent bugs are still in progress, reopen this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
QA Contact: edchen
Assignee: slee → pchang
QA Whiteboard: [COM=SystemPlatform]
Depends on: 1024930
Depends on: 1020798, 1020801, 1020802
feature-b2g: 2.1 → ---
Flags: needinfo?(bhuang)
Update text selection Visual spec
As offline discussion with George & Omega.
Spec Changed:
1. dialog box-shadow:0.2rem 0.2rem 0.4rem 0 rgba(0, 0, 0, 0.4)
2. divider color: #596466

thanks!
Attachment #8432951 - Attachment is obsolete: true
Updated UX spec.
Adding handle tilt rules.
Attachment #8448605 - Attachment is obsolete: true
Depends on: 1029943
Updated UX spec.
Removing 2 or more rows rule for handle tilt
Adding cases: scrolling, overscrolling, zooming, orientation changing, and scrolling iFrame
Attachment #8468355 - Attachment is obsolete: true
QA Whiteboard: [COM=SystemPlatform] → [COM=SystemPlatform][QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: [ucid:SystemPlatform26, 2.1, ft:system-platform][NPOTB] → [ucid:SystemPlatform26, 2.1, ft:system-platform][NPOTB][2.1-flame-test-run-1]
QA Whiteboard: [COM=SystemPlatform][QAnalyst-Triage?] → [COM=SystemPlatform]
Flags: needinfo?(dharris)
Whiteboard: [ucid:SystemPlatform26, 2.1, ft:system-platform][NPOTB][2.1-flame-test-run-1] → [ucid:SystemPlatform26, 2.1, ft:system-platform][NPOTB]
No longer blocks: CopyPasteLegacy
Blocks: keyboard-rtl
No longer blocks: gaia-rtl
ux-b2g: 2.1 → 2.2
Hi .. will this also work in content editable text sections? Many forums and other web sites and increasingly apps rely on rich text and thats provided via content editable, vs just the plain text you get in text area so if this bug is being fixed will it also work in these for rich text?
(In reply to James from comment #32)
> Hi .. will this also work in content editable text sections? Many forums and
> other web sites and increasingly apps rely on rich text and thats provided
> via content editable, vs just the plain text you get in text area so if this
> bug is being fixed will it also work in these for rich text?

Yes. It will work in both plain text and rich text.
Update UX spec for 2.2.
Attachment #8478886 - Attachment is obsolete: true
this is not related to RTL but it's 2.2 feature
No longer blocks: keyboard-rtl
feature-b2g: --- → 2.2+
Component: Gaia::Keyboard → Runtime
Whiteboard: [ucid:SystemPlatform26, 2.1, ft:system-platform][NPOTB] → [FT:System-Platform]
blocking-b2g: --- → backlog
QA Whiteboard: [COM=SystemPlatform] → [COM=SystemPlatform][textselection]
Status: REOPENED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → FIXED
UX spec update
Password Input: Allow only "Select All" and "Paste" in password input
Attachment #8521959 - Attachment is obsolete: true
QA Whiteboard: [COM=SystemPlatform][textselection] → [COM=SystemPlatform][COM=Text Selection]
blocking-b2g: backlog → ---
Hi,

Here is a simple feedback about the new cut/paste behavior.

I see from the spec in attachment 8548759 [details] that there is a behavior difference depending on when the user copied text (before/after 15 sec). As a user I find this confusing, and I'd rather always see the "paste" button.

However I understand this can be painful to always see this button so maybe we miss a second button to clear the clipboard.

NI UX about this feedback.
Flags: needinfo?(firefoxos-ux-bugzilla)
> However I understand this can be painful to always see this button so maybe
> we miss a second button to clear the clipboard.

Or a button to dismiss the copy & paste menu buttons?

NI UX for comment #37
Flags: needinfo?(tchen)
(In reply to Julien Wajsberg [:julienw] from comment #37)
> Hi,
> Here is a simple feedback about the new cut/paste behavior.

> I see from the spec in attachment 8548759 [details] that there is a behavior
> difference depending on when the user copied text (before/after 15 sec). As
> a user I find this confusing, and I'd rather always see the "paste" button.

Normally users need to "long press" to activate text selection. However, since copy usually followed by paste immediately(the intention is clear), we let users to paste text by single click in 15 seconds. 
If it exceeds 15 seconds, users would need to long press to activate text selection and paste the text. The reason is that after a period, it is more possible that they already forget the copied text and only want to switch the cursor by single click.

You can also find similar flow on Android. 

> However I understand this can be painful to always see this button so maybe
> we miss a second button to clear the clipboard.

I think it is complex to users, since we don't clear copied text on laptop or smartphones.
Flags: needinfo?(tchen)
Flags: needinfo?(firefoxos-ux-bugzilla)
Attach the latest spec from bug 1217757.
Attachment #8548759 - Attachment is obsolete: true
Attach the latest spec from bug 1263578.
Attachment #8739912 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.