Closed Bug 923548 Opened 8 years ago Closed 7 years ago

Australis: Sizing issues with completed download icon on OSX and Linux

Categories

(Firefox :: Theme, defect)

27 Branch
x86_64
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 29

People

(Reporter: anshin, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P2])

Attachments

(2 files)

There are various issues with the new icons on Linux.
The address bar slightly overlaps the back button (but not the forward button).
The downloads icon is missing the tip of the arrow when there are unchecked downloads (the icon is green).

Here's a screencast showcasing both: http://i.wonoes.com/z7whprjcg.gif
The star button also seems to have an issue where the star overlaps its menu button, if you hover the menu button and then move left over the star button.
Status: UNCONFIRMED → NEW
Depends on: 874674
Ever confirmed: true
Whiteboard: [Australis:P2][Australis:M?]
Summary: Issues with new icons on Linux. → Australis: Sizing issues with (borders of?) new icons on Linux.
Blocks: 874674
No longer depends on: 874674
Assignee: nobody → gijskruitbosch+bugs
Depends on: 925710
Bug 925710 has updated the back/fwd button stuff, that should be fixed now. I think the star button thing depends on bug 875479. I'll fix the downloads button here - it's also wrong on OS X.
OS: Linux → All
Summary: Australis: Sizing issues with (borders of?) new icons on Linux. → Australis: Sizing issues with completed download icon on OSX and Linux
Stephen, could we have an updated completed-download icon (download-glow.png) for Linux and OSX that's 18x18? (ie matches the toolbar.png sizes; so 36x36 on OS X retina)

(if I should redirect this request elsewhere, please let me know, and feel free to reassign to you / someone else who could get us icons)
Status: NEW → ASSIGNED
Flags: needinfo?(shorlander)
Duplicate of this bug: 926024
Note that we should probably also have such an icon in the size that'd match the panel... see bug 930984. Assigning to Stephen pending new assets.
Assignee: gijskruitbosch+bugs → shorlander
Duplicate of this bug: 933164
Blocks: 924050
Duplicate of this bug: 940592
Duplicate of this bug: 940641
Duplicate of this bug: 940595
Duplicate of this bug: 941737
Duplicate of this bug: 943731
Duplicate of this bug: 944459
Do you need the Download glyphs solo or in the toolbar.png sprites?
Flags: needinfo?(shorlander) → needinfo?
Assignee: shorlander → mmaslaney
Flags: needinfo?
(In reply to mmaslaney from comment #13)
> Do you need the Download glyphs solo or in the toolbar.png sprites?

They have always been solo before, so for simplicity, let's keep it like that. If we add them to the sprite, I'm afraid that at least on Windows/Linux (no hover styles), we'll need a new row just for that, which would be sadfaces.
Flags: needinfo?
Attached file Download-glow.zip
Contains the following:

• Download-glow - 18px OSX

• Download-glow - 36px OSX

• Download-glow - 18px Linux 

Based on Stephen's source files, toolbar icons for Linux are either 16px or 24px; providing the 18px as requested.
Flags: needinfo?
Taking to integrate these assets. :-)
Assignee: mmaslaney → gijskruitbosch+bugs
Patch with the new files, and the unused small version on linux removed.
Attachment #8347987 - Flags: review?(jaws)
Attachment #8347987 - Flags: review?(jaws) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/b7d469a149e9
Whiteboard: [Australis:P2][Australis:M?] → [Australis:P2][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/b7d469a149e9
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][fixed-in-fx-team] → [Australis:P2]
Target Milestone: --- → Firefox 29
Blocks: 953153
QA Contact: cornel.ionce
I was able to confirm the fix for this issue on the latest Aurora (Build ID: 20140309004003) and latest Nightly (Build ID: 20140309030204), using:
- Ubuntu 13.10 64-bit [1]
- Mac OS X 10.9.1 [2]

1. Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0
2. Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.