Closed Bug 92722 Opened 19 years ago Closed 18 years ago

Images on this page are fetched twice from server [if not yet in cache]

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME
Future

People

(Reporter: jrgmorrison, Assigned: pavlov)

References

()

Details

(Keywords: perf)

In the course of looking at the no-store fix by darin (last minute branch
checkin), I happened to notice the following glitch in the server logs. (Note:
this doesn't depend on the no-store fix in any way; that's just how I happened 
to notice this). 

If you have not previously visited this URL (i.e., you don't have this content 
cached), then when you go to the URL:
  http://cowtools.mcom.com/perf/content/base/www.yahoo.com/index.html
then you get this output in the access_log (edited for clarity and 78 columns)

[22:57:14] "GET .../www.yahoo.com/index.html HTTP/1.1" 200 14340
[22:57:15] "GET .../www.yahoo.com/res/m5v2.gif HTTP/1.1" 200 5776
[22:57:15] "GET .../www.yahoo.com/res/hp_auctions1.gif HTTP/1.1" 200 4706
[22:57:15] "GET .../www.yahoo.com/res/m5v2.gif HTTP/1.1" 200 5776
[22:57:15] "GET .../www.yahoo.com/res/hp_auctions1.gif HTTP/1.1" 200 4706

So, there are two fetches of the two images in that page. Hmmm.

I haven't tried this on Mac and Linux (noticed it on win32 and thought I 
would just file it before I forgot).
John this looks like Bug 91738 - " mozilla geting file twice"
And both this bug and bug 91738 are likely what's causing bug 76565...
Keywords: perf
This could be a dupe, but you're not reloading, are you?
No, this is not on a reload. To be specific, delete Cache, cookies.txt, and
history.dat, start/shutdown mozilla a couple of times, and then start mozilla.

Enter http://cowtools.mcom.com/perf/content/base/www.yahoo.com/index.html
in the urlbar and hit Enter. Mozilla will GET index.html, and then each of 
the two images _twice_ (200 OK on all GET's).




*** Bug 101165 has been marked as a duplicate of this bug. ***
Hey, isn't bug 103432 a dup of this as well?
From my bug report, I see this on http://news.bbc.co.uk/
Thought I'd mention the URL here, since this bug's URL is internal to NSCP.
Happening on Linux for me, so marking OS All.
OS: Windows 2000 → All
Hardware: PC → All
fixed
Status: NEW → RESOLVED
Closed: 18 years ago
Depends on: 108161
Resolution: --- → FIXED
Target Milestone: --- → mozilla0.9.8
Hey jrgm@netscape.com, would you mind verifying this?  Thanks, Terri
actually not fixed. Still fetches each image of those two images twice (and now 
doesn't fire onload [bug 120041]). current trunk at 4pm/Jan15 win2k.

Steps to reproduce and results (from above):

> To be specific, delete Cache, cookies.txt, and history.dat, start/shutdown 
> mozilla a couple of times, and then start mozilla.
> 
> Enter http://cowtools.mcom.com/perf/content/base/www.yahoo.com/index.html
> in the urlbar and hit Enter. Mozilla will GET index.html, and then each of 
> the two images _twice_ (200 OK on all GET's).


Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Similar thing on http://news.bbc.co.uk/ which I used to have a problem with too.

Page now never finished loading (it looks done, but status bar still says it's
retrieving stuff), which is like your onlond issue, plus I notice in network
trace it requests things like "v.gif?" (with the question mark) though view
source didn't show a v.gif or v.gif? in the source. When I went to investigate
further, I got caught up filing a bunch of save bugs.
*** Bug 104827 has been marked as a duplicate of this bug. ***
Target Milestone: mozilla0.9.8 → mozilla0.9.9
moving this to future.  The problem described here is due to the page getting 
reframed.  This ends up causing images to get destroyed and refetched.  I'm 
cc'ing waterson and marc incase they have any ideas.
Target Milestone: mozilla0.9.9 → Future
In bug 133217 Mozilla (build 2002040503) is loading every image (for the
rollover) again from network.
Depends on: 133217
No longer depends on: 133217
Component: ImageLib → Image: Layout
It also happens when the image url is typed in directly:
for http://www.google.com/images/logo.gif on a windows 2000 PC with Mozilla
build 2002051006, this image is downloaded twice.
A second request is sent from the browser right after the response to the first
one has been fully received.
I repeated it with other image URLS too.
Keywords: mozilla1.0mozilla1.1
Who is willing to take this - deserves really some attention.
Actually, for the specific case for which this bug was filed, the yahoo 
example, this is no longer observable in a current trunk build. WFM.
Status: REOPENED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → WORKSFORME
regarding comment #15 we should file a new bug if this problem is still there.
Comment 15 is (or was) a known problem with a bug filed somewhere.
Product: Core → Core Graveyard
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.