Closed Bug 944523 Opened 8 years ago Closed 7 years ago

Add in historic in-app purchases page

Categories

(Marketplace Graveyard :: Consumer Pages, defect, P3)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: andy+bugzilla, Unassigned)

References

Details

This page allows a user to see the list of in-app purchases that they have done and then click to get a receipt (using bug 944522) installed. This will need to use the API created in bug 757226.

Currently the "My Apps" page just shows purchased or installed apps. There could be multiple transactions for each app.
Depends on: 757226
Keywords: uiwanted
Whiteboard: [ux-wanted]
Setting priority, will ping teams involved when are ready to go on this.
Priority: -- → P5
Clicking to install a receipt is likely not possible because it has to be the app installing the receipt, not the marketplace. Being able to list all the in-app transactions is still of value though imho.
Summary: Add in in-app purchases page → Add in historic in-app purchases page
Assignee: nobody → asantos
Priority: P5 → P3
Duplicate of this bug: 1023403
This is going to be tricky because only the app that installed the original receipt can restore a new one. Marketplace will not have permission to re-install receipts. 

We may need to expose this as an API call for third party apps to access through a method of fxpay.js.
Assignee: asantos → nobody
Keywords: uiwanted
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
This was wontfix'ed because of the app origin problem with re-installing receipts. We still want a feature like this though. See bug 1045228
You need to log in before you can comment on or make changes to this bug.