Closed Bug 951208 Opened 8 years ago Closed 7 years ago

[an] Test failure "A new window has been opened" in /testPrivateBrowsing/testOpenClosePBKeyboardShortcut.js

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect)

x86
macOS
defect
Not set
normal

Tracking

(firefox27 affected, firefox28 fixed)

RESOLVED FIXED
Tracking Status
firefox27 --- affected
firefox28 --- fixed

People

(Reporter: mihaelav, Unassigned)

References

()

Details

Happened on all Mac OS X versions (10.6.8, 10.7.5, 10.8.5, 10.9) with Firefox 28.0a2 (build 20131217004003) with "an" locale:
http://mozmill-crowd.blargon7.com/#/functional/report/ca1869364f98dd0de71202e01ed4cc69

I reproduced it locally, but I couldn't reproduce with other locale(e.g. xh).
Not reproducible with Firefox 27.0 beta 2 (build 20131216183647)
If this is a localisation problem, file a bug under that specific locale and set it as a blocker for this one.

It would probably help to also find out if there is conflict in a localisation file, and point that out.
Depends on: 951579
Reproduced the issue manually: Command+Shift+P keyboard shortcut enters browser in full screen mode instead of opening a new private browsing window
Blocks: 951212
Blocks: 951219
Blocks: 951222
Blocks: 951225
Blocks: 951226
Blocks: 951227
We have to make sure that this test is correctly stopping the private browsing mode if it is still active because the shortcut doesn't work. How many other private browsing tests are affected by this? We should file a new bug for this.
(In reply to Mihaela Velimiroviciu [QA] (:mihaelav) from comment #5)
> However, there are several failures in the /testAccessKeys/test1.js test
> from the l10n testrun:
> http://mozmill-crowd.blargon7.com/#/l10n/report/
> 65853485b33d6c38cddef8e3363ab768

None of those are blockers but should be filed as a separate bug like bug 760772. Please cc me when you file it.
As localizer, I changed the conflicting access key in http://hg.mozilla.org/releases/l10n/mozilla-aurora/an/rev/a1689f02eb22
Thank you Daniel! Mihaela, can you please re-run the tests with the latest Aurora build for an? Thanks.
Flags: needinfo?(mihaela.velimiroviciu)
I run the functional tests across al Mac OS X versions (10.6.8, 10.7.5, 10.8.5 and 10.9) and the failure doesn't appear anymore on Aurora builds:
http://mozmill-crowd.blargon7.com/#/functional/reports?branch=28.0&platform=Mac&from=2014-01-06&to=2014-01-08
Flags: needinfo?(mihaela.velimiroviciu)
That's good to hear. Daniel, do we also need this fix for beta?
Yes, I think that beta uses the old localization files in which this isn't fixed
Given that beta will be merged to production today and the first RCs will be produced, we will have to wait for the changes on aurora to get merged into beta. So it will be fixed in the 28 release.

Daniel, I think that we can close this bug now?
Assignee: nobody → entaltoaragon
Status: NEW → ASSIGNED
Oh wait. This is the wrong bug we comment on. The actual fix for your localization is bug 951579.
Assignee: entaltoaragon → nobody
Status: ASSIGNED → NEW
The dependency is fixed and the fix landed long time ago. This bug should have been marked as fixed.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.