Add ability to collapse entire sections of articles

RESOLVED DUPLICATE of bug 1158595

Status

support.mozilla.org
Knowledge Base Software
P3
normal
RESOLVED DUPLICATE of bug 1158595
4 years ago
3 years ago

People

(Reporter: atopal, Unassigned)

Tracking

unspecified
2014Q2

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=wiki p= s=2013.backlog)

(Reporter)

Description

4 years ago
During the last platform meeting we decided to add collapsible sections to the KB. A previous test using optimizely showed that the helpfulness stayed the same while the number of votes went up, further proving that people also use the voting mechanism to rate whether they landed on the right article.

There are at least two options for collapsing sections, not mutually exclusive:
1. Add a tag, like <collapse> that we can wrap sections in that should be collapsed by default

2. Collapse everything beyond the first paragraph by default.

In our Optimizely testing we used the second approach. The first approach would give us more flexibility, but I'm assuming would be harder to implement.

The goal is to provide an uncluttered view for the vast majority of users and thus reducing cognitive load, while providing more information on demand for those whose needs are not satisfied with the default content.

Note: If we go with option 2, we should also get rid of the TOC.

Michael, any comments on the preferred route forward?

Comment 1

4 years ago
(In reply to Kadir Topal [:atopal] from comment #0) 
> 2. Collapse everything beyond the first paragraph by default.

I think it was - collapse all the H1s and get rid of the TOC. Here's a mockup that I made http://people.mozilla.org/~mverdi/mockups/article-layout1/

(In reply to Kadir Topal [:atopal] from comment #0)
> 
> Michael, any comments on the preferred route forward?

I'm inclined to say option 1 - the tag - would be preferred. Option 2 would effect all articles at once and some may need to be rewritten a bit. Option 1 let's us implement as time allows along with giving us greater control.
After looking through the 50 most visited articles, I'm leaning towards option 2. Even if we were to choose which sections we'd collapse by default, I'd collapse all the H1s anyway. It might throw people off to see different sections collapsed for each article. I think consistency might be a better experience.

Roughly 25-30% of the top 50 articles would need some rewriting if we went with option 2.
(Reporter)

Comment 3

4 years ago
It looks like this might need some discussion still. Is this something we want to talk about at the platform meeting or maybe a separate discussion?
Q1 is over. Bring it on, Q2!
Target Milestone: 2014Q1 → 2014Q2

Comment 5

3 years ago
Also related:
Bug 1079413
Bug 1141677
Bug 1141669
Bug 1142285

Comment 6

3 years ago
(In reply to Kadir Topal [:atopal] from comment #0)
> There are at least two options for collapsing sections, not mutually
> exclusive:
> 1. Add a tag, like <collapse> that we can wrap sections in that should be
> collapsed by default
> 
> 2. Collapse everything beyond the first paragraph by default.

Can this bug be closed?  Option 2 was implemented for most KB articles.  See bug 1141677 comment 3
Yes, this was done in bug 1158595.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1158595
You need to log in before you can comment on or make changes to this bug.