Closed Bug 970020 Opened 6 years ago Closed 6 years ago

Australis: Layout glitch on LocationBar/SearchBar and no longer resize them by mouse dragging

Categories

(Firefox :: Theme, defect)

29 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 + verified
firefox30 + verified

People

(Reporter: alice0775, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Australis:P2])

Attachments

(2 files)

Attached image screenshot
Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/cafe909f7e07
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140208030207

Steps To Reproduce:
1. Drag resizer(LocationBar/SearchBar) by mouse to the left
   ---- Layout glitch happen
2. Attempt to drag the resizer by mouse

Actual Results:
Layout glitch happen
No longer resize them

Expected Results:
No glitch
Should be resizable
Blocks: 965772
Component: Untriaged → Toolbars and Customization
Component: Toolbars and Customization → Location Bar
FWIW, this also happens when you reduce browser window's width to a certain point.
Bug 972140 covers at least one of the small-window problems.

I can't reproduce this on OS X... Windows-only?
Whiteboard: [Australis:P2]
Assignee: nobody → dao
Attached patch patchSplinter Review
Another stray min-width that's not useful anymore since urlbar-container has a min-width.
Attachment #8378717 - Flags: review?(jaws)
Component: Location Bar → Theme
https://hg.mozilla.org/mozilla-central/rev/1d91384b8777
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Comment on attachment 8378717 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): various Australis changes
User impact if declined: as described in comment 0
Testing completed (on m-c, etc.): landed on m-ac
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8378717 - Flags: approval-mozilla-aurora?
Attachment #8378717 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Contact: cornel.ionce
Reproduced with Nightly from 2014-02-08.

Verified as fixed with latest Aurora (Build ID:20140314004001) and Nightly (Build ID: 20140314030202):
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.