Closed Bug 1368063 (yuv444) Opened 5 years ago Closed 4 years ago

Video with YUV444 chroma subsampling can't be played back

Categories

(Core :: Audio/Video: Playback, defect, P3)

Unspecified
All
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ehsan.akhgari, Unassigned)

References

Details

(Keywords: parity-chrome)

See this link: https://bugzilla.mozilla.org/attachment.cgi?id=8871594

web console says:

Media resource https://bug1367970.bmoattachments.org/attachment.cgi?id=8871594 could not be decoded, error: Error Code: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005)
Details: mozilla::SupportChecker::AddMediaFormatChecker(const mozilla::TrackInfo&)::<lambda()>: Decoder may not have the capability to handle the requested video format with YUV444 chroma subsampling.
We don't support YUV444 at this stage. 

If h264 probably never as we rely on systems decoders.
Summary: Video can't be played back (on Linux at least) → Video with YUV444 chroma subsampling can't be played back (on Linux at least)
Component: Audio/Video → Audio/Video: Playback
Doesn't play on Safari.
Priority: -- → P3
YUV444 chroma subsampling seems to be some sort of default when making videos with ffmpeg -- I made one with "ffmpeg -i img%2d.png -filter:v "setpts=6.0*PTS" output.mp4" and firefox can't play it. I'm not finding much online about how to turn off this YUV444 thing that firefox can't handle. 

Chromium and Python's QtWebEngine can play the video; I'm not sure what "systems decoders" means in this context but I clearly have the libraries needed both to encode and decode this video.
While ffmpeg can decode them, neither windows WMF decoder nor Apple's one can.
For coonsistency sake, we've disabled them on Linux too.

If you want to play yuv444 video, prefer a free codec such as vp9 for which we can provide decoder.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1468617
When attempting to read such a file, maybe it would be nice to write on the screen, or in the console, that the format is voluntarily unsupported/disabled (and will never be supported)? Currently the message on screen says the file is corrupt.

That would help people like me to avoid loosing time thinking there is an issue in Firefox, and start looking on the ffmpeg side.

I think a better message would also help regarding people perception of Firefox, because that video format works fine on Chrome.
See Also: → 1469193
See Also: → 1469195

(In reply to Akkana Peck from comment #3)

YUV444 chroma subsampling seems to be some sort of default when making
videos with ffmpeg -- I made one with "ffmpeg -i img%2d.png -filter:v
"setpts=6.0*PTS" output.mp4" and firefox can't play it. I'm not finding much
online about how to turn off this YUV444 thing that firefox can't handle.

For future reference for people who stumble upon this Firefox bug, the solution is to add "-pix_fmt yuv420p" in your ffmpeg command line.

By the way, it is a shame that Firefox shows nothing for yuv444 videos. It makes it look like a bug. It'd be nice if instead it showed a message explaining the problem, "Proprietary video format. Firefox will not fix. Please encode video using an open standard (VP9). FFmpeg users may create mp4's using -pix_fmt yuv420p."

Amusingly, one site suggests, after detecting this failure,using the Brave browser.

Duplicate of this bug: 1563667
Duplicate of this bug: 1574042
Duplicate of this bug: 1588344

Setting an alias on this since it comes up with some regularity and I keep needing to find the bug.

Alias: yuv444
Duplicate of this bug: 1596231
Duplicate of this bug: 1638561
Duplicate of this bug: 1645543

Chrome on Win10 and Linux is able to play it.
Chromium on Linux is able to play it.
Chromium on Win10 won't load the video.
Old Edge: Decode Error
Edgium (Chrome repeatedly freezes on Edge's download page and shows a popup asking to close the page, I had to use my regular Nightly to successfully download it: But Edge installer itself doesn't download more than ~20%): uninstallable, untestable 3:)

Keywords: parity-chrome
OS: Unspecified → All
Summary: Video with YUV444 chroma subsampling can't be played back (on Linux at least) → Video with YUV444 chroma subsampling can't be played back
Duplicate of this bug: 1678318
Duplicate of this bug: 1689310
Duplicate of this bug: 1698350
See Also: → 1698618
Duplicate of this bug: 1705476
You need to log in before you can comment on or make changes to this bug.