Closed Bug 1007840 Opened 8 years ago Closed 6 years ago

[tracker] make thank you page for sad feedback helpful (phase 1)

Categories

(Input Graveyard :: Submission, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED
2015q2

People

(Reporter: willkg, Assigned: willkg)

References

Details

It's pretty common for people to be leaving feedback about problems they're having. We should see if we can help users by showing relevant SUMO articles.

This would require the following:

1. adding an API endpoint in SUMO that takes a blob of text and checks the kb for relevant articles

2. change the thank you page so that for sad feedback in English (we'll do this English-only for now) with descriptions that are longer than X words, we ping SUMO for relevant articles and display them to the user
Note that when we do kb links, we should add whatever tracking information we need so that we can measure whether users click on these links or not.

To clarify, we're going to prototype this for en-US locale-using users only. Depending on what we discover, we can nix this or roll it out to other locales, too.
Oh, and we shouldn't show SUMO kb articles for Thank You pages displayed for throttled users.
You might be able to use SUMO search as is, passing format=json. For example:

https://support.mozilla.org/en-US/search?q=flash+crashes&w=1&product=firefox&format=json

q=<text to search for>
w=1 (only returns KB results)
product=<product slug>
format=json

There are other parameters you are well aware of, but those might be the only ones you need here.
I'll try that, but I'm pretty sure I'll need to add a stop words list and need to do an MLT to get useful results.
Bumping this to 2014q3.
Whiteboard: u=user c=feedback p= s=input.2014q2 → u=user c=feedback p= s=input.2014q3
Whiteboard: u=user c=feedback p= s=input.2014q3 → u=user c=feedback p= s=input.2014q4
Mental note to instrument the links so we know whether people are actually clicking on them. I don't know if I mentioned that already, but can't look at the comments now.
I'd be really great to get something done on this this quarter. Making it a P2.
Priority: -- → P2
I'm going to block this on bug #1081997 to see if that API endpoint provides an easier implementation here.
Depends on: 1081997
Oops! This should block on bug #1083405 because that's the bug about the API endpoint that's interesting.
Depends on: 1083405
No longer depends on: 1081997
Duplicate of this bug: 1088506
Talked with Lukas and she mentioned having a "None of these help me" thing which would send the user over to SUMO. I think that sounds like a good idea.
Love it. Maybe it could dump them right into the Ask a Question flow. Since we'll be grabbing about:support data soon that would be good to carry over as well.
+1 for passing the user off to the SUMO AAQ flow.

We won't have to pass along the about:support data since in the glorious future, SUMO will be able to grab it themselves.
One thing I just found out is that some locales don't do support on SUMO and instead have other forums. Figured I'd jot that down here so we have it in the requirements when I write up the project plan.

For now, I think we should ignore this since we're going to do all our prototyping/testing with en-US. Whatever we roll out for all locales will have to be aware that some support isn't done on SUMO and will have to figure out what to do about that.
Pushing this out to next quarter.

Right now this requires the following:

1. a project plan broken down into a series of experiments

2. turn this bug into a tracker bug for that project

3. a breakdown of bugs for implementing the first experiment which would all block this tracker bug


Assigning it to myself and doing item 2 now.
Assignee: nobody → willkg
Summary: show related kb articles for sad feedback → [tracker] make thank you page for sad feedback helpful
Whiteboard: u=user c=feedback p= s=input.2014q4
Target Milestone: --- → 2015q1
Depends on: 1116523
Depends on: 1116838
Depends on: 1116848
Depends on: 1124412
Depends on: 1129615
No longer blocks: 1133769
Depends on: 1133769
No longer blocks: 1133771
Depends on: 1133771
No longer blocks: 1133774
Depends on: 1133774
One thing I was thinking about was whether to do a SUMO search for the feedback or whether to pull the top 100 SUMO kb documents and do a search on Input for keywords. The kb documents don't really have keywords. so that's probably not an option unless we want to figure out keywords somehow. But that probably won't work in non-English languages without lots of extra work.
Depends on: 1167241
Depends on: 1169261
Depends on: 1173430
Summary: [tracker] make thank you page for sad feedback helpful → [tracker] make thank you page for sad feedback helpful (phase 1)
Target Milestone: 2015q1 → 2015q2
Depends on: 1173763
Last bug is closed, so I'm closing this out.

Yay!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Product: Input → Input Graveyard
You need to log in before you can comment on or make changes to this bug.