bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Double clicking to add an event in month view

RESOLVED FIXED in Firefox OS v2.1S

Status

Firefox OS
Gaia::Calendar
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: evanxd, Assigned: millermedeiros)

Tracking

({polish})

unspecified
2.2 S5 (6feb)
x86
Mac OS X
polish
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1S+, b2g-v2.1 affected, b2g-v2.1S verified, b2g-v2.2 verified, b2g-master verified)

Details

User Story

Double tapping on a day in month view will go to the add new event page.

Attachments

(4 attachments)

Comment hidden (empty)
(Reporter)

Updated

4 years ago
Depends on: 1021445
(Assignee)

Updated

4 years ago
Blocks: 1009249
(Assignee)

Updated

4 years ago
Duplicate of this bug: 999955
(Assignee)

Updated

4 years ago
See Also: → bug 999959
(Assignee)

Updated

4 years ago
See Also: → bug 1094717
(Assignee)

Comment 2

4 years ago
Created attachment 8518286 [details]
[2.1 Calendar] Double Click to Add Event_v1.0.pdf
(Assignee)

Updated

4 years ago
User Story: (updated)
Depends on: 1084014
(Assignee)

Updated

4 years ago
Assignee: nobody → mmedeiros
Status: NEW → ASSIGNED
Whiteboard: polish
(Assignee)

Updated

4 years ago
See Also: → bug 1107432
(Assignee)

Updated

4 years ago
Depends on: 846940
(Assignee)

Updated

4 years ago
See Also: → bug 1118853
(Assignee)

Comment 3

4 years ago
also good to note that if you tap quickly on the day "15th" after tapping on "14th" it considers it as a double tap on the "14th".
(Assignee)

Updated

4 years ago
Keywords: polish
Whiteboard: polish
(Assignee)

Updated

4 years ago
Depends on: 1051752
(Assignee)

Comment 4

4 years ago
Created attachment 8549965 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27440
Attachment #8549965 - Flags: review?(gaye)
Comment on attachment 8549965 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27440

LGTM. Just had one question on GH about resetting _lastTarget after sending the user to the add event form.
Attachment #8549965 - Flags: review?(gaye) → review+
(Assignee)

Updated

4 years ago
Blocks: 1021445
No longer depends on: 1021445
(Assignee)

Comment 6

4 years ago
landed on master: https://github.com/mozilla-b2g/gaia/commit/eacf4416a6760bd78a0314b0da78e4bc1d091cbe
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

4 years ago
Comment on attachment 8549965 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27440

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: confusing UX since on other views user can add a new event just by double clicking and it might also cause 2 tabs to be highlighted (Bug 1021445) 
[Testing completed]: manual + marionette
[Risk to taking this patch] (and alternatives if risky): low risk
[String changes made]: none
Attachment #8549965 - Flags: approval-gaia-v2.2?
(Assignee)

Updated

4 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → fixed

Updated

4 years ago
Attachment #8549965 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Depends on: 1130865
v2.2: https://github.com/mozilla-b2g/gaia/commit/6146c3058300a2cd006e696f70dd6b55f1d508b1
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S5 (6feb)
(Assignee)

Updated

3 years ago
See Also: → bug 1153780
Hi Vincent, let's take this for 2.1S. thanks.
blocking-b2g: --- → 2.1S+
Flags: needinfo?(vliu)

Comment 10

3 years ago
(In reply to Steven Yang [:styang] from comment #9)
> Hi Vincent, let's take this for 2.1S. thanks.

It seems that the code conflicts happens when I tried to merge it into v2.1s. Could you please attach a patch for v2.1s? Thanks
Flags: needinfo?(mmedeiros)
Created attachment 8601662 [details] [review]
[gaia] millermedeiros:1037351-2.1S > mozilla-b2g:v2.1s
(Assignee)

Comment 12

3 years ago
Comment on attachment 8601662 [details] [review]
[gaia] millermedeiros:1037351-2.1S > mozilla-b2g:v2.1s

also included the commit for Bug 846940 because it is a dependency; logic is the same as what we have on master, only difference is that v2.1 was before we did the modularization refactor.
Flags: needinfo?(mmedeiros)
Attachment #8601662 - Flags: review?(gaye)
Attachment #8601662 - Flags: review?(gaye) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
There was an error creating the taskgraph, please try again. If the issue persists please contact someone in #taskcluster.
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Flags: needinfo?(vliu)
(Assignee)

Updated

3 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.1S: --- → fixed
Duplicate of this bug: 1153780
This bug has been verified as pass on latest build of Flame v2.2&3.0 & Nexus5 v2.2&3.0 and v2.1s.

See attachment: verified_v2.2&3.0.mp4
Reproduce rate: 0/5

STR:
1.Launch Calendar.
2.Double click to add an event in month view.
3.Tap "X" icon to exit adding an event.
**Device backs to month view normally and only shows one highlight blue line under "Month". 


----------------------------------------------------------------------------------
Device: v2.1s build(Pass)
Build ID               20150507001201
Gaia Revision          e4c6fee5a08daddf2d9dc90be7c1516e0f371f9d
Gaia Date              2015-05-06 21:48:08
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/6b61a152c89e
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015

Device: Flame 2.2 build(Pass)
Build ID               20150507002500
Gaia Revision          83a63e0e6fcc22c6a74b06ef77b88d5049719cad
Gaia Date              2015-05-07 00:17:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/118ddfc76b60
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150507.041847
Firmware Date          Thu May  7 04:18:59 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Pass)
Build ID               20150507160204
Gaia Revision          bc5bfa18f795919b56b952bbf3637c235d0e13dc
Gaia Date              2015-05-07 13:18:34
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5e02da1141d2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150507.193314
Firmware Date          Thu May  7 19:33:24 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v2.2 build (Pass)
Build ID               20150507162502
Gaia Revision          fa88af3a8e175be6a35ddd3e88b4446976027894
Gaia Date              2015-05-07 22:06:25
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/006e0cf17e6f
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150507.194838
Firmware Date          Thu May  7 19:48:53 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 v3.0 build (Pass)
Build ID               20150507160204
Gaia Revision          bc5bfa18f795919b56b952bbf3637c235d0e13dc
Gaia Date              2015-05-07 13:18:34
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5e02da1141d2
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150507.192329
Firmware Date          Thu May  7 19:23:43 EDT 2015
Bootloader             HHZ12f
status-b2g-v2.1S: fixed → verified
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Created attachment 8603140 [details]
verified_v2.2&3.0.mp4
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.