Closed Bug 1038635 Opened 6 years ago Closed 6 years ago

zoom doesn't work in the email composer

Categories

(Core :: DOM: Editor, defect, major)

defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla33
Tracking Status
firefox32 --- fixed
firefox33 --- fixed
firefox-esr31 --- fixed

People

(Reporter: msucan, Assigned: mkmelin)

References

Details

(Keywords: access, regression)

Attachments

(1 file)

Starting with Thunderbird 30 (IIRc) zoom fails to work in the email composition window. This is making it hard for me to write emails.

I would really appreciate a fix.
Keywords: regression
Confirming as a bug in TB31 beta 20140704014635

STR

1 compose (HTML) msg, type "Hello world"
2a Press Ctrl++ or Ctrl+- or Ctrl+0
2b Alternatively, use menu: View > Zoom > Zoom in/out/reset

Actual result

2a) and 2b) nothing (zoom does not change)

Expected result

zoom should change accordingly
Having no composition zoom at all is a major accessability bug which should block release of TB31.
Blocks: TB31found
Severity: normal → major
OS: Linux → All
Hardware: x86_64 → All
good: 2013-12-31
broken: 2014-01-22
(In reply to Magnus Melin from comment #3)
> good: 2013-12-31
> broken: 2014-01-22

Could it be the landing of bug 691614 ?

This was fixed for SeaMonkey in bug 965057 with changeset http://hg.mozilla.org/comm-central/rev/efa3650fd3b7
Indeed, this is from bug 691614. Thx Ian!
Blocks: 691614
Attached patch proposed fixSplinter Review
Add needed attributes to editor.xml
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #8457927 - Flags: review?(neil)
Comment on attachment 8457927 [details] [diff] [review]
proposed fix

I had to add Zoom support to composer to test this out ;-)
Attachment #8457927 - Flags: review?(neil) → review+
(In reply to neil@parkwaycc.co.uk from comment #7)
> Comment on attachment 8457927 [details] [diff] [review]
> proposed fix
> 
> I had to add Zoom support to composer to test this out ;-)

Is that another patch somewhere (in bug 233513) ? ;-)
https://hg.mozilla.org/integration/mozilla-inbound/rev/c1ddceb19abc
Target Milestone: --- → Thunderbird 33.0
https://hg.mozilla.org/mozilla-central/rev/c1ddceb19abc
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Thank you very much for the fix. Can this patch be backported to aurora and beta? Pretty please. :)
Flags: needinfo?(mkmelin+mozilla)
(In reply to Mihai Sucan [:msucan] from comment #11)
> Thank you very much for the fix. Can this patch be backported to aurora and
> beta? Pretty please. :)

+1, see my comment 2:
> Having no composition zoom at all is a major accessability bug which should
> block release of TB31.
Comment on attachment 8457927 [details] [diff] [review]
proposed fix

Approval Request Comment
[Feature/regressing bug #]: 691614
[User impact if declined]: can't zoom in thunderbird compose window. The same goes for any <editor> element where zooming is used. Our next general release is Thunderbird 38 so waiting until then would leave compose zooming broken for a long time, causing serious problems for people with disabilities. Therefore it is needed for esr31.
[Describe test coverage new/current, TBPL]: tested on trunk
[Risks and why]: low risk, it's just adding missing attributes that were added in bug 691614 
[String/UUID change made/needed]: none
Attachment #8457927 - Flags: approval-mozilla-esr31?
Attachment #8457927 - Flags: approval-mozilla-beta?
Attachment #8457927 - Flags: approval-mozilla-aurora?
Flags: needinfo?(mkmelin+mozilla)
Duplicate of this bug: 1042852
Comment on attachment 8457927 [details] [diff] [review]
proposed fix

Is it possible to test that on Firefox?
Attachment #8457927 - Flags: approval-mozilla-esr31?
Attachment #8457927 - Flags: approval-mozilla-esr31+
Attachment #8457927 - Flags: approval-mozilla-beta?
Attachment #8457927 - Flags: approval-mozilla-beta+
Attachment #8457927 - Flags: approval-mozilla-aurora?
Attachment #8457927 - Flags: approval-mozilla-aurora+
Flags: needinfo?(mkmelin+mozilla)
I don't think it's easily testable in firefox, that's probably why it went unnoticed for quote some time.
Flags: needinfo?(mkmelin+mozilla)
Keywords: checkin-needed
Whiteboard: [checkin-needed: aurora, beta, esr31]
Changing this to a core component since the fix wasn't specific to c-c (and it makes uplift tracking a lot easier).
Component: Composition → Editor
Product: MailNews Core → Core
Target Milestone: Thunderbird 33.0 → mozilla33
Version: 31 → Trunk
Comment on attachment 8457927 [details] [diff] [review]
proposed fix

This landed on trunk when it was still 33, so not sure why this is being marked as needing landing on Aurora...
Attachment #8457927 - Flags: approval-mozilla-aurora+
Keywords: checkin-needed
Whiteboard: [checkin-needed: aurora, beta, esr31] → [checkin-needed: beta, esr31]
Duplicate of this bug: 1042505
Duplicate of this bug: 1047331
Duplicate of this bug: 1045578
So... ESR users are stuck for a full year with a broken ZOOM in compose...?

That really sucks...
Scratch  that... no more ESR, but Thunderbird won't be updated until the next Firefox ESR relase for a year, so basically the same thing...

:(
No, this got backported to the esr branch, so the next security update will fix it, due in what, 4 weeks.
<whew>


Thanks... I was envisioning having to downgrade everyone back to 24.7 and stay there until the next release.

I really like most everything else in the new 31, so this is a relief...

Thanks!
Duplicate of this bug: 1059514
You need to log in before you can comment on or make changes to this bug.